ID do artigo: 190059 - Última revisão: quinta-feira, 28 de junho de 2001 - Revisão: 1.0

PROBLEMA: Falha do Certificate Server iniciar após a instalação autônoma

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante: Este artigo contém informações sobre a edição do Registro. Antes de editar o registro, verifique se que você sabe como restaurá-lo se ocorrer um problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurando o registro" no Regedit.exe ou o tópico da Ajuda "Restaurando uma chave do Registro" no Regedt32.exe.
Expandir tudo | Recolher tudo

Sintomas

Após uma instalação autônoma do Windows NT 4.0 Option Pack, incluindo o Certificate Server versão 1.0, o serviço de autoridade de certificação Falha ao iniciar. A seguinte entrada log de eventos do aplicativo é gerada:
Fonte: CertSvc
IDENTIFICAÇÃO de evento: 17
Descrição: "O servidor de certificados não iniciados: não é possível inicializar a conexão de banco de dados da autoridade de certificação COMPUTERNAME. O código de erro é 0xffffffff."
Aviso: Usar o Editor do Registro incorretamente pode causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que problemas resultantes do uso incorreto do Editor do Registro possam ser resolvidos. Use o Editor do registro por sua própria conta e risco.

Para obter informações sobre como editar o registro, consulte o tópico da Ajuda "Alterando chaves e valores" no Editor do Registro (Regedit.exe) ou tópicos de Ajuda "Adicionar e excluir informações no Registro" e "Editar dados de registro" no Regedt32.exe. Observe que você deve fazer backup do registro antes de editá-lo. Se você estiver executando o Windows NT, atualize também seu disco de reparação de emergência.

Para solucionar esse problema, execute o seguinte script REGINI ou REGEDIT para criar "CertSrv" ODBC após a conclusão da instalação autônoma e reiniciou o servidor de fonte de dados.

Observe que o caminho especificado nas entradas "Driver" e "DBQ" deve ser ajustado acordo com a configuração real.

Arquivo de script REGEDIT (CERTSRV.REG):

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\CertSrv]
"Driver"="C:\\WINNT\\System32\\odbcjt32.dll"
"DBQ"="C:\\WINNT\\System32\\CertLog\\certsrv.mdb"
"DriverId" = dword:00000019
"SafeTransactions" = DWORD: 00000000
"UID"="Admin"

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\CertSrv\Engines\Jet]
"ImplicitCommitSync"="Sim"
"Segmentos" = dword:00000003
"LockRetry"="Sim"

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\ODBC Data Sources]
"CertSrv"="Microsoft Access Driver (*.mdb)"

O utilitário Regedit.exe está incluído no Windows NT Server 4.0. Ele pode ser executado no modo silencioso usando a opção de linha de comando /S. Uma linha de comando de exemplo é:
REGEDIT /S C:\CERTSRV.REG
Arquivo de script REGINI:
\Registry\Machine\SOFTWARE\ODBC\odbc.ini
CertSrv
Driver = C:\WINNT\System32\odbcjt32.dll
DBQ = C:\WINNT\System32\CertLog\certsrv.mdb
DriverId = REG_DWORD 0x00000019
SafeTransactions = REG_DWORD 0 x 00000000
UID = Admin
Mecanismos
Jet
ImplicitCommitSync = Yes
Segmentos = REG_DWORD 0 x 00000003
LockRetry = Yes
Fontes de dados ODBC
CertSrv = driver do Microsoft Access (*.mdb)
Regini.exe é um utilitário para manipular o registro local ou remotamente usando um arquivo de script. Esse utilitário está incluído com o Windows NT Server Resource Kit.

Causa

O problema é causado pelo programa de instalação autônomo não adicionando a fonte de dados ODBC necessária para o banco de dados Certificate Server.

Situação

A Microsoft confirmou este é um problema no servidor de certificado versão 1.0.

A informação contida neste artigo aplica-se a:
  • Microsoft Certificate Server 1.0
Palavras-chave: 
kbmt kbpending kbprb kbsbk KB190059 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 190059  (http://support.microsoft.com/kb/190059/en-us/ )
Retired KB ArticleAviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.