Article ID: 190361 - Last Review: October 28, 2006 - Revision: 3.3

XWEB: IIS Hangs When User Cancels File Upload from Within Browser

This article was previously published under Q190361
Expand all | Collapse all

SYMPTOMS

When you use Outlook Web Access to send an attachment of a large file (for example, 30 MB), click "Add attachment now", click Close, and then click OK to cancel the task, Internet Information Server (IIS) stops responding (90% to 100% CPU utilization). The file must be large enough, or the link slow enough, that the client can cancel the upload before the whole file is sent up.

CAUSE

Exupload.dll failed to test that the client had terminated the task and looped infinitely.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For more information, please see the following article in the Microsoft Knowledge Base:
191014  (http://support.microsoft.com/kb/191014/EN-US/ ) XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

The English version of this fix should have the following file attributes or later:
Component:
   File Name     Platform  Date     Time    Size
   ----------------------------------------------------
   Exupload.dll (Intel)    5/27/98  10:51a  17,680
   Exupload.dll (Alpha)    5/27/98  10:44a  29,456
				

STATUS

Microsoft has confirmed this to be a problem in Microsoft Outlook Web Access version 5.5.

APPLIES TO
  • Microsoft Outlook Web Access 5.5
  • Microsoft Internet Information Server 4.0
  • Microsoft Exchange Server 5.5 Standard Edition
Keywords: 
kbbug kbfix kbqfe KB190361
 

Article Translations