Article ID: 190489 - Last Review: August 21, 1999 - Revision: 1.1

BUG: Choosing Page Setup Causes "Printer not ready" Error

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
This article was previously published under Q190489

On This Page

Expand all | Collapse all

SYMPTOMS

Choosing the Page Setup option from the Visual FoxPro File menu produces the following error message:
Printer not ready.

CAUSE

There are no printers installed.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce Behavior

  1. If there are any Windows printers installed, remove them.
  2. From the Visual FoxPro File menu, Choose Page Setup.
You get a message stating that the printer could not be found, followed by a message on how to install a printer. Once you click OK in the dialog box, the message is followed by the "Printer not ready" error.

APPLIES TO
  • Microsoft Visual FoxPro 5.0 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
Keywords: 
kbbug kbnofix KB190489