Kernel32.dll y otros mensajes de error cuando instala productos de Office 2000 con acceso directo a memoria (DMA) habilitado en Windows 95 o Windows 98

Seleccione idioma Seleccione idioma
Id. de artículo: 190630 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Al instalar cualquiera de los productos enumerados al principio de este artículo en Microsoft Windows 95 o Microsoft Windows 98, puede recibir el siguiente mensaje de error:
Este programa ha efectuado una operación no válida y se cerrará. Si el problema persiste, póngase en contacto con el fabricante del programa.
Si hace clic en Detalles , recibirá un mensaje de error similar al siguiente:
ACMSETUP provocó un error de página no válida en el módulo Kernel32.dll en 0177:bff7be97.
Al instalar Office 2000, puede experimentar los síntomas siguientes:
  • Oír ruido excesivo de unidad de CD-ROM cuando se instala Office.
  • Aparece alguno de los mensajes de error siguientes:

    • Aparece el error 1904
      Cuando El programa de instalación de Office 2000 es acabado se haya reiniciado el equipo.
    • Error 1911
      Cuando El programa de instalación de Office 2000 es acabado se haya reiniciado el equipo.
    • Instalación terminado antes de tiempo
      seguido de:
      La operación de E/s se anuló debido de o una salida de subproceso una solicitud de aplicación.

Causa

Este problema puede ocurrir cuando se cumplen las condiciones siguientes:
  • El equipo está ejecutando Microsoft Windows 95 o Microsoft Windows 98.

    - y -

  • Unidad de CD-ROM de su equipo está configurada para utilizar acceso directo a memoria (DMA) en el Administrador de dispositivos de Windows.

Solución

Para evitar este problema, siga estos pasos.

Deshabilitar DMA para el CD-ROM

  1. Haga clic en Inicio, seleccione Configuración y, a continuación, haga clic en control de panel.
  2. Haga doble clic en el icono <B>Sistema</B> y, a continuación, en la ficha <B>Administrador de dispositivos</B>.
  3. Seleccione ver dispositivos por tipo y haga clic en el signo más a la izquierda del CD-ROM.
  4. Haga clic en la unidad de CD-ROM que desea cambiar y, a continuación, haga clic en Propiedades.
  5. En el cuadro de diálogo Propiedades de la unidad de CD-ROM, haga clic en la ficha configuración.
  6. En configuración, desactive la casilla de verificación DMA. Haga clic en Aceptar.
  7. Cerrar la ventana Propiedades del sistema, reinicie el equipo y, a continuación, intente instalar uno de los productos enumerados al principio de este artículo para asegurarse de que el error no aparecen.
Si no se soluciona el problema, deberá utilizar los siguientes pasos adicionales.

Deshabilitar DMA para la Disk drive(s)

  1. Haga clic en Inicio, seleccione Configuración y, a continuación, haga clic en control de panel.
  2. Haga doble clic en el icono <B>Sistema</B> y, a continuación, en la ficha <B>Administrador de dispositivos</B>.
  3. Seleccione ver dispositivos por tipo y haga clic en el signo más a la izquierda de unidades de disco.
  4. Haga clic en la unidad de disco que desea cambiar y, a continuación, haga clic en Propiedades.
  5. En el cuadro de diálogo Propiedades de la unidad de disco, haga clic en la configuración de ficha.
  6. En configuración, desactive la casilla de verificación DMA. Haga clic en Aceptar.
  7. Repita los pasos 4 a 6 para cada unidad de disco.

Eliminar carpeta de producto y reinstalar

  1. Eliminar la carpeta creada durante la instalación del producto que le gustaría instalar. Por ejemplo, si instaló Microsoft Office 97, deberá eliminar la carpeta c:\Archivos de programa\Microsoft Office.
  2. Reinicie Windows 98. En el menú Inicio de Windows, haga clic en Apagar. Seleccione reiniciar y haga clic en Aceptar.
  3. Instalar uno de los productos enumerados al principio de este artículo.
Una vez finalizada la instalación, repita los pasos adecuados en las secciones anteriores para volver a habilitar DMA.

Más información

Como 15 de desde el de agosto de 1998, soporte técnico de Dell empezó a distribuir un componente de repuesto para equipos portátiles Toshiba 24 x unidades de CD-ROM en la 3200 Inspiron Dell para corregir un problema que puede ocasionar los síntomas de "Kernel32" descritos en la sección "Síntomas" de este artículo. Si desea realizar cualquier consulta al respecto, póngase en contacto con el servicio de soporte técnico de Dell.

Para obtener más información acerca de información de contacto de proveedores hardware y software, visite el siguiente sitio Web:-
  http://support.microsoft.com/gp/vendors  


Los productos de terceros aquí descritos están fabricados por proveedores independientes de Microsoft; no ofrecemos ninguna garantía, implícita ni de cualquier otro tipo, con respecto al rendimiento o la confiabilidad de estos productos.

Para obtener información adicional, consulte en contacto con los artículos siguientes en Microsoft Knowledge Base:
solucionar 190517 errores de Kernel32.dll con Office en Windows 98

Equipo de Toshiba Tecra 750 188195 con unidad de CD-ROM se bloquea al iniciar

189113 Windows 98 instalación mayo bloqueo en Toshiba Tecra o Protege

Propiedades

Id. de artículo: 190630 - Última revisión: martes, 23 de enero de 2007 - Versión: 5.4
La información de este artículo se refiere a:
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Project 98 Standard
  • Microsoft Works 4.5a
  • Microsoft Works 4.0 Standard Edition
  • Microsoft Works 4.0a
  • Microsoft Office 97 Small Business Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard
Palabras clave: 
kbmt kbtshoot kbsetup kberrmsg kbprb KB190630 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 190630

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com