STATUS_CANT_WAIT Returned from an NTCreateFile Call

Article translations Article translations
Article ID: 190791 - View products that this article applies to.
This article was previously published under Q190791
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

A Dr. Watson log or an application may report an error message referencing ERROR_NO_MID.

CAUSE

STATUS_CANT_WAIT is being occasionally returned from an NTCreateFile call when the user opens a volume handle and the system is under load. This status should never be returned outside of the Windows NT file system.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 190791 - Last Review: October 9, 2013 - Revision: 2.1
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
kbnosurvey kbarchive kbbug kbfix KB190791

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com