Aktovka položky je potrebné synchronizovať dvakrát

Preklady článku Preklady článku
ID článku: 190812 - Zobraziť produkty, ktorých sa tento článok týka.
Tento článok bol archivovaný. Je publikovaný v aktuálnej podobe a už nebude aktualizovaný.
Rozbaliť všetko | Zbaliť všetko

Príznaky

Máte priečinok Aktovka a súbor v ňom má synchronizovanej kópie ona Windows NT zdieľané v sieti.

Keď upraviť súbor v lokálnom priečinku, a synchronizovať ho s theserver kópiou, stav synchronizácie ešte ukazuje, "Potrebuje aktualizáciu." Whenyou to znova vykonajte synchronizáciu, Aktovka ponúka kopírovať súbor z remotelocation, hoci súboru časovú pečiatku je identický.

Po Aktovka skopíruje súbor zo vzdialeného miesta, thesynchronization správne nastavený stav "Up-to-date".

Príčina

Po Aktovka skopíruje súbor na server pri prvej aktualizácii, ituses FindFirstFile čítať späť informácie o súbore. V niektorých prípadoch Presmerovač správcu ktorá prevádzkuje túto API pred zatvorením súboru. Ak thishappens, veľkosť súboru zo vzdialeného súboru nie je správny a thesynchronization stav nie je nastavený správne.

V sledovanie siete, môžete vidieť rám postupnosť takhle medzi theclient a server:

   SMB       C write, FID = 0x9804, Write 0x0 at 0x0000020E
   SMB       R write, Wrote 0x0
   SMB       C transact2 Set file info, FID = 0x9804
   SMB       R transact2 Set file info (response)
   SMB       C transact2 Findfirst, File = \Text2.txt
   SMB       R transact2 Findfirst (response)
   SMB       C close file, FID = 0x9804
   SMB       R close file
				

V reakcii na Findfirst blok hlásení servera (SMB), zobrazia sa veľkosť súboru anincorrect.

Riešenie

Ak chcete vyriešiť tento problém, získať najnovšie balík service pack pre systém Windows NT 4.0 alebo individuálne softvérovej aktualizácie. Informácie o získaní najnovší balík service pack, prejdite na:
  • 152734 ako získať najnovší balík service pack pre systém windows nt 4.0
Informácie o možnosti získania jednotlivých softvérovej aktualizácie, kontaktujte technickú podporu spoločnosti Microsoft. Úplný zoznam telefónnych čísel služieb technickej podpory spoločnosti Microsoft a informácie o náklady na technickú podporu, prejdite na adresu na World Wide Web:
http://support.Microsoft.com/default.aspx?SCID=FH;EN-US;CNTACTMS

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v systéme Windows NT 4.0. Tento problém bol prvýkrát vyriešený v systéme Windows NT 4.0 Service Pack 5.

Vlastnosti

ID článku: 190812 - Posledná kontrola: 3. novembra 2013 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Kľúčové slová: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbmt KB190812 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 190812

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com