Network Problems That Occur When Logging Off May Corrupt Roaming Profiles

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Article ID: 191834 - View products that this article applies to.
This article was previously published under Q191834
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SYMPTOMS

User profiles that are stored on the server (roaming user profiles) may become corrupted if contact with the remote server is terminated during the copy process. This may happen in, but is not limited to, the following scenarios:

  • The user prematurely turns the workstation off.
  • The network connection from the workstation to the server is severed, for example, the cable is disconnected from the network card.

CAUSE

This problem occurs when Ntuser.dat contains only part of the profile information.

MORE INFORMATION

It should be noted that this hotfix does not resolve the underlying cause of the profile corruption. It merely prevents the user's NTUSER.DAT on the server from being overwritten by the uploaded version, until the upload completes successfully. If the profile does fail to copy successfully, then one of two things will occur, depending on the user.

If the User Does Not Roam from Computer to Computer

The user will be prompted at the next logon to select between the local profile and the remote profile. Because the upload process failed at the last logoff, the date/time stamp on the remote Ntuser.dat file is older than the date/time stamp on the local Ntuser.dat file. This causes Windows NT to prompt the user to prevent a loss of data on the local workstation. If the user selects the remote profile then any changes made to the user profile in the last session -- colors, wallpaper, or other settings -- will be lost.

If the User Does Roam from Computer to Computer

Any changes made to the user profile in the last session -- colors, wallpaper, or other settings -- session will be lost.

This does not affect any files saved to the Desktop, Personal folder, or other profile folders.

RESOLUTION

A change has been made that causes profile information to be stored in a temporary file (Ntuser.dat.tmp) and then renamed to Ntuser.dat when logging off.

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 191834 - Last Review: November 1, 2006 - Revision: 2.3
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbqfe KB191834

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