DifficoltÓ nell'utilizzo della CPU AMD K6-2 o Athlon

Traduzione articoli Traduzione articoli
Identificativo articolo: 192841 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato precedentemente pubblicato con il codice di riferimento I192841
Espandi tutto | Chiudi tutto

Sintomi

Quando si avvia un computer basato su Windows 95 o Windows 95 OEM Service Release che utilizza una CPU AMD K6/2 (350MHz o superiore) o AMD Athlon (1.1GHz o superiore), Ŕ possibile che venga visualizzato un messaggio di errore analogo a uno dei seguenti:
  • Impossibile inizializzare la periferica IOS. Errore di protezione di Windows. Riavviare il computer.
  • Errore di protezione di Windows. Riavviare il computer.
  • Durante l'inizializzazione della periferica IOS: Errore di protezione di Windows.
NOTA: il problema non si verifica spesso con la CPU K6/2 a 350 MHz, mentre Ŕ pi¨ frequente a velocitÓ superiori e pu˛ manifestarsi anche quando si avvia il computer in modalitÓ provvisoria.

Cause

Il primo messaggio d'errore Ŕ il risultato di una eccezione di divisione in Ios.vxd; il secondo Ŕ dovuto a un errore simile in Esdi_506.pdr o Scsiport.pdr.

Le versioni originali rilasciate dei file elencati nella sezione "Risoluzione" di questo articolo contengono cicli di temporizzazione dell'inizializzazione che non vengono eseguiti correttamente sui processori indicati alla velocitÓ di 350 MHz o superiore. Si noti che il problema Ŕ dovuto a limitazioni degli algoritmi software e non indica affatto un errato funzionamento del processore in sÚ.

Risoluzione

L'aggiornamento AMD-K6-2 Ŕ stato rivisto in modo da incorporare una versione pi¨ recente del file Vfbackup.vxd. Per ulteriori informazioni su questo aggiornamento, vedere il seguente articolo della Knowledge Base:
234259 Revisione dell'aggiornamento della CPU AMD K6-2/350
Microsoft ha giÓ messo a disposizione una correzione supportata che risolve il problema in Microsoft Windows 95 OEM Service Release versioni 2, 2.1 e 2.5, malgrado non sia ancora stata completamente testata, pertanto deve essere utilizzata solo per i computer su cui si verifica il problema specifico. Se questo problema non influisce gravemente sul funzionamento del computer, Microsoft consiglia di passare alla versione successiva di Windows.
Scorrere la sezione relativa ai service pack e fare clic sul collegamento per scaricare l'aggiornamento di Windows 95 per AMD-K6-2/350.
Il problema viene risolto dai seguenti file aggiornati per Windows 95 OSR 2 e OSR 2.1:
   Data        Ora    Versione   Dimensioni    Nome file
   ---------------------------------------------------------
   04/09/1998  11.18  4.00.1118  24.426 byte   Esdi_506.pdr
   03/08/1998  11.13  4.00.1113  25.249 byte   Hsflop.pdr
   04/09/1998  11.12  4.00.1112  23.158 byte   Scsiport.pdr
   15/01/1997  11.12  4.00.1112  59.153 byte   Cdfs.vxd
   15/01/1997  11.12  4.00.1112  18.809 byte   Disktsd.vxd
   15/01/1997  11.12  4.00.1112   9.955 byte   Int13.vxd
   04/09/1998  11.13  4.00.1113  68.962 byte   Ios.vxd
   15/01/1997  11.12  4.00.1112  18.197 byte   Vfbackup.vxd
				
Per la versione OSR 2.1 Ŕ inoltre necessario il seguente file aggiornato:
   Data        Ora    Versione   Dimensioni      Nome file
   --------------------------------------------------------
   04/12/1998  12.13  4.00.1213  111.678 byte   Ntkern.vxd
				
NOTA: la correzione non risolve il problema nella versione definitiva di Windows 95, inoltre le versioni datate "18/09/1998 11.00" del file Amdk6upd.exe non eseguono la sostituzione del file Ntkern.vxd nelle versioni OSR 2.1 e OSR 2.5. Per determinare quale versione del file Ntkern.vxd Ŕ installata sul computer, fare clic con il pulsante destro del mouse sul file Ntkern.vxd nella cartella Windows\System\Vmm32, scegliere ProprietÓ e selezionare la scheda Versione. Se il numero di versione non Ŕ 4.03.1213, Ŕ necessario procurarsi e installare una nuova versione dell'aggiornamento, come descritto in seguito. Si noti che la versione del file Ntkern.vxd originale Ŕ 4.03.1212.

Per installare l'aggiornamento, attenersi alla seguente procedura:
  1. Scaricare il file Amdk6upd.exe su un disco floppy. Scaricare il file da un altro computer, se necessario.
  2. Riavviare il computer. Quando viene visualizzato il messaggio "Avvio di Windows 95 in corso...", premere F8 e scegliere la modalitÓ provvisoria dal menu di avvio.
  3. Se il computer si avvia in modalitÓ provvisoria, passare al punto 6. Se non Ŕ possibile avviare Windows, continuare con il punto 4.
  4. Riavviare il computer. Quando viene visualizzato il messaggio "Avvio di Windows 95 in corso...", premere F8 e scegliere Prompt dei comandi in modalitÓ provvisoria dal menu di avvio.
  5. Al prompt c:\ digitare win /d:m per avviare Windows in modalitÓ provvisoria.
  6. Inserire il disco floppy contenente il file Amdk6upd.exe scaricato al punto 1 e aprire Gestione risorse o Risorse del computer per fare doppio clic sul file.
  7. Seguire le istruzioni visualizzate sullo schermo per installare l'aggiornamento.
Il seguente file Ŕ disponibile per il download dall'Area download Microsoft:
Download di Amdk6upd.exe


Per ulteriori informazioni sul download di file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file Ŕ stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus pi¨ recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.

Status

Microsoft ha confermato che questo Ŕ un problema di Windows 95 e delle versioni OEM Service Release 2, 2.1 e 2.5

Il problema Ŕ stato risolto in Microsoft Windows 98.

ProprietÓ

Identificativo articolo: 192841 - Ultima modifica: lunedý 28 maggio 2007 - Revisione: 3.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 95
  • Microsoft Windows 95
  • Microsoft Windows 95
  • Microsoft Windows 95
Chiavi:á
kbqfe kbhotfixserver kbdownload kbenv kberrmsg kbfile kbgraphxlinkcritical kbprb KB192841
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Dichiarazione di non responsabilitÓ per articoli della Microsoft Knowledge Base su prodotti non pi¨ supportati
Questo articolo Ŕ stato scritto sui prodotti per cui Microsoft non offre pi¨ supporto. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com