Potíže při použití procesoru AMD K6-2 či Athlon

Překlady článku Překlady článku
ID článku: 192841 - Produkty, které se vztahují k tomuto článku.
Tento článek byl dříve publikován CZ192841
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při spouštění počítače se systémem Windows 95 či Windows 95 OEM Service Release vybaveného procesorem AMD K6/2 (350 MHz nebo rychlejší) či AMD Athlon (1,1 GHz či rychlejší) se může zobrazit následující chybová zpráva:
  • Nezdařila se inicializace systému IOS zařízení. Chyba ochrany systému Windows. Musíte restartovat počítač.
  • Chyba ochrany systému Windows. Musíte restartovat počítač.
  • Při inicializaci systému IOS zařízení došlo k chybě: Chyba ochrany systému Windows.
Poznámka : V případě procesoru K6/2 350 MHz dochází k této chybě jen nepravidelně, ovšem mnohem častěji k ní dochází v případě rychlejších procesorů. Dále může k těmto potížím docházet i při spuštění počítače v Nouzovém režimu.

Příčina

První chyba je výsledkem výjimky při dělení v ovladači Ios.vxd, druhá chyba má stejnou příčinu v ovladači Esdi_506.pdr či Scsiport.pdr.

Původní verze souborů uvedených v oddílu "Řešení" tohoto článku obsahují inicializační smyčky časování, které na uvedených procesorech při rychlosti 350 MHz a vyšší neproběhnou správně. K této chybě dochází z důvodu omezení softwarového algoritmu a neznamená chybu procesoru, který funguje správně.

Řešení

Na trh byla uvedena oprava procesoru AMD-K6-2, která zahrnuje novější verzi ovladače Vfbackup.vxd. Další informace o této aktualizaci naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
234259 Oprava procesoru AMD K6-2/350
Společnost Microsoft vydala opravu, která odstraňuje tyto potíže v systému Microsoft Windows 95 OEM Service Release verze 2, 2.1 a 2.5, ale nebyla doposud důkladně testována. Proto by měla být použita pouze v systémech, ve kterých k těmto potížím opravdu dochází a nikoli preventivně. Pokud jste tyto potíže nezjistili, doporučujeme použít novou verzi systému Windows.
Přejděte na oddíl určený aktualizacím Service Pack a poté klepněte na odkaz pro stažení aktualizace systému Windows 95 pro procesor AMD-K6-2/350.
Tyto potíže byly odstraněny aktualizací následujících souborů systému Windows 95 OSR 2 a OSR 2.1:
   Datum     Čas      Verze      Velikost       Název souboru
   ----------------------------------------------------------
   4. 9. 98  11:18    4.00.1118  24 426 bajtů   Esdi_506.pdr
   3. 8. 98  11:13    4.00.1113  25 249 bajtů   Hsflop.pdr
   4. 9. 98  11:12    4.00.1112  23 158 bajtů   Scsiport.pdr
   15. 1. 97 11:12    4.00.1112  59 153 bajtů   Cdfs.vxd
   15. 1. 97 11:12    4.00.1112  18 809 bajtů   Disktsd.vxd
   15. 1. 97 11:12    4.00.1112   9 955 bajtů   Int13.vxd
   4. 9. 98  11:13    4.00.1113  68 962 bajtů   Ios.vxd
   15. 1. 97 11:12    4.00.1112  18 197 bajtů   Vfbackup.vxd
Pro verze OSR 2.1 je dále potřebný následující aktualizovaný soubor:
   Datum     Čas      Verze      Velikost       Název souboru 
   ----------------------------------------------------------
   4. 12. 98 12:13    4.00.1213  111 678 bajtů  Ntkern.vxd
Poznámka : Tato oprava neodstraňuje tyto potíže v koncové verzi systému Windows 95. Verze aktualizace Amdk6upd.exe s datem 18. 9. 1998 11:00 nenahrazuje soubor Ntkern.vxd v systému OSR 2.1 a OSR2.5. Verzi souboru Ntkern.vxd v počítači určíte tak, že pravým tlačítkem myši klepnete na soubor Ntkern.vxd ve složce Windows\System\Vmm32, klepnete na položku Vlastnosti a poté klepnete na kartu Verze. Pokud není číslo verze 4.03.1213, měli byste stáhnout a nainstalovat novou verzi aktualizace, jak je popsáno níže. Verze původního souboru Ntkern.vxd je 4.03.1212.

Při instalaci této aktualizace postupujte podle následujících pokynů:
  1. Stáhněte soubor Amdk6upd.exe a uložte jej na disketu. Pokud je to nezbytné, stáhněte jej z jiného počítače.
  2. Restartujte počítač. Jakmile se zobrazí zpráva "Spouštění systému Windows 95", stiskněte klávesu F8 a poté ze spouštěcí nabídky zvolte možnost Nouzový režim.
  3. Pokud se počítač spustí v Nouzovém režimu, přejděte ke kroku 6. Pokud není možné systém Windows spustit, pokračujte krokem 4.
  4. Restartujte počítač. Jakmile se zobrazí zpráva "Spouštění systému Windows 95", stiskněte klávesu F8 a poté ze spouštěcí nabídky zvolte možnost Jen systém MS-DOS.
  5. Na příkazovém řádku c:\ zadejte příkaz win /d:m , kterým spustíte systém Windows v Nouzovém režimu.
  6. Vložte do jednotky disketu se souborem Amdk6upd.exe, který jste stáhli v kroku 1, a poté na něj v Průzkumníku Windows nebo okně Tento počítač poklepejte.
  7. Při instalaci aktualizace postupujte podle pokynů na obrazovce.
Následující soubor je k dispozici ke stažení z centra pro stahování Microsoft Download Center:
Zmenšit tento obrázekZvětšit tento obrázek
DOWNLOAD
Stáhnout soubor Amdk6upd.exe
Další informace o stahování souborů odborné pomoci společnosti Microsoft naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
119591 Jak získat soubory odborné pomoci společnosti Microsoft ze serverů služeb online
Společnost Microsoft použila ke kontrole tohoto souboru nejnovější antivirový software, který byl k dispozici v době jeho publikování. Po publikování je soubor uložen na zabezpečených serverech neumožňujících neoprávněné změny souborů.



Prohlášení

Společnost Microsoft potvrzuje, že jde o chybu v produktu Microsoft Windows 95 a OEM Service Release verze 2, 2.1 a 2.5.

Tyto potíže byly odstraněny v systému Microsoft Windows 98.

Vlastnosti

ID článku: 192841 - Poslední aktualizace: 28. května 2007 - Revize: 2.5
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 95
  • Microsoft Windows 95
  • Microsoft Windows 95
Klíčová slova: 
kbdownload kbdownload kbenv kberrmsg kbfile kbgraphxlinkcritical kbprb win95 KB192841
Právní omezení pro obsah znalostní báze týkající se produktů, jejichž podpora byla ukončena
Tento článek byl napsán o produktech, pro které společnost Microsoft již neposkytuje nadále podporu. Článek je tedy nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com