Language format is not available or is not applied to all parts of a document in Word for Mac

Article translations Article translations
Article ID: 193595 - View products that this article applies to.
This article was previously published under Q193595
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

Symptoms

When you change the language format on the Tools menu for only the body of your document by clicking Select All on the Edit menu, this change is not applied to headers, to footers, to text boxes, to footnotes, or to endnotes.

Cause

The Select All command on the Edit menu does not select headers, footers, text boxes, and footnotes or endnotes. Therefore, if you change the language format in the main part of your document, these other parts of the document are not affected.

Workaround

To work around this issue, first ensure that the desired international proofing tools files are installed. In Microsoft Word 2004 for Mac, in Microsoft Word X for Mac, in Microsoft Word 2001 for Macintosh, and in Microsoft Word 98 Macintosh Edition, the proofing tools are installed at the following location:
/Microsoft Office <version>/Shared Applications/Proofing Tools/
If the proofing tools for the language that you want are not installed at this location, you must install them.

By default, all proofing tools are installed in Word 2004 for Mac. However, in Word X for Mac, in Word 2001 for Macintosh, and in Word 98 Macintosh Edition, you must run the Value Pack installer from the CD to install the proofing tools.

To assure the Language setting is applied to all text in the entire document, regardless of its location, use either of the following methods.

Method 1: Add the Language Format to the Styles in Your Document

  1. On the Format menu, click Style.
  2. In the Style dialog box, click one of the styles that you used in the document, and then click Modify.
  3. Click to select the Add To Template check box if you want to permanently redefine the style in your template.
  4. Click the Format button, and then click Language.
  5. Select the language that you want.
  6. Click OK twice, and then click Close.
  7. Repeat steps 1-6 for each style in your document.

Method 2: Select the Text and Manually Apply the Language Format

  1. Select the text.
  2. On the Tools menu, click Language, and then click Set Language.
  3. Select the language that you want, and then click OK.

More information

When you insert form fields into a document, the language format of the form field is set to No Proofing. Therefore, you need set the language format of the form field manually.

For additional information about the Language format, please see the following articles in the Microsoft Knowledge Base:
141306 How to enable support for multiple languages in Windows
79482 "No Proofing" is selected if two languages are selected
89646 Text formatted with no proofing was skipped

Properties

Article ID: 193595 - Last Review: November 2, 2013 - Revision: 4.0
Applies to
  • Microsoft Word 98 for Macintosh
  • Microsoft Word 2001 for Mac
  • Microsoft Word X for Mac
  • Microsoft Word 2004 for Mac
Keywords: 
kbnosurvey kbarchive kbprb KB193595

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com