Fractions convertie en caractères de soulignement dans Word pour Macintosh et Excel pour Macintosh

Traductions disponibles Traductions disponibles
Numéro d'article: 193979 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Dans Microsoft Word pour Macintosh versions répertoriées dans la section "S'applique À", fractions, comme 1/2 ou 1/4, qui ont un caractère de fraction contenu dans le document sont remplacés par un trait de soulignement lorsque vous ouvrez un document Microsoft Word pour Windows. Un comportement similaire peut également se produire dans Microsoft Excel pour Macintosh.

Cause

Ce problème se produit car certaines polices de Microsoft Windows comportent des fractions commun. Par exemple, certaines polices Windows contiennent les fractions commun 1/2, 1/4 et 3/4. Étant donné que ces caractères sont disponibles dans certaines polices, il existe une fonctionnalité dans Microsoft Word pour Windows, en commençant par Microsoft Word 97 pour Windows version, qui remplace automatiquement les fractions de texte ordinaire en un caractère de fraction. En outre, certaines fractions commun peut être insérées en tant que symbole. Sur Macintosh, les caractères de fraction n'existent pas dans les polices Macintosh. Par conséquent, lorsque vous ouvrez le document Word pour Windows dans Word pour Mac, le caractère de fraction est remplacé par un trait de soulignement. Ce problème ne se produit plus dans Word 2004 pour Mac, car il inclut les caractères de fraction spécial.

Contournement

Remarque : vous ne pouvez pas reconvertir le caractère de soulignement en une fraction sur Macintosh. Cependant, si vous laissez les traits de soulignement comme partie du document, puis enregistrez le document, les fractions d'origine sont conservées lorsque vous rouvrez le document dans Word pour Windows.

Pour afficher correctement la fraction sur plates-formes Windows et Macintosh, les fractions doivent être créées à l'aide de l'éditeur d'équations ou à l'aide d'une équation (EQ) de champ plutôt qu'à l'aide de la fraction des caractères sur la plate-forme Windows.

Méthode 1: Utiliser un champ d'équation (EQ)

Pour insérer une fraction sous la forme d'un champ d'équation, procédez comme suit :
  1. Dans le menu Insertion, cliquez sur champ.
  2. Dans la liste catégories, cliquez pour sélectionner des équations et formules.
  3. Dans la liste de Champs, cliquez sur Sélectionnez EQ, puis cliquez sur Options.
  4. Dans la liste commutateurs, sélectionnez \F(,), puis cliquez sur Ajouter au champ.
  5. Dans la zone avec le texte \F(,) EQ, tapez le numérateur de la fraction d'avant la virgule et le dénominateur de la fraction après la virgule au sein de la parenthèse.

    Par exemple, pour une fraction de 1/2, modifiez le champ EQ \F(,) comme :
    EQ \F(1,2)
  6. Cliquez sur OK pour fermer la boîte de dialogue Options de champ.
  7. Cliquez sur OK pour fermer la boîte de dialogue champ.
Votre champ fraction doit être inséré dans votre document. Si vous ne voyez pas la fraction, mais que vous voyez {EQ \F(1,2)} au lieu de cela, appuyez ensuite sur ALT + F9 (Windows) ou OPTION + F9 (Macintosh) pour désactiver les codes de champ.

Méthode 2: Utiliser l'éditeur d'équations

Pour insérer la fraction à l'aide de l'éditeur d'équations, procédez comme suit :
  1. Dans le menu Insertion, cliquez sur objet.
  2. Sous l'onglet Créer nouveau, sélectionnez Microsoft Equation 3.0, puis cliquez sur OK.
  3. Dans la barre d'outils équation, cliquez sur fraction et modèles radicale.

    Remarque : le bouton modèles radicaux et fraction doit être le second bouton de gauche sur la ligne inférieure de la barre d'outils équation.
  4. Cliquez sur le style souhaité pour la fraction parmi les choix disponibles.
  5. Tapez le nombre du numérateur, appuyez sur bas, puis tapez le numéro de dénominateur pour créer la fraction.
  6. Après avoir créé la fraction, cliquez dans le document pour fermer l'éditeur d'équations.
Si vous ne voyez pas la fraction, mais que vous voyez {EMBED Equation.3} au lieu de cela, appuyez sur ALT + F9 (Windows) ou OPTION + F9 (Macintosh) pour désactiver les codes de champ.

Plus d'informations

Pour activer (désactiver) la mise en forme automatique de texte à caractères de fraction dans Word 97 pour Windows, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Correction automatique.
  2. Sous l'onglet Afficher ci-dessous les options, cliquez sur pour effacer la fractions (1/2) par caractère de fraction (1/2) case à cocher.

    Remarque : vous pouvez également souhaiter activez l'onglet mise en forme et désactivez le fractions (1/2) par caractère de fraction (1/2) case à cocher.
Avec la fractions (1/2) par caractère de fraction (1/2) option est activée, fractions ne seront pas remplacées par le caractère de fraction.

Dans Microsoft Windows, vous pouvez également avez la possibilité d'entrer certaines autres fractions (par exemple: 1/3, 2/3, 1/8, 3/8, 5/8 et 7/8) comme caractère de symbole. Le caractère de soulignement convertira également ces fractions lorsque le document est ouvert dans Word 98 Édition Macintosh.

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
185510WD98 : Fraction non remplacée automatiquement (aucune option mise en forme automatique)

Propriétés

Numéro d'article: 193979 - Dernière mise à jour: mardi 23 janvier 2007 - Version: 3.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word X pour Mac
  • Microsoft Word 2001 pour Mac
  • Microsoft Word 98 for Macintosh
  • Microsoft Excel X pour Mac
  • Microsoft Excel 2001 pour Mac
  • Microsoft Excel 98 pour Macintosh
Mots-clés : 
kbmt kbfield kbprb KB193979 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 193979
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com