Article ID: 194047 - Last Review: October 3, 2001 - Revision: 1.0

FP98: No Documents Found After Performing Search Query

This article was previously published under Q194047

For a Microsoft FrontPage 2000 version of this article, see 205710  (http://support.microsoft.com/kb/205710/EN-US/ ) .
For a Microsoft FrontPage 97 version of this article, see 192434  (http://support.microsoft.com/kb/192434/EN-US/ ) .

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SYMPTOMS

When you perform a search, no results are returned and you may receive the following message:
No documents found. Please try again.

CAUSE

This message may appear if any of the following are true:
  • The files that contain the index information for the search component are corrupted or missing (for example, they were deleted or moved).

    -or-
  • If you are publishing to a web that uses Microsoft Index Server, the catalog file does not exist.

    -or-
  • You are searching for a word that is on the WAIS stop list.

RESOLUTION

To resolve this behavior, use one of the following methods.

NOTE: You should try Method 1 first. If Method 1 does not resolve this behavior, use Method 2. If you are using Microsoft Index Server, use Method 3.

Method 1: Recalculate Links

  1. Start FrontPage Explorer and open your Web.
  2. On the Tools menu, click Recalculate Hyperlinks.
  3. Rerun your search in a Web browser.

    NOTE: You may need to refresh or reload the page in the Web browser.

Method 2: Reset the Dependency Databases

To reset the dependency databases used by the FrontPage Search Component, follow these steps:
  1. In Windows Explorer, open the folder that contains your Web content. To determine where your content is stored, use the following table as a guide.

    NOTE: The folders listed in the table are the default folders created when you install FrontPage. If you configured your Web server to use a different content root, select that folder instead of the one listed in the table.
          Web Server                              Folder
          ---------------------------------------------------------------
    
          FrontPage Personal Web Server           \FrontPage Webs\Content
          Microsoft Personal Web Server           \Webshare\Wwwroot
          Microsoft Internet Information Server   \InetPub\Wwwroot
    						
  2. Open the folder that contained the deleted page.
  3. Open the \_vti_pvt folder and delete the following two files:
          Deptodoc.btr
          Doctodep.btr
    						
  4. Open the \_vti_txt\default.wti folder. Delete the following files:
          All.cat
          All.dct
          All.doc
          All.fmt
          All.fn
          All.hl
          All.idx
          All.inv
          All.src
    						
  5. Switch to FrontPage Explorer.
  6. On the Tools menu, click Recalculate Hyperlinks.

Method 3: Create a Catalog File using Index Server

Set up Index Server with a catalog for the virtual server. For information about how to do this, please see the following article in the Microsoft Knowledge Base:
183731  (http://support.microsoft.com/kb/183731/EN-US/ ) How to Index and Create a Catalog for a New Web Site

MORE INFORMATION

For additional information about search problems, please see the following articles in the Microsoft Knowledge Base:
194263  (http://support.microsoft.com/kb/194263/EN-US/ ) FP98: Deleted Pages from Web Show up in Search Results List

185543  (http://support.microsoft.com/kb/185543/EN-US/ ) FP98: No Documents Found Using FrontPage 98 & Index Server

APPLIES TO
  • Microsoft FrontPage 98 Standard Edition
Keywords: 
kbprb KB194047
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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