Verzögerungen bei Verbindungen zu NetWare-Servern

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Artikel-ID: 194827 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
194827 Delays Connecting to NetWare Servers in Mixed Network
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Zusammenfassung

WARNUNG:
Dieser Artikel enthält Informationen zum Bearbeiten der Registierdatenbank. Bevor Sie die Registrierung bearbeiten, erstellen Sie eine Sicherungskopie der Dateien SYSTEM.DAT und USER.DAT. Vergewissern Sie sich, dass Sie die Registrierung wiederherstellen können, wenn ein Problem auftritt. Informationen hierzu finden Sie unter dem Hilfethema "Wiederherstellen der Registrierung" in "Regedit.exe" oder unter "Wiederherstellen eines Registrierungsschlüssels" in "Regedt32.exe".

Problembeschreibung

Wenn Sie in einer gemischten Netzwerkserverumgebung arbeiten, in der Sie Verbindungen herstellen zu Novell NetWare-Servern (mit dem IntraNetWare-Client [Client32], Version 2.2 von Novell) und zu Microsoft Windows NT-Servern und anderen SMB-Servern (mit dem Microsoft-Client für Microsoft-Netzwerke), nimmt der Aufbau einer Verbindung zu einem NetWare-Server möglicherweise viel Zeit in Anspruch.

Ursache

Diess Problem kann auftreten, wenn alle nachstehenden Umstände vorliegen:
  • Für die Herstellung von Verbindungen zu Microsoft-Netzwerkservern wird TCP/IP verwendet.
  • Das IPX/SPX-kompatible Protokoll und der IntraNetWare-Client 2.2 von Novell werden für Verbindungen zu NetWare-Servern verwendet.
  • Für die Auswertung von TCP/IP-Netzwerknamen wird der Domain Name Service (DNS) eingesetzt.
  • Auf dem NetWare-Server läuft TCP/IP zusätzlich zu einem IPX/SPX-kompatiblen Protokoll.
  • Die TCP/IP-Adresse des NetWare-Servers ist bei dem DNS-Server mit einem DNS-Namen registriert, der mit dem NetWare-Servernamen identisch ist.
Unter diesen Bedingungen versucht Windows, den Servernamen zunächst unter Verwendung des NetWare-Netzwerk-Clients und dann mit Hilfe des Microsoft-Netzwerk-Clients auszuwerten. Wenn der NetWare-Server auf die Anforderung zur Auswertung des Servernamen unter Verwendung des Service Advertising Protocol (SAP) nicht reagiert, versucht der Microsoft-Netzwerk-Client, den Namen unter Verwendung von DNS auszuwerten. Da der NetWare-Server beim DNS-Server registriert ist, ist der DNS-Server möglicherweise in der Lage, den NetWare-Servernamen schneller auszuwerten, als der NetWare-Server auf die SAP-Anforderung reagieren kann.

Tritt das in diesem Artikel behandelte Problem auf, wenn die vorstehend aufgelisteten Umstände vorliegen, ist der NetWare-Servername bei der Speicherung in der lokalen Registrierung unter Umständen fälschlicherweise als Microsoft-Servername (SMB-Servername) gekennzeichnet worden. Bei Versuchen, eine Verbindung zu diesem Servernamen herzustellen, wird auf diese Informationen in der Registrierung Bezug genommen und zuerst der Microsoft-Netzwerk-Client verwendet und der NetWare-Client erst dann herangezogen, wenn für den ersten Versuch eine Zeitüberschreitung eingetreten ist. Aufgrund des für die DNS-Namensauswertung und TCP/IP-Verbindungen festgelegten Grenzwertes für die Zeitüberschreitung kann es eine Minute oder länger dauern, bevor für den ersten Versuch eines Verbindungsaufbaus zu dem NetWare-Server eine Zeitüberschreitung eintritt und Windows danach versucht, eine Verbindung mit Hilfe des NetWare-Clients aufzubauen.

Lösung

Sie können dieses Problem umgehen, indem Sie eines der folgenden Verfahren anwenden:
  • Verwenden Sie statt des IntraNetWare-Clients von Novell den Microsoft-Client für NetWare-Netzwerke zur Herstellung einer Verbindung zu NetWare-Servern. (Das Problem in Form langsamer Antworten auf SAP-Anforderungen kann möglicherweise auch durch eine Aktualisierung des IntraNetWare-Clients von Novell behoben werden.)
  • Vermeiden Sie es, den NetWare-Server bei DNS mit einem DNS-Namen zu registrieren, der mit dem NetWare-Servernamen identisch ist.
  • Bearbeiten Sie den Registrierungswert für den inkorrekt zwischengespeicherten Servernameneintrag so, daß er korrekt als NetWare-Server erkannt und nicht für einen Microsoft-Netzwerkserver (SMB-Server) gehalten wird.
Diese Werte finden Sie unter dem folgenden Registrierungsschlüssel:

HKEY_LOCAL_COMPUTER\System\CurrentControlSet\Services\VxD\VCACHE\
Lookup\ServerNameCache

Dieser Schlüssel enthält eine Reihe von Werten mit Namen in der Form "Key<####>", wobei <####> für eine Zahl zwischen 0000 und der maximalen Anzahl zwischengespeicherter Servernamen steht.
  1. Suchen Sie im Registrierungseditor nach diesem Schlüssel und diesen Werten, klicken Sie jeden Wert nacheinander doppelt an und prüfen Sie die Daten dieser Werte. Führen Sie keine Änderungen an diesen Werten durch.
  2. Wenn Sie den Wert identifiziert haben, der den Namen des Servers enthält, mit dem es Probleme beim Verbindungsaufbau gibt, notieren Sie den numerischen Teil dieses Namens (Key<####>).
  3. In demselben Registrierungsschlüssel suchen Sie den Wert mit einem Namen in der Form "Data<####>", wobei <####> der numerische Teil des Wertes Key<####> aus dem vorstehenden Schritt 2 ist. Alle diese Werte setzen sich aus vier Byte an Daten in Form von vier Sedezimalziffernpaaren zusammen. Beachten Sie das dritte dieser vier Paare. Der Wert dieses Paares gibt an, welcher Netzwerk-Client dem Servernamen zugeordnet ist. Ein Wert von 02 steht für einen Microsoft-Netzwerkserver. Ein Wert von 03 steht für einen Novell NetWare-Server.
  4. Ist der Servertyp in dem Wert Data<####> nicht korrekt (02 anstelle von 03 für einen NetWare-Server), klicken Sie den Wert Data<####> doppelt an, um ihn bearbeiten zu können. Klicken Sie doppelt auf das dritte Ziffernpaar, um es auszuwählen, geben Sie 03 ein, und klicken Sie dann auf "OK".
  5. Beenden Sie den Registrierungseditor und starten Sie Windows neu, damit die Änderungen wirksam werden können.
Nachdem ein Servername einmal korrekt zwischengespeichert ist, wird er normalerweise nicht mehr in einen falschen Wert geändert.
  • Sie können jetzt bei Microsoft ein unterstütztes Korrekturprogramm beziehen, durch das dieses Problem für Windows 95 und Windows 95 OEM Service Release 2, 2.1 und 2.5 behoben wird. Die Regressionsprüfung für dieses Korrekturprogramm ist jedoch noch nicht vollständig abgeschlossen. Es sollte daher nur bei Systemen angewendet werden, bei denen dieses spezifische Problem auftritt. Wenn Sie das in diesem Artikel angesprochene Problem sofort beheben möchten, wenden Sie sich bitte an den Microsoft Software Service und bestellen Sie das Korrekturprogramm.
Die Dateien dieses Korrekturprogramms für Windows 95 (Verkaufsversion) sollten folgende Attribute aufweisen, wobei die Angaben zu Datum/Uhrzeit auch später als in der nachstehenden Tabelle liegen dürfen:
   Dateiname     Version    Datum     Uhrzeit   Größe
   Vcache.vxd    4.00.950   11/18/97   7:58pm   19.590 Byte
Die Dateien dieses Korrekturprogramms für Windows 95 OEM Service Release 2, 2.1 und 2.5 sollten folgende Attribute aufweisen, wobei die Angaben zu Datum/Uhrzeit auch später als in der nachstehenden Tabelle liegen dürfen:
   Dateiname     Version     Datum      Uhrzeit    Größe
   Vcache.vxd    4.00.1111   10/31/97   4:09pm     41.752 Byte
Mit diesem Korrekturprogramm kann der Servernamenzwischenspeicher vollständig deaktiviert werden, indem der folgende Registrierungswert auf den Datenwert Null gesetzt wird:

Schlüssel: HKEY_LOCAL_COMPUTER\System\CurrentControlSet\Services\VxD\
                VCACHE\Lookup\ServerNameCache
Wert: MaxElements
Datenwert: 00 00 00 00 (zum Deaktivieren des Servernamenzwischenspeichers)

Das Paket, das dieses Korrekturprogramm automatisch installiert, setzt diesen Registrierungswert auf den Wert Null, um den Servernamenzwischenspeicher zu deaktivieren.

Wenn dieser Wert auf Null gesetzt ist, wird der Servernamenzwischenspeicher bei der Auflösung von Netzwerkservernamen nicht eingesetzt und dem Servernamenzwischenspeicher werden bei der Auflösung von Servernamen keine neuen Einträge hinzugefügt.

Diese Funktion ist in Microsoft Windows 98 enthalten und kann aktiviert werden, indem man den Registrierungswert "MaxElements" wie vorstehend beschrieben auf Null setzt.

Status

Microsoft hat bestätigt, daß dieses Problem in Microsoft Windows 95 und OEM Service Release 2 (OSR 2) auftritt.

Weitere Informationen

Dieses Problem ist in der Novell Knowledge Base als Dokument 2929988, "Verlangsamte Client-Leistung aufgrund von DNS-Abfragen" dokumentiert. Auf die Novell Knowledge Base können Sie unter der folgenden Internet-Adresse zugreifen:
   http://support.novell.com
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Für weitere Informationen über Windows 95-Updates lesen Sie bitte den folgenden Artikel in der Microsoft Knowledge Base:
   ARTIKEL-ID: D36052
   TITEL     : Implementierung von Windows 95-Updates
Microsoft kann keine Gewährleistungen oder Support für Probleme übernehmen, welche durch eine Manipulation der Windows oder Windows NT Registrierdatenbank verursacht wurden. Es ist Ihr eigenes Risiko, den Windows oder Windows NT Registriereditor Regedit.exe oder ähnliche Werkzeuge zur Manipulation der Windows oder Windows NT Registrierdatenbank zu verwenden.

Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, daß nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachige(n) Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Eigenschaften

Artikel-ID: 194827 - Geändert am: Dienstag, 4. Februar 2014 - Version: 1.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
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