Retrasos de conexión a servidores de NetWare en red mixto

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importante : este artículo contiene información acerca de cómo modificar el registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
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Síntomas

Cuando se trabaja en un entorno de servidor de red mixto, conectar a servidores Novell NetWare (mediante IntraNetWare Client [Client32] versión de Novell 2.2) a Microsoft Windows NT y otros servidores basados en SMB (mediante el cliente de Microsoft para redes Microsoft), conectarse a un servidor de NetWare puede a veces tardar mucho.

Causa

Este problema puede producirse si todas las condiciones siguientes:

  • TCP/IP se utiliza para conectarse a servidores de Microsoft Network.
  • El protocolo compatible con IPX/SPX y IntraNetWare Client 2.2 de Novell se utilizan para conectarse a servidores NetWare.
  • Servicio de nombres de dominio (DNS) se utiliza para resolver nombres de red TCP/IP.
  • Que el servidor NetWare ejecuta TCP/IP además el protocolo compatible con IPX/SPX.
  • Dirección TCP/IP del servidor de NetWare se registra con el servidor DNS, con un nombre DNS idéntico al nombre de servidor de NetWare.



En estas condiciones, Windows intenta resolver el nombre del servidor primero utilizando al cliente de red de NetWare, y luego utiliza al cliente de red de Microsoft. Cuando el servidor NetWare no responde a la solicitud para resolver el nombre de servidor mediante Service Advertising Protocol (SAP), el cliente de red de Microsoft intenta resolver el nombre mediante DNS. Porque el servidor NetWare está registrado con el servidor DNS, el servidor DNS puede resolver que el nombre del servidor NetWare antes que el propio servidor de NetWare pueda responder a la solicitud SAP.

Si este comportamiento se produce cuando existen las condiciones enumeradas anteriormente, el nombre de servidor de NetWare puede marcarse incorrectamente como un nombre de servidor (basado en SMB) de Microsoft cuando se guarda en el registro local. Posteriormente, intenta conectar a ese nombre de servidor consulte la información almacenada en el registro y utiliza primero el cliente de red de Microsoft y intente conectarse utilizando al cliente NetWare sólo después del primer intento agote. Causa de la longitud de los tiempos de espera especificada para la resolución de nombres DNS y las operaciones de conexión de TCP/IP, puede tardar un minuto o más para el primer intento de conexión al servidor NetWare para tiempo de espera después de que Windows intenta conectarse mediante el cliente de NetWare.

Solución

Advertencia : si utiliza incorrectamente el Editor del registro, pueden surgir problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.


Para evitar este problema mediante cualquiera de los métodos siguientes:

  • Utilizar el cliente Microsoft para redes NetWare para conectarse a NetWare servidores, en lugar de Novell IntraNetWare Client. (Actualizar al cliente Novell IntraNetWare puede también resolver el problema causa lentas respuestas a solicitudes SAP.)
  • No registre el servidor NetWare con DNS con un nombre DNS idéntico al nombre de servidor de NetWare.
  • Edite el valor de registro de la entrada de nombre de servidor incorrectamente en caché para que se reconoce correctamente como un servidor NetWare en lugar de un servidor de red de Microsoft (basadas en SMB).

    Estos valores se encuentran en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCACHE\Lookup\ServerNameCache
    Esta clave contiene un número de valores con nombres del "Clave < # >" del formulario donde < # > es un número entre 0000 y el número máximo de nombres de servidor en caché.

    1. En el Editor del registro, busque esta clave y estos valores, haga doble clic a su vez en cada valor y examinar los datos de valor. No realice cambios en los datos del valor.
    2. Cuando se identifican el valor que contiene el nombre del servidor que tiene problemas para conectarse a, tenga en cuenta la parte numérica del nombre de valor (clave < # >).
    3. En la misma clave del registro, busque el valor con un nombre del formulario "Datos < # >" donde < # > es la parte numérica de la clave < #value > del paso 2 anterior. Cada uno de estos valores contiene cuatro bytes de datos, representados como cuatro pares de dígitos hexadecimales. Tenga en cuenta el valor de la tercera de estos cuatro pares. El valor de este byte indica qué cliente de redes está asociado con este nombre de servidor. Un valor de 02 indica un servidor de red de Microsoft. Un valor de 03 indica un servidor Novell NetWare.
    4. Si el tipo de servidor en los datos < #value > es incorrecta (02 en lugar de 03 para un servidor NetWare), haga doble clic en los datos < #value > Editar sus datos de valor. Haga doble clic en el tercer par de dígitos para seleccionarlo, escriba 03 y, a continuación, haga clic en Aceptar.
    5. Salga del Editor del registro y reinicie Windows para que el cambio surta efecto.
    Una vez que se almacena correctamente en caché un nombre de servidor, no normalmente cambiará a un valor incorrecto.
  • Una revisión compatible para Windows 95 y Windows 95 OEM Service Release 2, 2.1 y 2.5 que corrige este problema ahora es de Microsoft, pero no ha sido completamente probado de regresión y debe aplicarse sólo a equipos experimentando este problema específico. Para resolver este problema inmediatamente, póngase en contacto con soporte técnico de Microsoft para obtener la revisión.

    Esta corrección para Windows 95 (versión comercial) debe tener los siguientes atributos de archivo (o posterior):

          File name    Version    Date       Time     Size
          --------------------------------------------------------
          Vcache.vxd   4.00.950   11/18/97   7:58pm   19,590 bytes
    
    						


    Esta corrección para Windows 95 OEM Service Release 2, 2.1 y 2.5 debe tener los siguientes atributos de archivo (o posterior):

          File name    Version     Date       Time     Size
          ---------------------------------------------------------
          Vcache.vxd   4.00.1111   10/31/97   4:09pm   41,752 bytes
    						


    Esta revisión permite la caché nombreDeServidor deshabilitará completamente, si el valor del Registro siguiente está establecido en un valor de datos de cero:

          Key:   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\ 
                    VCACHE\Lookup\ServerNameCache
          Value: MaxElements
          Data:  00 00 00 00   (to disable Server Name Cache)
    						


    El paquete instala esta revisión automáticamente, establece este valor del registro a cero para deshabilitar la caché de nombre del servidor.

    Con este valor se establece en cero, la caché de nombre del servidor no utiliza resolver nombres de servidor de red y nuevas entradas no se agregan a la caché de nombre del servidor como servidor de nombres se resuelven.



Esta funcionalidad se incluye en Microsoft Windows 98 y puede habilitarse estableciendo el valor de registro de "MaxElements" a cero, tal como se documenta anteriormente.

Estado

Microsoft ha confirmado que se trata de un problema de Microsoft Windows 95 y OEM Service Release 2 (OSR2).

Más información

Este problema está documentado en Novell Knowledge Base como documento 2929988, "Bajo rendimiento de cliente debido a la consulta DNS." Puede tener acceso a la base del conocimiento Novell desde la siguiente ubicación de Internet:
http://support.novell.com

La información de contacto con otros proveedores incluida en este artículo se ofrece para ayudarle a encontrar el soporte técnico que necesita. Esta información de contacto está sujeta a cambios sin previo aviso. Microsoft no ofrece ninguna garantía con respecto a la exactitud de esta información de contacto con otros proveedores.

Para obtener información adicional acerca de los hotfix (revisiones) de Windows 98 y Windows 98 Segunda edición, haga clic en el número de artículo para verlo en Microsoft Knowledge Base:
206071Información general acerca de las revisiones de Windows 98 y Windows 98 Segunda edición
Para obtener información adicional acerca de las revisiones de Windows 95, haga clic en el número de artículo para verlo en Microsoft Knowledge Base:
161020Implementación de las actualizaciones de Windows 95

Propiedades

Id. de artículo: 194827 - Última revisión: martes, 4 de febrero de 2014 - Versión: 1.3
La información de este artículo se refiere a:
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Palabras clave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kb3rdpartynetclient kbnetwork kbprb KB194827 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 194827

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