Délais de connexion aux serveurs NetWare dans un réseau mixte

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Numéro d'article: 194827 - Voir les produits auxquels s'applique cet article
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IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, veillez à sauvegarder et assurez-vous que vous savez comment le restaurer en cas de problème. Pour savoir comment sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
256986Description du Registre Microsoft Windows
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Symptômes

Lorsque vous travaillez dans un environnement de serveur réseau mixte, connecter aux serveurs Novell NetWare (à l'aide IntraNetWare de [Client32] version de Novell 2.2) à Microsoft Windows NT et les autres serveurs SMB (à l'aide client de Microsoft pour les réseaux Microsoft), qui se connectent à un serveur NetWare peut parfois prendre beaucoup de temps.

Cause

Ce problème peut se produire si toutes les conditions suivantes existent :

  • TCP/IP est utilisé pour se connecter aux serveurs de réseau Microsoft.
  • Le protocole compatible IPX/SPX et IntraNetWare Client 2.2 de Novell sont utilisés pour se connecter aux serveurs NetWare.
  • DNS (Domain Name Service) est utilisé pour résoudre les noms de réseau TCP/IP.
  • Le serveur NetWare est en cours d'exécution des TCP/IP avec le protocole compatible IPX/SPX.
  • L'adresse TCP/IP du serveur NetWare est enregistrée avec le serveur DNS, avec un nom DNS identique au nom de serveur NetWare.



Dans ces conditions, Windows tente de résoudre le nom du serveur d'abord à l'aide du client de réseau NetWare, puis à l'aide du client réseau Microsoft. Lorsque le serveur NetWare ne répond pas à la demande de résoudre le nom de serveur à l'aide de SAP (Service Advertising Protocol), le client réseau Microsoft tente de résoudre le nom à l'aide de DNS. Car le serveur NetWare est enregistré avec le serveur DNS, le serveur DNS peut être en mesure de résoudre que le nom du serveur NetWare plus tôt que le serveur NetWare lui-même peut répondre à la demande SAP.

Si ce problème se produit lorsque les conditions ci-dessus sont remplies, le nom du serveur NetWare peut être marqué de façon incorrecte comme un nom de serveur (basé sur SMB) de Microsoft lorsqu'elle est enregistrée dans le Registre local. Par la suite, tentatives de connexion à ce nom de serveur reportez-vous aux informations stockées dans le Registre et utilisent d'abord le client réseau Microsoft et essaient de vous connecter en utilisant le client NetWare uniquement après la première tentative expire. En raison de la durée des délais spécifiés pour la résolution de noms DNS et les opérations de connexion TCP/IP, peut prendre une minute ou plus pour la première tentative de connexion au serveur NetWare soit écoulé, après laquelle Windows essaie de se connecter en utilisant le client NetWare.

Résolution

Avertissement : Si vous utilisez l'Éditeur du Registre incorrectement, vous exposez à de graves problèmes pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que vous puissiez résoudre les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls.


Vous pouvez contourner ce problème en utilisant l'une des méthodes suivantes :

  • Utiliser le Client Microsoft pour les réseaux NetWare pour vous connecter à NetWare serveurs, au lieu de Novell IntraNetWare Client. (Mise à niveau de Novell IntraNetWare Client peut également résoudre le problème à l'origine des réponses lentes aux demandes SAP.)
  • Ne s'enregistrent pas le serveur NetWare dans DNS avec un nom DNS identique au nom de serveur NetWare.
  • Modifiez la valeur de Registre pour l'entrée du nom de serveur incorrectement mis en cache afin qu'il est correctement reconnu comme un serveur NetWare au lieu d'un serveur réseau Microsoft (mode SMB).

    Ces valeurs se trouvent sous la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCACHE\Lookup\ServerNameCache
    Cette clé contient un nombre de valeurs avec des noms de la forme «Clé < # >» où < # > est un nombre à partir de 0000 au nombre maximal de noms de serveurs mis en cache.

    1. Dans l'Éditeur du Registre, recherchez cette clé et ces valeurs, double-cliquez sur chaque valeur à son tour et examiner les données de valeur. Ne pas modifier les données de valeur.
    2. Lorsque vous identifiez la valeur contenant le nom du serveur que vous rencontrez des difficultés à vous connecter à, notez la partie numérique de la valeur nom (clé < # >).
    3. Dans la même clé de Registre, recherchez la valeur avec le nom de l'écran «Données < # >» où < # > est la partie numérique de la clé < #value > à partir de l'étape 2 ci-dessus. Chacune de ces valeurs contenir quatre octets de données, représentées par quatre paires de chiffres hexadécimaux. Notez la valeur de la troisième de ces quatre paires. La valeur de cet octet indique quel client d'accès réseau est associé à ce nom de serveur. La valeur 02 indique un serveur réseau Microsoft. La valeur 03 indique un serveur Novell NetWare.
    4. Si le type de serveur dans les données < #value > est incorrect (02 au lieu de 03 pour un serveur NetWare), double-cliquez sur le < #value > des données à modifier ses données de valeur. Double-cliquez sur la troisième paire de chiffres pour le sélectionner, tapez 03 et puis cliquez sur OK.
    5. Quittez l'Éditeur du Registre et redémarrez Windows pour que la modification prenne effet.
    Une fois un nom de serveur est correctement mis en cache, il pas normalement devient une valeur incorrecte.
  • Un correctif pris en charge pour Windows 95 et Windows 95 OEM Service Release 2, 2.1 et 2.5 qui résout ce problème est désormais disponible auprès de Microsoft, mais n'a pas été entièrement tests de régression et doit être appliqué uniquement aux ordinateurs rencontrant ce problème spécifique. Pour résoudre ce problème immédiatement, contactez le support technique de Microsoft pour obtenir le correctif.

    Ce correctif pour Windows 95 (version commercialisée) doit comporter les attributs de fichier suivants (ou version ultérieure) :

          File name    Version    Date       Time     Size
          --------------------------------------------------------
          Vcache.vxd   4.00.950   11/18/97   7:58pm   19,590 bytes
    
    						


    Ce correctif pour Windows 95 OEM Service Release 2, 2.1 et 2.5 doit comporter les attributs de fichier suivants (ou version ultérieure) :

          File name    Version     Date       Time     Size
          ---------------------------------------------------------
          Vcache.vxd   4.00.1111   10/31/97   4:09pm   41,752 bytes
    						


    Ce correctif permet de la mémoire cache de nom du serveur à désactiver entièrement, si la valeur de Registre suivante est une valeur de données égale à zéro :

          Key:   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\ 
                    VCACHE\Lookup\ServerNameCache
          Value: MaxElements
          Data:  00 00 00 00   (to disable Server Name Cache)
    						


    Le package qui installe automatiquement ce correctif définit cette valeur de Registre à zéro pour désactiver le cache de nom du serveur.

    Avec cette valeur est définie sur zéro, le cache de nom du serveur sert pas lorsque la résolution noms de serveur de réseau et les nouvelles entrées ne sont pas ajoutés au cache de nom du serveur comme serveur de noms sont résolus.



Cette fonctionnalité est incluse dans Microsoft Windows 98 et peut être activée en définissant la valeur de Registre «MaxElements» à zéro, comme indiqué ci-dessus.

Statut

Microsoft a confirmé l'existence de ce problème dans Microsoft Windows 95 et OEM Service Release 2 (OSR2).

Plus d'informations

Ce problème est documenté dans la base de connaissances Novell en tant que document 2929988, «Slow Client Performance en raison d'une requête DNS». La base de connaissances de Novell est accessible à partir de l'adresse suivante :
http://support.novell.com

Les informations de contacts tiers incluses dans cet article sont fournies pour vous aider à trouver l'assistance technique que vous avez besoin. Les informations de contact sont sujettes à modification sans préavis. Microsoft ne garantit l'exactitude des informations concernant les tiers.

Pour plus d'informations sur les correctifs Windows 98 et Windows 98 Deuxième Édition, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
206071Informations générales sur Windows 98 et les correctifs de Windows 98 Deuxième Edition
Pour plus d'informations sur les correctifs de Windows 95, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
161020Mise en ?uvre des mises à jour de Windows 95

Propriétés

Numéro d'article: 194827 - Dernière mise à jour: jeudi 30 janvier 2014 - Version: 1.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Mots-clés : 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kb3rdpartynetclient kbnetwork kbprb KB194827 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 194827
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