XADM: IS desliga com JET relatório fora do espaço em disco devido a SFM

Traduções deste artigo Traduções deste artigo
ID do artigo: 196217 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sintomas

O armazenamento de informações Microsoft Exchange Server desliga próprio quando o mecanismo de banco de dados Jet (EDB) relata que o disco rígido que contém os logs de transação está completo. Esse problema também pode ocorrer quando há espaço em disco suficiente disponível, mas os logs de transação estão contidos em um serviços para Macintosh (SFM) de volume.

Aparecerá a seguinte seqüência de eventos nos logs de eventos de aplicativo do Windows NT antes ao armazenamento de informações sendo encerrado:

   Event ID:    32
   Source:      EDB
   Type:        Error
   Category:    Logging/Recovery
   Description: MSExchangeIS ((273) ) Unable to create the log. The drive
                may be read-only or out of disk space. Error -1811.
				
   Event ID:    1111
   Source:      MSExchangeIS
   Type:        Error
   Category:    General
   Description: An error occurred while writing to the database log file.
                Attempting to stop the Microsoft Exchange Information
                Store.
				
   Event ID:    1101
   Source:      MSExchangeIS Private
   Type:        Error
   Category:    Background Cleanup
   Description: Error -510 occurred during a background cleanup on message
                1-E85.
				
   Event ID:    1101
   Source:      MSExchangeIS Private
   Type:        Error
   Category:    Background Cleanup
   Description: Error -510 occurred during a background cleanup on message
                1-E8C.
				
   Event ID:    1025
   Source:      MSExchangeIS Private
   Type:        Warning
   Category:    Transport General
   Description: An error occurred. Function name or description of problem:
                EcDoDeliverMessage Error: -510
				
   Event ID:    1101
   Source:      MSExchangeIS Private
   Type:        Error
   Category:    Background Cleanup
   Description: Error -510 occurred during a background cleanup on message
                1-E93.
				
   Event ID:    5004
   Source:      MSExchangeSA
   Type:        Error
   Category:    General
   Description: Generation of the offline Address Book is complete. Result:
                The Microsoft Exchange Server computer is not available.
                Either there are network problems or the Microsoft Exchange
                Server computer is down for maintenance. Microsoft Exchange
                Server Information Store ID no: 8004011d-0525-00000000.
				
Depois que o armazenamento de informações foi desligado propriamente dito, o administrador pode reiniciar o armazenamento de informações desde que haja espaço em disco suficiente disponível.

Causa

Esse problema pode ocorrer quando SFM foi instalado no computador do Exchange Server e os logs de transação do Jet (DSADATA e MDBDATA) residem em um volume Macintosh. Depois que o armazenamento de informações foi desligado próprio após o erro tiver ocorrido, o byte zero Edbtmp.log ou zero byte edb.log arquivo será deixado na pasta MDBDATA. Essa condição de erro surge quando o arquivo edb.log está cheio e precisa ser revertida para o próximo número de arquivo de log de geração. Um zero arquivo Edbtmp.log de byte é criado pelo Jet e é estendido para um tamanho de arquivo de 5 MB. Em seguida, edb.log é renomeado para o próximo arquivo de log numerado (por exemplo, Edb000xx.log). Edbtmp.log, em seguida, é renomeado para Edb.log e, em seguida, jet continua processando novas mensagens de entrada.

O problema ocorre na transição de renomear esses arquivos quando SFM está envolvido. Com o SFM, existem essencialmente dois índices de arquivo que precise ser mantido: NTFS e AFP (Apple FileShare Protocol). Pode surgir uma condição de tempo em que a atualização AFP ocorre depois que o arquivo já foi renomeado e, portanto, não existe mais sob o nome antigo em NTFS. Em caso afirmativo, SFM irá criar um novo arquivo zero bytes, que faz com que uma condição de erro reporta novamente para Jet "O arquivo já existe." Este erro eventualmente é interpretado pelo Jet como sendo uma falta de condição de espaço em disco e o armazenamento de informações desliga próprio para manter a integridade do banco de dados.

Como Contornar

Esse problema pode ser evitado por não ter os logs de transação de Jet localizados em um volume SFM.

Resolução

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT 4.0 ou a atualização de software individual. Para informações sobre como obter o service pack mais recente, vá para:
  • 152734como obter o service pack mais recente do windows nt 4.0
Para obter informações sobre como obter a atualização de software individual, contate o Atendimento Microsoft. Para obter uma lista completa de números de telefone do Atendimento Microsoft e informações sobre os custos de suporte, visite o seguinte endereço na Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Situação

Microsoft confirmou que este é um problema no Windows NT versão 4.0.Esse problema foi corrigido primeiro no Windows NT versão 4.0 Service Pack 5.

Propriedades

ID do artigo: 196217 - Última revisão: sábado, 22 de fevereiro de 2014 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
  • Microsoft Windows NT 4.0
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe KB196217 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 196217

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com