DHCP クライアントで DHCP サーバーから IP アドレスを取得できない。

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文書番号: 197197 - 対象製品
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目次

現象

Dynamic Host Configuration Protocol (以下、DHCP) クライアントで DHCP サーバーから IP アドレスを取得することができません。

原因

この問題は、次のいずれかの状況によって発生することがあります。

状況1

DHCP サーバーの IP アドレスが変更され、クライアントが IP アドレスを取得できなくなった。

状況2

DHCP クライアントがルーター経由で DHCP サーバーからアドレスを取得できない。

状況3

複数の DHCP サーバーが LAN 上に存在する。

解決方法

それぞれの原因を解決するには、次の解決策のうちのいずれかを実行します。

状況 1 に対する解決策

DHCP サーバーは、ネットワーク ID が DHCP サーバーの IP アドレスのネットワーク ID と同じスコープに対する要求のみをサービスすることができます。

サーバーの IP アドレスが、サービスの対象となるスコープと同じ IP ネットワーク ID にあるかどうかを確認してください。たとえば、サーバーの IP アドレスが 192.168.0.0 ネットワーク内にある場合、スーパー スコープが使用されていない限り、10.0.0.0 などのスコープのアドレスを割り当てることはできません。

関連情報については、次の Microsoft Knowledge Base の資料を参照してください。

139904 How to Configure Your DHCP Server Scope

169140 Using DHCP to Assign IP Addresses to Secondary Networks

169140 [NT] DHCPでセカンタリ ネットワークに IPアドレスを割り当てる

161571 Using DHCP "Superscopes" to Serve Multiple Logical Subnets

状況 2 に対する解決策

RFC 1542 (BOOTP) のリレー エージェントとして機能するルーターによって複数のサブネットが分割されている場合、DHCP サーバーはそれらのサブネット全体にわたるクライアントに IP アドレスを提供することができます。

  1. クライアント セグメントで BOOTP/DHCP リレー エージェントを設定します。これは、ルーターか、または DHCP リレー サービスを実行している Windows NT コンピュータです。
  2. DHCP スコープを、クライアントがあるルーターのもう一方のネットワーク アドレスと一致するように設定します。サブネット マスクが正しいことを確認します。 - DHCP サーバーの NIC に、クライアントが存在するサブネットをサポートしているルーターと同じアドレスのデフォルト ゲートウェイを設定しないでください。- DHCP サーバーの LAN セグメント上に構成されているスーパー スコープには、サブネットのスコープを含めないでください。
  3. サーバーとリモート クライアント間の論理ルートが必ず 1 つだけになるようにしてください。
関連情報については、Microsoft Knowledge Base の次の資料を参照してください。

174765 How to Configure Microsoft DHCP Server for BOOTP Clients
174765 [NT] BOOTP クライアント用に Microsoft DHCP サーバを設定する

状況 3 に対する解決策

重複するスコープがある DHCP サーバーを同じ LAN 上に構成しないようにします。

Small Business Server の場合、LAN 上でほかの DHCP サーバーが検出されると、DHCP サービスは自動的に停止します。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 197197 (最終更新日 2000-01-20) をもとに作成したものです。

プロパティ

文書番号: 197197 - 最終更新日: 2004年2月3日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
キーワード:?
kbprb KB197197
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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