Article ID: 197289 - Last Review: October 28, 2006 - Revision: 3.3 XFOR: Internet Mail Service May Not Save Turfed Messages or Saves Them to an Unexpected LocationThis article was previously published under Q197289 IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base: 256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
SYMPTOMS
Spoofed messages coming into Exchange Server from the Internet Mail Service
may not be saved as configured in the Windows NT registry. The spoofed
messages may be saved on the system drive or not at all.
CAUSE
The Exchange Server Administrator program in Microsoft Exchange Server
version 5.5 Service Pack 1 provides a dialog box (Configuration-Connections-
Internet Mail Service-Connections-Message Filter) for adding originator
domains and user names to the "Turf" table. The Turf table is then used to
filter out incoming messages. If incoming messages are from a user or
domain in the Turf table, the message is not delivered to the Exchange
Server recipient. Instead, it is deleted, or saved in a Turf directory.
This directory is set by default in the Exchange Server Administrator
program to be C:\Turfdir. You can change this location by adjusting the
following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\Services\MSExchangeIMC
\Parameters\Turfdir
However, every time you add a domain or user to the Turf table through the
Message Filter in the Exchange Server Administrator program, the Turf
directory is reset to the default location. If the default location does
not have a Turfdir directory created, the messages will not be saved.
For more information on Turf tables and Turf directories, please see the following Microsoft Knowledge Base articles: RESOLUTIONTo resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
191014
(http://support.microsoft.com/kb/191014/EN-US/
)
XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:Component: Administrator Program Collapse this table
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3. | Article Translations
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