Postup použití Nástroje pro opravu doručené pošty k obnovení zpráv v aplikaci Outlook 2000 s podporou podniků nebo pracovních skupin

Překlady článku Překlady článku
ID článku: 197316 - Produkty, které se vztahují k tomuto článku.
Verzi tohoto článku pro aplikace Microsoft Outlook 2002 a Microsoft Office Outlook 2003 naleznete pod číslem 287497.
Verzi tohoto článku pro aplikaci Microsoft Outlook 2000 (IMO) naleznete pod číslem 197315.
Verzi tohoto článku pro aplikaci Microsoft Outlook 98 (CW) naleznete pod číslem 181325.
Verzi tohoto článku pro aplikaci Microsoft Outlook 98 (IMO) naleznete pod číslem 181523.
POZNÁMKA: Postupy v tomto článku platí pouze pro aplikaci Outlook nainstalovanou s volbou Pracovní nebo podniková skupina. S touto volbou můžete využívat služby rozhraní MAPI (Messaging Application Programming Interface). Chcete-li zjistit, jaký typ instalace byl použit, klepněte v nabídce Nápověda na příkaz O aplikaci Microsoft Outlook. Máte-li nainstalovanou volbu Podniková nebo pracovní skupina, je zde položka „Podniková nebo pracovní skupina“.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

V
tomto článku je popsán postup obnovení složek a položek z poškozeného souboru osobních složek (PST) pomocí Nástroje pro opravu doručené pošty.  

Další informace

POZNÁMKA: Níže uvedené příklady platí pro použití Nástroje pro opravu doručené pošty u souboru PST. Stejné postupy lze použít i u souboru složek offline (OST). Chcete-li vyhledat soubor složek offline (OST), vyberte v okně Vyberte soubor ke kontrole položku Složky offline (*.ost).

Nástroj pro opravu doručené pošty (Scanpst.exe) pomáhá při opravě problémů souvisejících se soubory osobních složek (PST). Tento nástroj lze použít také k opravám souborů složek offline (OST).

Nástroj pro opravu doručené pošty se dodává se systémem Microsoft Windows 95 a je rovněž na disku CD-ROM aplikace Microsoft Outlook 98 i na disku sady Microsoft Office 2000. Instaluje se automaticky současně s produktem. Tento nástroj se dále instaluje v rámci instalace Kurýrní služby systému Windows umístěné na disku CD-ROM se systémem Microsoft Windows 98. Tyto programy naleznete v následující složce:
<jednotka CD>:\tools\oldwin95\message\wms.exe
V systému Windows 2000 naleznete tyto programy v následující složce:
<jednotka CD>:\Program Files\Common Files\System\Mapi\1033\NT\Scanpst.exe

Video: Oprava souborů osobních složek v aplikaci Outlook (PST)

Zmenšit tento obrázekZvětšit tento obrázek
assets video1
uuid=864d6ddc-b810-4c61-9737-9c4a1d6ca023 VideoUrl=http://www.microsoft.com/cs-cz/showcase/details.aspx?uuid=864d6ddc-b810-4c61-9737-9c4a1d6ca023
Zmenšit tento obrázekZvětšit tento obrázek
assets video2


Spuštění Nástroje pro opravu doručené pošty

  1. Klepněte na tlačítko Start a v závislosti na používaném operačním systému přejděte na příkaz Najít nebo Hledat.
  2. Do pole Vyhledat soubory a složky s názvem zadejte název scanpst.exe.
  3. Zadejte název souboru PST (včetně cesty) nebo klepněte na tlačítko Procházet a vyhledejte daný soubor pomocí systému souborů systému Windows.
  4. Klepněte na tlačítko Spustit.

Jak pracuje Nástroj pro opravu doručené pošty

Po spuštění Nástroje pro opravu doručené pošty pro určitý soubor PST (osobní složky) provede tento nástroj následující operace:
  • Nástroj pro opravu doručené pošty provede analýzu hlaviček položek a struktury adresáře souboru osobních složek (PST) a pokusí se obnovit všechny složky a položky.
  • Jestliže Nástroj pro opravu doručené pošty obnoví soubor osobních složek (PST), znamená to, že našel problémy a opravil vše, co bylo možné.
  • Nástroj pro opravu doručené pošty se pokusí změnit jakýkoli soubor na soubor osobních složek (PST). (Pokud například změníte název určitého spustitelného souboru na název Neco.pst, změní Nástroj daný soubor na připojitelný soubor PST).

Obnovený soubor osobních složek

Po spuštění Nástroje pro opravu doručené pošty spusťte aplikaci Outlook s použitím profilu obsahujícího soubor osobních složek (PST), který jste se pokusili opravit. Klepnutím na příkaz Seznam složek v nabídce Zobrazit zobrazte seznam složek. V seznamu složek by měly být zobrazeny následující obnovené složky:
   Obnovené osobní složky

      Kalendář
      Kontakty
      Odstraněná pošta
      Doručená pošta
      Deník
      Poznámky
      Pošta k odeslání
      Odeslaná pošta
      Úkoly
				
Tyto obnovené složky jsou obvykle prázdné, protože se jedná o znovu vytvořený soubor PST. Měla by být zobrazena také složka s názvem Ztráty a nálezy. Tato složka obsahuje složky a položky obnovené Nástrojem pro opravu doručené pošty. Položky, které ve složce Ztráty a nálezy chybí, nelze opravit.

Postup při obnovení opravených položek

Všechny položky ze složky Ztráty a nálezy byste měli přesunout do nového souboru osobních složek (PST) ve svém profilu. Nejdříve vytvořte ve svém profilu novou položku souboru osobních složek (PST), a potom přetáhněte všechny obnovené položky ze složky Ztráty a nálezy do příslušného umístění v novém souboru osobních složek (PST).

Vytvoření nového souboru osobních složek (PST) v profilu

  1. Spusťte aplikaci Outlook s použitím profilu obsahujícího obnovené soubory osobních složek (PST).
  2. V nabídce Soubor klepněte na příkaz Správa datových souborů.
  3. Klepnutím na tlačítko Přidat otevřete dialogové okno Nový datový soubor aplikace Outlook.
  4. V poli Typy úložišť vyberte klepnutím položku Soubor osobních složek (PST) a potom klepněte na tlačítko OK.
  5. V dialogovém okně Vytvořit nebo otevřít datový soubor aplikace Outlook klepněte na adresář a název nového souboru osobních složek (PST) a potom klepněte na tlačítko Otevřít.
  6. Klepněte na tlačítko OK.
V profilu by měl být vytvořen nový soubor osobních složek (PST). Přetáhněte obnovené položky ze složky Ztráty a nálezy do nového souboru osobních složek (PST). Po přesunutí všech položek můžete obnovený soubor osobních složek (PST) včetně složky Ztráty a nálezy odebrat ze svého profilu.

Obnovení položek ze záložního souboru osobních složek (PST)

POZNÁMKA: Nelze-li původní soubor osobních složek (PST) před spuštěním Nástroje pro opravu doručené pošty otevřít, je možné, že následující postupy nebudou fungovat. Jestliže lze původní soubor osobních složek (PST) otevřít, je možné, že následující postupy umožní obnovit další položky z poškozeného souboru osobních složek (PST).

Při spuštění Nástroje pro opravu doručené pošty je vybrána možnost pro vytvoření záložní kopie původního souboru osobních složek (PST). Při použití této možnosti je na pevném disku vytvořen soubor s názvem <název_souboru>.BAK, který je kopií původního souboru <název_souboru>.PST s jinou příponou. Soubor s příponou BAK je uložen v adresáři původního souboru osobních složek (PST).

Je možné, že ze souboru s příponou BAK budete moci obnovit položky, které nebylo možné obnovit pomocí Nástroje pro opravu doručené pošty. Vytvořte kopii souboru s příponou BAK, přičemž souboru přiřaďte nový název s příponou PST (například Nový_název.PST).

Spusťte aplikaci Outlook s použitím profilu obsahujícího nový soubor osobních složek (PST) z kroku 4 uvedeného v části Obnovení opravených položek tohoto článku a pokuste se importovat složku Nový_název.PST pomocí Průvodce importem a exportem. Postup:
  1. V nabídce Soubor klepněte na příkaz Import a export.
  2. Klepněte na položku Import z jiného programu nebo souboru a potom na tlačítko Další.
  3. Klepnutím vyberte položku Soubor osobních složek (.pst) a potom klepněte na tlačítko Další.
  4. Do pole Importovat soubor zadejte název Nový_název.PST. Ve skupinovém rámečku Možnosti klepněte na přepínač Neimportovat duplicitní položky a potom klepněte na tlačítko Další.
  5. V seznamu Vyberte složku, ze které chcete importovat vyberte klepnutím soubor osobních složek (PST), zaškrtněte políčko Včetně vnořených složek, klepněte na přepínač Importovat položky do stejné složky v, klepněte na nový soubor osobních složek (PST) z kroku 4 uvedeného v části Obnovení opravených položek tohoto článku a potom klepněte na tlačítko Dokončit.
POZNÁMKA: Nezapomeňte, že záložní soubor byl vytvořen z původního poškozeného souboru, a proto se může stát, že nebudete moci obnovit nic jiného, než co bylo obnoveno ve složce Ztráty a nálezy. Pokud není možné importovat soubor Nový_název.PST do aplikace Outlook, došlo ke ztrátě veškerých informací, které nejsou ve složce Ztráty a nálezy.

Obnovení osobní složky (PST) o velikosti 2 GB

Horní hranice velikosti souboru osobních složek (PST) je dva gigabajty. Když se velikost osobní složky (souboru PST) k této hranici blíží, v některých případech není možné ukládat nebo načítat položky. Totéž omezení platí pro složky offline (soubory OST).

Společnost Microsoft vyvinula nástroj, který se pokusí o obnovení položek uložených v souboru osobních složek (PST) snížením velikosti souboru pod kritickou hranici. Pomocí tohoto nástroje lze obnovit maximální množství dat za cenu ztráty určité části dat.

Další informace o omezení velikosti souborů PST a nástroji pro zkrácení souborů PST a OST naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
296088 Nástroj pro zkrácení příliš velkých souborů PST a OST

Vlastnosti

ID článku: 197316 - Poslední aktualizace: 22. března 2013 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Outlook 2000 Standard Edition
Klíčová slova: 
kbcorrupt kbrepair kbhowto kbvideocontent KB197316

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com