Article ID: 198941 - Last Review: November 1, 2006 - Revision: 3.4 Users Cannot Change Password When Logging OnThis article was previously published under Q198941 On This PageSYMPTOMS
When a user on a computer running Windows NT Workstation logs on with an expired password and is prompted to change the password, he or she receives either of the the following errors:
You do not have permission to change your password.
Unable to change the password on this account (C00000BE). Please consult your system administrator.
CAUSE
Users can receive the above error messages under a variety of conditions. The underlying cause for these errors is a security registry change involving the RestrictAnonymous value. For additional information about the RestrictAnonymous value, please see the following
articles in the Microsoft Knowledge Base: 143474
(http://support.microsoft.com/kb/143474/EN-US/
)
Restricting Information Available to Anonymous Logon Users
Scenario 1In this scenario, the following conditions are true:
You do not have permission to change your password.
If the password meets the password requirements, the password should be changed successfully. The error text is reported incorrectly and should state that the user's password does not meet the domain policy. This issue is addressed in SP4.
Scenario 2In this scenario, the following conditions are true:
Unable to change the password on this account (C00000BE). Please consult your system administrator.
Because a null session is used for this password change, the operation fails.
Scenario 3In this scenario, administrators can have the "Users must log on in order to change password" account policy enabled. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:135060
(http://support.microsoft.com/kb/135060/EN-US/
)
Access Denied Attempting to Change Client Domain Password
RESOLUTION
To work around this problem, remove the RestrictAnonymous entry or set the value to 0, and then restart the PDC. This workaround will resolve both scenarios above. In scenario 2, upgrading the clients to Service Pack 4 will also resolve the problem.
MORE INFORMATION
For additional information, see the following article or articles in the
Microsoft Knowledge Base: 196289
(http://support.microsoft.com/kb/196289/EN-US/
)
PRB: SP3 Clients Cannot Change Passwords - Error C00000BE
161990
(http://support.microsoft.com/kb/161990/EN-US/
)
How to Enable Strong Password Functionality in Windows NT
174076
(http://support.microsoft.com/kb/174076/EN-US/
)
Invalid Password Message When Strong Passwords Are Required
158388
(http://support.microsoft.com/kb/158388/EN-US/
)
Useful Resource Kit Utilities for Domain Administrators
812530
(http://support.microsoft.com/kb/812530/
)
You Do Not Have Permission to Change Your Password" Error Message When You Change Your Password At Logon
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