启用日志记录时,用户不能更改密码

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症状

当运行 Windows NT 工作站的计算机上的用户使用过期密码登录,并更改密码提示时,他或她接收的任何一个,以下错误:
您没有权限更改您的密码。
-或者-
无法更改此帐户 (C00000BE) 上的密码。请查阅您的系统管理员联系。

原因

用户可以收到上述错误消息,在各种情况下。 这些错误的根本原因是安全注册表更改涉及 RestrictAnonymous 值。有关 RestrictAnonymous 值的其他信息,请参阅 Microsoft 知识库中下面的文章:
143474 限制对匿名登录用户可用的信息

方案 1

在这种情况下满足以下条件为真:
  • PDC 上启用 RestrictAnonymous。
  • 运行 Service Pack 3 (SP3) 主域控制器 (PDC)。
  • 客户端运行的 SP3。
  • 在域通过 Passfilt.dll 或从 Windows NT 的资源工具包 Passprop.exe 上强制执行强密码或域帐户策略在用户管理器中指定最小密码长度。
如果该客户机试图登录时更改已过期的密码,并且它不符合密码的要求将显示以下错误消息:
您没有权限更改您的密码。
如果密码符合密码要求,应成功更改密码。错误文本会错误地报告,并应该声明用户的密码不符合域策略。 此问题得到解决在 SP4 中。

方案 2

在这种情况下满足以下条件为真:
  • PDC 上启用 RestrictAnonymous。
  • PDC 正在运行 Service Pack 4 (SP4)。
  • 客户端运行的 SP3。
如果客户端在登录时更改已过期的密码将显示以下错误消息:
无法更改此帐户 (C00000BE) 上的密码。请查阅您的系统管理员联系。
因为空会话用于此密码更改,则操作将失败。

方案 3

在这种情况下管理员可以启用"用户必须登录才能更改密码"帐户策略。有关更多的信息请单击下面文章编号,以查看 Microsoft 知识库中相应的文章:
135060试图更改客户端域密码拒绝访问

解决方案

若要变通解决此问题,删除 RestrictAnonymous 条目或将值设置为 0,然后重新启动 PDC。 此变通办法可以解决上述这两种方案。 在应用场景 2 Service Pack 4 到升级客户端将也解决此问题。

更多信息

有关更多的信息,请参阅下面的文章或 Microsoft 知识库中相应的文章:
196289PRB: SP3 客户端不能更改密码的错误 C00000BE
161990如何启用在 Windows NT 的强密码功能
174076强密码要求时的无效密码消息
158388域管理员的有用资源工具包实用程序
812530您没有权限更改密码"更改密码在登录时出现错误信息

属性

文章编号: 198941 - 最后修改: 2006年11月1日 - 修订: 3.4
这篇文章中的信息适用于:
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Server 4.0 Terminal Server(终端服务器)
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 开发员版
关键字:?
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