System DSN Entries Do Not Appear in ODBC Data Source Administrator (odbcad32.exe)

Article translations Article translations
Close Close
Article ID: 2000277 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When using ODBC administrator (odbcad32.exe) to configure system DSNs you may notice one of the following symptoms though you have sufficient privileges on the system:

  • You are not able to view and configure some or all of the existing DSNs.
  • You create a new DSN using the Add button and walking through the various steps in the Create New Data Source wizard, but the DSN does not show up in the list even after the Test Data Source reports success. If you try to recreate the DSN with the same name, you get an error that is similar to the following:

'DSN name'is already a data source name. Overwrite?

Cause

The following registry sub key has an incorrect value:

HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources\(Default)

The value for this key should always be  (value not set). If the value is set (either by a third party application or inadvertently) to an empty string or some other value you will run into problems described in the Symptoms section.

Resolution

Use one of the following methods to resolve the problem:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

  • 322756 How to back up and restore the registry in Windows

Method 1:

  1. Go to Start | Run and enter the following: regedit 
  2. Click OK and the Registry Editor will open. 
  3. Navigate to the following location: HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources.
  4. Right-click the key called ' (Default) ' and select Delete. 
  5. If unable to delete the key, double-click the key and erase the Data value entered. Once done, the value should read ' (value not set) '. 
  6. Close the Registry Editor and all previously created System DSNs should now appear in the ODBC Data Source Administrator.

Method 2: . You can run the following command:

reg.exe DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources" /ve /f

More Information

  • 971987  Error message when you use an ADODB.Connection object with an ODBC driver on a Windows x64-based computer: "Provider is not specified and there is no designated default provider"
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2000277 - Last Review: November 3, 2009 - Revision: 7.0
APPLIES TO
  • Microsoft Data Access Components 2.8
  • Microsoft Data Access Components 2.7
Keywords: 
KB2000277

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com