Sharepoint 2007 alert emails fail to send

Article ID: 2000689 - View products that this article applies to.
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Symptoms

SharePoint alert emails are not being received by users. Users do not even get the initial email that says you signed up for an alert. All other outgoing email functions are also not working. Sometimes subnew.aspx page when creating an alert hangs after clicking OK, however the alert entry gets created in ImmedSubscriptions table in the content database.

Cause

SharePoint opens a socket to the SMTP server via port 25 without specifying the socket type.
If in the winsock catalog an LSP provider which defaults to UDP sockets is placed before the TCP, SharePoint will try to open the SMTP connection on UDP port which will be opened successfully, but the receive call will timeout since no SMTP server listens on UDP (SMTP servers only listen on TCP 25)

This happens usually when Vmware machines or when Vmware tools were installed.
In the affected systems usually the RSVP UDP Service Provider was placed above MSAFD Tcpip [TCP/IP]

Winsock test . . . . . . . . . . . : Passed
The number of protocols which have been reported : 10
Description: RSVP UDP Service Provider
Provider Version :6
Description: RSVP TCP Service Provider
Provider Version :6
Max message size : Stream Oriented
Description: MSAFD Tcpip [TCP/IP]
Provider Version :2
Max message size : Stream Oriented
Description: MSAFD Tcpip [UDP/IP]
Provider Version :2

You can check it with the "netsh winsock show catalog" command.

Resolution

Change the winsock provider order with the sporder.exe tool.
Make sure the MSAFD Tcpip [TCP/IP] is placed above any UDP providers.
sporder.exe is a GUI tool part of the windows platform SDK
http://msdn.microsoft.com/en-us/library/ms740483(VS.85).aspx

Warning: the sporder.exe can only change the x86 winsock provider order.

On x64 machines you need to change the order with the tool, then fix x64 the catalog

  1. Backup the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2\Parameters\Protocol_Catalog9 registry hive with regedti.exe into winsock_backup.reg
  2. Export HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2\Parameters\Protocol_Catalog9\Catalog_Entries with subkeys to winsockproviderorderfix64.reg
  3. Open winsockproviderorderfix64.reg in notepad and replace \Catalog_Entries\ with \Catalog_Entries64\  and in the 3rd line replace \Catalog_Entries with \Catalog_Entries64
  4. Save the reg file and double click it to make the changes in the registry

You need to restart the machine to apply the changes to the registry.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Article ID: 2000689 - Last Review: March 12, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft Office SharePoint Server 2007
  • Microsoft Windows SharePoint Services 3.0
Keywords: 
KB2000689

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