SCVMM: Adding a host to System Center Virtual Machine Manager 2008 may fail with error 2912 / 0xc0000BBF

Article ID: 2001247 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When you try to add a host to System Center Virtual Machine Manager 2008, it fails with the following message:

Error (2912)
An internal error has occurred trying to contact an agent on the server.domain.com server.
 (Unknown error (0xc0000bbf))

Recommended Action
Ensure the agent is installed and running. Ensure the WS-Management service is installed and running, then restart the agent.

In the Application log on the host machine that you’re trying to add, the following events may be logged:

WMI, Event 10
Event filter with query "select * from __instancemodificationevent within 30 where targetinstance isa 'Win32_PerfFormattedData_PerfDisk_LogicalDisk' and targetinstance.PercentFreeSpace < 1 and targetinstance.Name != '_Total'" could not be reactivated in namespace "//./root/CIMV2" because of error 0xc0000bbf. Events cannot be delivered through this filter until the problem is corrected.

WMI, Event 5612:
Windows Management Instrumentation has stopped WMIPRVSE.EXE because a quota reached a warning value. Quota: HandleCount  Value: 12853 Maximum value: 12288 WMIPRVSE PID: 7232

 

Cause

This issue occurs when the performance counters are corrupt on the host you are trying to add.

Resolution

Perform the steps documented in the following knowledge base article to manually rebuild the performance counters:

2554336 How to manually rebuild Performance Counters for Windows Server 2008 64bit or Windows Server 2008 R2 systems

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2001247 - Last Review: July 18, 2011 - Revision: 5.0
APPLIES TO
Keywords: 
KB2001247

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com