Media files cannot be viewed from Internet Explorer 8.0

Article ID: 2001329 - View products that this article applies to.
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Symptoms

Using Internet Explorer 8.0 running on Windows 7, you navigate to a web page that contains a link to a media file.  You click on the link to open the media file in Media Player.  Instead of seeing the media open and run in Media Player, you are presented with an error message similar to the following: 

 

"Internet Explorer cannot display the webpage"

 

 

Cause

IE8 and Media Player are not configured properly to allow for media viewing via hyperlinks.

 

Resolution

To resolve this problem, follow the steps below:

 

1.            Open Control Panel.
2.            Click Programs.
3.            Click Default Programs.
4.            Click Set program access and computer defaults.
5.            In the resulting dialog box, click to expand the Custom section.
6.            Under Choose a default media player, click Windows Media Player, then click OK.
7.            Restart Internet Explorer.

 

 

More Information

A problem in Windows 7 that affects the playback of certain media files in Windows Media Player, when Windows Media Player is started from Windows Internet Explorer, has been addressed in the following update:

Update to improve the stability and reliability of Windows 7 and of Windows Server 2008 R2
http://support.microsoft.com/kb/974431

 

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2001329 - Last Review: February 2, 2010 - Revision: 16.0
APPLIES TO
  • Windows Internet Explorer 8, when used with:
    • Windows 7 Home Premium
    • Windows 7 Enterprise
    • Windows 7 Home Basic
    • Windows 7 Starter
    • Windows 7 Ultimate
    • Windows Web Server 2008 R2
    • Windows Server 2008 R2 Datacenter
    • Windows Server 2008 R2 Enterprise
    • Windows Server 2008 R2 Standard
Keywords: 
KB2001329

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