Dojde-li k výpadku napájení krátce po vytvoření jednoduchých svazků, může se stát, že nebudou přístupné

Překlady článku Překlady článku
ID článku: 2001877 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Předpokládejme následující situaci. V systému Windows 7 vytvoříte pomocí nástroje Správa disků nebo DiskPart.exe jednoduchý svazek na nevyměnitelném disku. Pokud v systému Windows 7 dojde v průběhu několika minut po vytvoření tohoto svazku k náhlému výpadku napájení, nebude svazek vytvořený před tímto výpadkem přístupný a po obnovení napájení systému mu nebude přiřazeno písmeno jednotky.

Dále se může stát, že v nástroji Správa disků nebude u tohoto svazku uveden stav (např. V pořádku) nebo typ systému souborů. Pokud se pokusíte upravit tento svazek v nástroji Správa disků, může se zobrazit následující chybová zpráva:

Operace se nezdařila, protože zobrazení konzoly Správa disků není aktuální. Aktualizujte zobrazení pomocí aktualizační úlohy. Pokud potíže potrvají, zavřete konzolu Správa disků a znovu ji spusťte nebo restartujte počítač.

Příčina

K těmto potížím dochází proto, že informace o konfiguraci nového svazku nebyly v okamžiku, kdy došlo k výpadku napájení, zapsány na disk.

Řešení

Chcete-li, abychom tyto potíže vyřešili za vás, přejděte k části Automatická oprava. Chcete-li tyto potíže vyřešit sami, přejděte k části Manuální oprava.

Automatická oprava

Chcete-li tyto potíže odstranit automaticky, klikněte na odkaz Opravit tyto potíže. V dialogovém okně Stažení souboru klikněte na položku Spustit a postupujte podle kroků v průvodci opravou.

Opravit tyto potíže
Microsoft Fix it 50651



Poznámka: Tento průvodce může být k dispozici pouze v angličtině. Tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.

Poznámka: Pokud právě nejste u počítače, který má tyto potíže, můžete automatickou opravu uložit na jednotku USB flash nebo na disk CD a spustit ji v příslušném počítači později.


Poté přejděte k části Byly potíže vyřešeny?.

Manuální oprava

Dochází-li k potížím popsaným v části Příznaky, budou vyřešeny přeinstalací svazku. Chcete-li přeinstalovat svazek, použijte následující postup.

  1. Otevřete Správce zařízení. Chcete-li spustit nástroj Správce zařízení, můžete zadat do pole Spustit hledání text Správce zařízení nebo devmgmt.msc.
  2. Jakmile je Správce zařízení spuštěn, rozbalte kliknutím položku Svazky úložiště stromu zařízení.
  3. V části Svazky úložiště by měl být uveden svazek označený Neznámé zařízení. Klikněte na toto zařízení pravým tlačítkem myši a pak vyberte příkaz Odinstalovat. Po zobrazení výzvy k potvrzení klikněte na tlačítko OK.
  4. Pokud budete vyzváni, restartujte systém. Po dokončení restartování systému by měl být svazek přístupný. Pokud nejste vyzváni k restartování systému, klikněte pravým tlačítkem myši ve Správci zařízení a vyberte příkaz Vyhledat změny hardwaru. Po dokončení vyhledávání a instalace svazku bude svazek přístupný.

Poznámka:Pokud k výpadku napájení dojde v průběhu několika sekund po vytvoření svazku, může se po provedení výše uvedených kroků velmi zřídka zobrazit výzva k formátování svazku. Pokud k tomu dojde, nebyla v okamžiku výpadku napájení zapsána konfigurace systému souborů. Je možné, že bude třeba svazek přeformátovat nebo vytvořit znovu.

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny. Pokud ano, v této části již pro vás nejsou žádné potřebné informace. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Chcete-li nám sdělit svůj názor nebo nahlásit potíže s tímto řešením, uveďte poznámky v blogu Fix it for me (Automatická oprava) nebo nám odešlete e-mailovou zprávu.

Vlastnosti

ID článku: 2001877 - Poslední aktualizace: 31. října 2011 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Windows 7 Starter
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Enterprise
  • Windows 7 Ultimate
Klíčová slova: 
KB2001877

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com