Picture orientation set by a camera is not honored by Windows or Windows applications

Article translations Article translations
Close Close
Article ID: 2001954 - View products that this article applies to.
Expand all | Collapse all

Symptoms

Windows Explorer and Windows applications do not display an image produced on cameras in the orientation in which the picture was taken.

Cause

Some camera manufacturers set the JPEG EXIF Orientation flag based on an orientation sensor built into the camera.  This image attribute is currently not supported by Windows Explorer or the imaging applications that ship with Windows.

Resolution

In order for images to display with the correct orientation, any of the following must occur:

  1. The camera must physically rotate the image instead of performing a “virtual” rotation using the EXIF Orientation flag.
  2. The image viewer application must support the EXIF Orientation flag.
  3. The end user can manually choose to rotate the image 90 degrees and save it.

More Information

The EXIFS orientation flag is considered unreliable because it is not widely supported, and double rotations can occur in the following scenario:

  1. An EXIFS orientation flag is set to flip the image 90 degrees by the camera.
  2. An imaging editing application that does not support the EXIFS orientation flag is used to rotate the image 90 degrees.
  3. The EXIFS orientation flag is not reset due to lack of support by the imaging editing application.
  4. An image viewer generates an upside-down image.  (The original was rotated 90 degrees twice -- once physically and once virtually.)
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2001954 - Last Review: March 27, 2013 - Revision: 3.0
Applies to
  • Windows Vista Service Pack 2
  • Windows Server 2008 Service Pack 2
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows Server 2003 Service Pack 2
  • Windows 7 Service Pack 1
  • Windows Server 2008 R2 Service Pack 1
Keywords: 
KB2001954

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com