You may receive a misleading error message when trying to join a Windows 7 Homegroup, when the computer's date and time does not match the date/time of system that owns the homegroup

Article translations Article translations
Close Close
Article ID: 2002121 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When joining a system to a homegroup, you may receive the following error message "The password is incorrect", even though you have typed the password correctly.

Cause

This can be caused by a difference in the Date and Time settings on the computer trying to join the homegroup, and not an invalid password.  If the date/time of the computer joining a homegroup is greater than 24 hours apart from the date/time of the system that owns the homegroup, this will cause the error.

Resolution

Adjust the date/time settings on the system joining the homegroup, to match the system that owns the homegroup, and then try to join again.

More Information

In this scenario, the authentication certificate is treated as invalid due to the timestamp.  The error returned is simply stating that the authentication failed.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2002121 - Last Review: October 8, 2009 - Revision: 2.0
APPLIES TO
  • Windows 7 Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
Keywords: 
KB2002121

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com