Lorsque vous testez l’accès dans le routeur de messagerie Microsoft Dynamics CRM, vous recevez une erreur « (401) Non autorisé »

Cet article fournit une solution à une erreur qui se produit lorsque vous testez l’accès dans le routeur de messagerie Microsoft Dynamics CRM.

S’applique à : Microsoft Dynamics CRM
Numéro de la base de connaissances d’origine : 2003033

Symptômes

Lorsque vous sélectionnez Tester l’accès dans l’outil de configuration du routeur de messagerie pour Microsoft Dynamics CRM, vous recevez l’erreur suivante pour les messages électroniques entrants :

« État entrant : Échec : le serveur de messagerie Microsoft Exchange distant a retourné l’erreur « (401) Non autorisé ». Vérifiez que vous êtes autorisé à vous connecter à la boîte aux lettres. Le serveur distant a renvoyé une erreur : (401) Non autorisé. »

Cause

Une ou plusieurs des conditions suivantes peuvent provoquer ce problème :

  • Le compte spécifié sur le profil entrant ne dispose pas d’un accès complet aux boîtes aux lettres des utilisateurs.
  • Il manque des noms de principal de service (SPN) lorsqu’un alias est utilisé pour Microsoft Office Outlook Web Access.
  • Le dernier correctif cumulatif pour Microsoft Dynamics CRM n’est pas appliqué.
  • L’authentification sur les répertoires virtuels Exadmin et Exchange est incorrecte.
  • L’URL Outlook Web Access est manquante dans la zone Intranet local dans Windows Internet Explorer sur le serveur sur lequel le routeur de messagerie est installé.

Résolution 1

Vérifiez que le compte spécifié sur le profil entrant dispose d’un accès complet aux boîtes aux lettres des utilisateurs. Vérifiez également que le compte système local démarre le service de routeur Microsoft CRM Email.

Pour vérifier le compte qui démarre le routeur Microsoft CRM Email, procédez comme suit sur le serveur sur lequel le routeur de messagerie est installé :

  1. Sélectionnez Démarrer, Exécuter, tapez Services.msc, puis sélectionnez OK.
  2. Recherchez le service routeur Microsoft CRM Email.

    Remarque

    Compte répertorié dans la colonne Ouvrir une session en tant que, puis vérifiez qu’il est défini sur LocalSystem.

Pour vérifier le compte spécifié pour l’accès au profil entrant, procédez comme suit sur l’ordinateur sur lequel le routeur Microsoft CRM Email est installé :

  1. Sélectionnez Démarrer, Tous les programmes, Microsoft Dynamics CRM Routeur de messagerie, puis Microsoft CRM Email routeur Configuration Manager.

  2. Sélectionnez l’onglet Profils de configuration , double-cliquez sur Profil entrant, puis notez le compte spécifié dans le champ Informations d’identification d’accès . Vérifiez que ce compte dispose d’un accès complet à la boîte aux lettres de l’utilisateur.

    1. Si vous utilisez l’option Transférer la boîte aux lettres pour tous vos utilisateurs et files d’attente, nous vous recommandons d’utiliser les informations d’identification de boîte aux lettres de transfert dans ce champ.
    2. Si vous utilisez l’option Routeur pour vos utilisateurs et vos files d’attente, vous devez vous assurer que le compte spécifié dans le champ Informations d’identification d’accès dispose d’un accès complet aux boîtes de réception de tous ces utilisateurs.

Pour plus d’informations sur l’ajout d’autorisations supplémentaires sur les boîtes de réception des utilisateurs, consultez les articles suivants :

Résolution 2

Si vous utilisez http://mail.domain.com pour accéder à Outlook Web Access, mais que votre nom d’Microsoft Exchange Server est Exchange01, vous devez ajouter d’autres spN sur le compte qui exécute le pool d’applications pour votre site web Exchange.

Pour déterminer le compte qui démarre le pool d’applications Exchange, procédez comme suit :

  1. Connectez-vous au Microsoft Exchange Server.
  2. Sélectionnez Démarrer, Exécuter, tapez Inetmgr, puis sélectionnez OK.
  3. Développez votre serveur dans IIS, puis sélectionnez Pools d’applications.
  4. Le compte qui exécute le pool d’applications Exchange est répertorié dans le volet d’aperçu.

Au compte que vous avez identifié à l’étape 4, ajoutez les SPN suivants :

  • HTTP/Mail
  • HTTP/Mail.yourdomainname.com

Remarque

Vous devez modifier ces SPN pour qu’ils correspondent à l’URL d’alias que vos utilisateurs utilisent pour accéder à Outlook Web Access.

Pour plus d’informations sur l’ajout de SPN, visitez les sites web Microsoft suivants :

Résolution 3

Remarque

Cette résolution s’applique uniquement à Microsoft Dynamics CRM 4.0.

Vérifiez que le correctif cumulatif 3 pour Microsoft Dynamics CRM 4.0 est installé au minimum pour le serveur Microsoft Dynamics CRM et pour le routeur de messagerie Microsoft Dynamics CRM. Le dernier correctif cumulatif est fortement recommandé.

Pour plus d’informations et pour télécharger le dernier correctif cumulatif pour Microsoft Dynamics CRM, consultez [mises à jour et correctifs Microsoft Dynamics CRM 4.0].

Résolution 4

Vérifiez l’authentification suivante sur les /Exchange répertoires virtuels et /Exadmin :

  • Vérifiez que l’authentification de base et l’authentification Windows sont activées sur le /Exadmin répertoire virtuel.
  • Vérifiez que l’authentification de base est activée sur le /Exchange répertoire virtuel.

Pour case activée l’authentification sur les répertoires virtuels, procédez comme suit sur le Microsoft Exchange Server en fonction du système d’exploitation que vous exécutez :

  • Sur Windows Server 2008 :

    1. Sélectionnez Démarrer, Exécuter, tapez Inetmgr, puis sélectionnez OK.
    2. Développez le nom du serveur, développez Sites, puis développez le site web Exchange.
    3. Sélectionnez le répertoire virtuel /Exadmin , ouvrez Authentification dans le volet Aperçu et vérifiez que l’authentification de base et l’authentification Windows sont activées.
    4. Sélectionnez le répertoire virtuel /Exchange , ouvrez Authentification dans le volet Aperçu et vérifiez que l’authentification de base est activée.
  • Sur Windows Server 2003 :

    1. Sélectionnez Démarrer, Exécuter, tapez Inetmgr, puis sélectionnez OK.
    2. Développez le nom du serveur, développez Sites, puis développez le site web Exchange.
    3. Cliquez avec le bouton droit sur le répertoire virtuel /Exadmin , puis sélectionnez Propriétés.
    4. Sélectionnez l’onglet Sécurité de l’annuaire , sélectionnez Modifier sous Authentification et contrôle d’accès, puis vérifiez que l’authentification de base et l’authentification Windows sont activées.
    5. Cliquez avec le bouton droit sur le répertoire virtuel /Exchange , puis sélectionnez Propriétés.
    6. Sélectionnez l’onglet Sécurité de l’annuaire , sélectionnez Modifier sous Authentification et contrôle d’accès, puis vérifiez que l’authentification de base et l’authentification Windows sont activées.

Résolution 5

Ajoutez l’URL d’Outlook Web Access à la zone Intranet local et vérifiez que l’ouverture de session automatique est activée sur le serveur sur lequel le routeur de messagerie Microsoft Dynamics CRM est installé. Pour ce faire, procédez comme suit :

  1. Connectez-vous à l’ordinateur sur lequel le routeur de messagerie CRM est installé à l’aide du compte spécifié dans le profil entrant.

  2. Ouvrez Internet Explorer.

  3. Sélectionnez Outils, puis Options Internet.

  4. Sélectionnez l’onglet Sécurité , sélectionnez Intranet local, puis Sites.

  5. Sélectionnez Avancé, ajoutez l’URL que vous utilisez pour accéder à Outlook Web Access, puis ajoutez l’URL de l’Exchange Server.

  6. Sélectionnez Fermer puis OK.

  7. Assurez-vous que l’option Intranet local est sélectionnée, sélectionnez Niveau personnalisé, puis ouvrir une session automatiquement uniquement dans la zone Intranet.

  8. Sélectionnez OK deux fois, puis sélectionnez Appliquer.

  9. Fermez toutes les sessions de Explorer Internet.

Remarque

Les Explorer Internet peuvent être exécutés dans le contexte d’un compte d’utilisateur spécifique lorsqu’ils sont connectés à Windows en tant que compte d’utilisateur différent. Ir peut être accompli en appuyant sur Maj, puis en cliquant avec le bouton droit sur Internet Explorer exécutable, ce qui affiche l’option permettant d’exécuter Internet Explorer en tant qu’utilisateur différent. Si le Explorer Internet est exécuté dans le contexte du compte de profil entrant sur l’ordinateur sur lequel le routeur de messagerie est installé, il peut être utilisé pour contourner les étapes 1 et 2 ci-dessus.