Article ID: 2004114 - Last Review: October 22, 2010 - Revision: 2.0

You receive the following error when you install Microsoft Dynamics CRM for Microsoft Office Outlook: “Installation cannot proceed”

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Symptoms

You receive the following error when you install Microsoft Dynamics CRM for Microsoft Office Outlook:

Installation cannot proceed: Setup cannot continue because a pending restart is required.  Restart the computer and then try running Setup again.

Cause

The RunOnce registry key exists.

Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

KB322756 How to back up and restore the registry in Windows

Check the the crm40setup.log to identify the registry key that causes the issue.  The crm40setup.log is located in %appdata%\Microsoft\MSCRM\Logs.  Once you have found the registry key, you can delete the registry key with the following steps:

  1. Click Start, click Run and type regedit, and then click OK.
  2. Locate the Registry Key listed in the Setup Log.  For example, the Registry Key is HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce.
  3. Right click RunOnce, and then click Delete.

More Information

Other common registry keys that cause this error:
  • HKEY_CURRENT_USER\Software\Microsoft\Windwos\CurrentVersion\RunOnce
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

APPLIES TO
  • Microsoft Dynamics CRM for Microsoft Office Outlook, when used with:
    • Microsoft Dynamics CRM 4.0
    • Microsoft Dynamics CRM Online Professional Edition
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