Cannot create a connection to data source 'CRM' error occurs when you run a Microsoft Dynamics CRM report in the SRS Report Manager or SRS Report Server

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Article ID: 2006869 - View products that this article applies to.
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Symptoms

 You receive the following errors when you run a Microsoft Dynamics CRM report in the SRS Report Manager or SRS Report Server:

An error has occurred during report processing (rsProcessingAborted)  Cannot create a connection to data source ‘CRM.’ (rsErrorOpeningConnection)  Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).

An error has occurred during report processing. (rsProcessingAborted)
Cannot create a connection to data source 'CRM'. (rsErrorOpeningConnection)
For more information about this error navigate to the report server on the local server machine, or enable remote errors.

Cause

This error occurs in Microsoft Dynamics CRM 4.0 because the Microsoft Dynamics CRM Data Connector for Microsoft SQL Server Reporting Services requires the user's SystemUserId value as the Log in name and the user's OrganizationId value as the password. 

This error occurs in Microsoft Dynamics CRM 2011 because the Microsoft Dynamics CRM Reporting Extensions requires the user's SystemUserId value as the Log in name and the user's OrganizationId value as the password.

When a report runs inside Microsoft Dynamics CRM, these values are passed automatically. These values must be entered manually when the report is run directly from SQL Server Reporting Services.

Resolution

Obtain the SystemUserId and OrganizationId from the database and manually enter the values using the following steps:

  1. Connect to the SQL server machine that contains the Microsoft Dynamics CRM databases as a user that has admin rights to SQL Server.
  2. Click Start, click All Programs, click Microsoft SQL Server, and then click SQL Server Management Studio.
  3. Click New Query.
  4. Click File, click New, and then click Database Engine Query.
  5. Select your <organization>_MSCRM from the dropdown list.
  6. Execute the following query:
    • Select FullName, SystemUserId, OrganizationId 
    • From FilteredSystemUser
    • Order by FullName
  7.  Locate the user that will run the report.
  8. Enter the SystemUserId value into the Login Name box on the report.
  9. Enter the OrganizationId value into the password field on the report.
  10. Run the report.

More Information

This approach should only be used for troubleshooting Microsoft Dynamics CRM reports.  To run Microsoft Dynamics CRM reports outside of Microsoft Dynamics CRM, the reports should be published for external use.  By publishing the report for external use, you will connect to the Microsoft Dynamics CRM data using a SQL server connection string and will not be prompted to enter credentials.

To publish reports for external use, complete the following steps:

  1. Open Microsoft Dynamics CRM, and then click Reports.
  2. Select the report, and then click Edit Report.
  3. Click the Actions menu, and then click Publish Report for External Use.

This will create a copy of the report in the root of the <OrganizationName>_MSCRM folder in SQL Server Reporting Services.  This copy of the report will use the MSCRM_DataSource that is located in the root of the <OrganizationName>_MSCRM folder.  This data source uses Microsoft SQL Server as the Connection type and Windows integrated security.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2006869 - Last Review: January 28, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Dynamics CRM 2011
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbmbsmigrate KB2006869

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