La mise à jour des dossiers est longue lorsqu'un utilisateur Exchange Server 2010 utilise Outlook 2003 en mode en ligne

Numéro d'article: 2009942 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Lorsque vous accédez à la boîte aux lettres Microsoft Exchange Server 2010 via Microsoft Office Outlook 2003 en mode en ligne, les erreurs suivantes sont susceptibles de se produire :

  • Les messages électroniques sortants restent dans le dossier Boîte d'envoi pendant environ 1 minute.
  • Les nouveaux messages électroniques n'atteignent pas le dossier Boîte de réception immédiatement et sont retardés pendant environ 1 minute.
  • Les éléments supprimés des dossiers restent affichés dans le dossier pendant environ 1 minute.
  • Les éléments déplacés entre dossiers restent affichés dans le dossier d'origine pendant environ 1 minute.

Les mises à jour du dossier ne se produisent pas dans un délai raisonnable.

Cause

Ces problèmes se produisent, car Exchange Server 2010 n'envoie pas de notifications du protocole UDP (User Datagram Protocol) dans Outlook.

Outlook 2003 utilise des notifications UDP comme principale méthode de réception des notifications d'un serveur Exchange. Outlook 2003 doit cependant interroger le serveur Exchange Server 2010 pour connaître les modifications, et la fréquence d'interrogation d'Outlook est d'environ 60 secondes. Par conséquent, la mise à jour d'un dossier peut être retardée jusqu'à 1 minute.

Résolution

Pour résoudre ce problème, installez le correctif cumulatif 3 pour le Exchange Server 2010 Service Pack 1.

Pour plus d'informations sur le correctif cumulatif 3 pour le Service Pack 1 de Microsoft Windows Server 2010, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.

2529939 Description du correctif cumulatif 3 pour le Service Pack 1 de Microsoft Exchange Server 2010

Après avoir installé cette mise à jour, vous devez créer une sous-clé de Registre pour activer la fonctionnalité de prise en charge des notifications UDP.

Pour que nous activions la fonctionnalité de prise en charge des notifications UDP à votre place, consultez la section « Aidez-moi ». Si vous préférez activer la fonctionnalité de prise en charge des notifications UDP vous-même, consultez la section « Je résous le problème moi-même ».

Aidez-moi

Pour résoudre automatiquement ce problème, cliquez sur le lien Résoudre ce problème. Cliquez ensuite sur Exécuter dans la boîte de dialogue Téléchargement de fichier et suivez la procédure indiquée par cet Assistant.

Résoudre ce problème
Microsoft Fix it 50689



Remarque Cet Assistant peut n'exister qu'en anglais. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.

Remarque Si vous n'êtes pas sur l'ordinateur pour lequel le problème existe, vous pouvez enregistrer la résolution automatique sur un lecteur flash ou sur un CD-ROM afin de pouvoir l'exécuter sur l'ordinateur concerné par le problème.

Je résous le problème moi-même

Créez la sous-clé de Registre suivante pour activer la fonctionnalité de prise en charge des notifications UDP :

Emplacement de la sous-clé : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

Nom de la sous-clé : EnablePushNotifications

Type : REG_DWORD

Valeur : 1

Remarque Si cette clé de Registre n'existe pas ou si sa valeur est définie sur 0, les fonctionnalités de prise en charge des notifications UDP ne sont pas actives.

Contournement

Pour contourner ce problème, activez le mode Exchange mis en cache dans Outlook 2003. Pour cela, procédez comme suit :

  1. Quittez Outlook 2003, s'il est en cours d'exécution.
  2. Dans le panneau de configuration, cliquez sur Courrier.
  3. Cliquez sur Comptes de messagerie.
  4. Sélectionnez Afficher ou modifier les comptes de messagerie existants, puis cliquez sur Suivant.
  5. Entrez un compte Microsoft Exchange Server, puis cliquez sur Modifier.
  6. Activez la case à cocher Utiliser le mode Exchange mis en cache.
  7. Cliquez sur Suivant, puis sur Terminer.
  8. Démarrez Outlook 2003.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Plus d'informations

Pour vérifier si les notifications de type push fonctionnent, procédez comme suit :

1.Créez la sous-clé de Registre suivante sur le serveur CQS pour activer les notifications de type push :

Emplacement de la sous-clé : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

Nom de la sous-clé : EnablePushNotifications

Type : DWORD

Valeur : 1

Remarque Si la sous-clé ParametersSystem n'existe pas, créez-la.

2.Créez la sous-clé de Registre suivante sur l'ordinateur client pour configurer Outlook 2003 de sorte qu'il utilise un port UDP fixe :

Emplacement de la sous-clé : HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\RPC

Nom de la sous-clé : FixedUDPPort

Type : DWORD

Valeur : entre 1024 et 65535 (décimale)

3.Configurez le pare-feu Windows pour autoriser le trafic UDP via ce port sur l'ordinateur client.

4.Ouvrez Outlook 2003 et configurez un profil Exchange via une opération manuelle.

Remarque Les notifications de type push sont prises en charge uniquement dans Outlook 2003. Outlook 2007 ou une version ultérieure ne pourront pas enregistrer ce type de notification.

5.Envoyez un nouveau message électronique à l'utilisateur Exchange.

6.Outlook 2003 affiche le nouveau message en moins d'une minute.

Remarque Si Outlook 2003 n'enregistre pas les notifications de type push, il utilise l'interrogation qui se produit toutes les minutes. Outlook 2003 reçoit les notifications de type push plus rapidement.

Propriétés

Numéro d'article: 2009942 - Dernière mise à jour: mardi 1 mai 2012 - Version: 9.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2010 Service Pack 1 sur le système suivant
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
  • Microsoft Office Outlook 2003
Mots-clés : 
kbsmbportal KB2009942
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires