As pastas demoram muito tempo a actualizar quando um utilizador do Exchange Server 2010 utiliza o Outlook 2003 no modo online

Artigo: 2009942 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Quando acede a uma caixa de correio do Microsoft Exchange Server 2010 utilizando o Microsoft Office Outlook 2003 no modo online, pode deparar-se com os seguintes problemas:

  • As mensagens de correio electrónico de saída ficam na pastaA Enviar durante até 1 minuto.
  • As novas mensagens de correio electróniconão chegam à pastaA Receber imediatamentee sofrem um atrasode até 1 minuto.
  • Os itens que são eliminados das pastas ainda aparecem na pasta durante até 1 minuto.
  • Os itens que são movidos de uma pasta para outra pasta ainda aparecem na pasta original durante até 1 minuto.

As actualizações das pastas não ocorrem de forma atempada.

Causa

Estes problemas ocorrem porque o Exchange Server 2010 não envia notificações do Protocolo de datagrama de utilizador (UDP) para o Outlook.

O Outlook 2003 utiliza as notificações do UDP como o método primário para receber notificações a partir de um servidor Exchange. No entanto, o Outlook 2003 tem de consultar o Exchange Server 2010 quanto a alterações e o intervalo de consulta predefinido para o Outlook é de cerca de 60 segundos. Por isso, a actualização de uma pasta pode sofrer um atraso de 1 minuto.

Resolução

Para resolver este problema, instale o Update Rollup 3 para o Exchange Server 2010 Service Pack 1.

Para obter mais informações sobre o Update Rollup 3 para o Exchange Server 2010 Service Pack 1, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:

2529939Descrição do Update Rollup 3 para o Exchange Server 2010 Service Pack 1

Depois de instalar esta actualização, tem de criar uma subchave de registo para activar a funcionalidade de suporte de notificações do UDP.

Para nos solicitar a activação da funcionalidade de suporte de notificações do UDP, consulte a secção "Corrigir por mim". Se preferir activar a funcionalidade de suporte de notificações do UDP sozinho, consulte a secção "Deixar-me corrigir o problema".

Corrigir por mim

Para corrigir este problema automaticamente, clique na hiperligação Corrigir este problema. Em seguida, clique em Executar na caixa de diálogo Transferência de Ficheiros e siga os passos neste assistente.

Corrigir este problema
Microsoft Fix it 50689



Nota Este assistente pode estar apenas em inglês. Contudo, a correcção automática também funciona para versões do Windows noutros idiomas.

Nota Se não estiver a trabalhar no computador que tem o problema, pode guardar a correcção automática numa unidade Flash ou num CD para poder executá-la no computador que tem o problema.

Deixar-me corrigir o problema

Criar o registo seguintesubchave para activar a funcionalidade de suporte de notificações do UDP:

Localização da subchave: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

Nome da subchave: EnablePushNotifications

Tipo: REG_DWORD

Valor: 1

NotaSe esta chave de registo não existir ou se o seu valor estiver definido para0, a funcionalidade de suporte de notificação do UDP não é activada.

Solução

Para contornar este problema, utilize o modo de intercâmbio em cache no Outlook 2003. Para isso, siga estes passos:

  1. Saia do Outlook 2003, se este estiver a ser executado.
  2. No Painel de controlo, clique em Correio.
  3. Clique em Contas de correio electrónico.
  4. Seleccione Ver ou alterar contas de correio electrónico existentes e, em seguida, clique em Seguinte.
  5. Escreva uma conta do Microsoft Exchange Server e clique em Alterar.
  6. Seleccione a caixa de verificação Utilizar modo de intercâmbio em cache.
  7. Clique em Seguinte e, em seguida, clique em Concluir.
  8. Inicie o Outlook 2003.

Estado

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para identificar se as notificações de emissão funcionam, siga estes passos:

1.Crie a seguinte subchave de registo no servidor CAS para activar as notificações de emissão:

Localização da subchave: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

Nome da subchave: EnablePushNotifications

Tipo: DWORD

Valor: 1

Nota Se a subchave ParametersSystem não existir, crie-a.

2.Crie a seguinte subchave de registo no computador cliente para configurar o Outlook 2003 para utilizar uma porta UDP fixa:

Localização da subchave: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\RPC

Nome da subchave: FixedUDPPort

Tipo: DWORD

Valor: entre 1024 e 65535 (decimal)

3.Configure a Firewall do Windows para permitir o tráfego do UDP através desta porta no computador cliente.

4.Abra o Outlook 2003 e, em seguida, configure um perfil Exchange numa operação manual.

Nota As notificações de emissão são suportadas apenas no Outlook 2003. O Outlook 2007 ou uma versão mais recente não conseguirá registar notificações de emissão.

5.Envie uma nova mensagem de correio electrónico para o utilizador Exchange.

6.O Outlook 2003 apresenta uma nova mensagem de correio electrónico dentro de 1 minuto.

Nota Se o Outlook 2003 não registar notificações de emissão, utiliza consultas que ocorrem a cada 1 minuto. Com as notificações de emissão, o Outlook 2003 recebe notificações mais rápido.

Propriedades

Artigo: 2009942 - Última revisão: segunda-feira, 31 de Outubro de 2011 - Revisão: 6.0
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2010 Service Pack 1 nas seguintes plataformas
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
  • Microsoft Office Outlook 2003
Palavras-chave: 
KB2009942

Submeter comentários