Disk Management gives a "Unspecified Error" with "Unable to connect to Logical Disk Management Service"

Article ID: 2023404 - View products that this article applies to.
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Symptoms

On opening Disk Management console on Windows Server 2003 it returns a dialog box with error:

Unspecified Error

At the bottom of the console you'll see the reported status as:

Unable to connect to Logical Disk Management Service

Cause

 This problem can occur for either of the following reasons.

  • The Logical Disk Manger and the Virtual Disk Service are not running on the Local System Account
  • DCOM Permissions are incorrect under COM Security

Resolution

To resolve this problem:

Verify that the Logical Disk Manager and the Virtual Disk Service are running on the Local System Account

          To verify that the Logical Disk Manger and the Virtual Disk Service are running on the Local System Account:
          1.  Click Start , point to Administrative Tools , and then click Services.
          2.  Right-click Logical Disk Manager, and then click Properties
          3.  Click the Log On tab. 
          4.  In the "Log on as" section, ensure the Local system account is selected and the allow service to interact with desktop is unchecked
          5.  Once verified click OK 
          6.  Repeat the previous steps for the Virtual Disk Service and then close the services console.

Verify the DCOM Permissions under COM Security tab with the following

          To Verify the DCOM Permissions:
          1.  Click Start , click Run , type dcomcnfg , and then click OK .
          2.  Expand Component Services , and then expand Computers .
          3.  Right-click My Computer , and then click Properties .
          4.  On the COM Security tab, click Edit default under Access Permissions 
          5.  Verify if the SELF and SYSTEM accounts are listed under Group and user names
          6.  Both SELF and SYSTEM accounts should have allow checked only for Local Access
          7.  Once verified click OK
          8.  Click Edit default under Launch and Activation Permissions
          9. Verify the SELF and SYSTEM accounts are listed under Group and user names
          10. Both SELF and SYSTEM accounts should have allow checked for the following permissions: 
               • Local Launch 
               • Remote Launch 
               • Local Activation 
               • Remote Activation   
          11. Once verified click OK, and then click Ok and close the Dcom properties window.

Once verified and corrected try and access disk management through its console.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2023404 - Last Review: May 6, 2010 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
Keywords: 
KB2023404

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