Excel for Macを開始するときに"Microsoft Excel で問題が発生し、閉じる必要がある"

現象

Microsoft Excel for Macを開始しようとすると、次のエラー メッセージが表示されます。

Microsoft Excel で問題が発生し、終了する必要があります。 ご不便をおかけして申し訳ございません。

原因

このエラーは、次のいずれかの条件に該当する場合に発生する可能性があります。

  • Excel の基本設定が破損しています。
  • バックグラウンドで実行されているプログラムは、Excel for Macに干渉しています。
  • アプリケーション ファイルが破損しています。
  • ユーザー アカウント プロファイルが破損しています。

解決方法

この問題を解決するには、問題が解決されるまで、次の方法を順番に試してください。

方法 1

手順 1: すべてのプログラムを終了する

続行する前にすべてのプログラムを終了する必要があります。 アプリケーションを終了するには、ツール バー (上部) でアプリケーションを選択し、[終了] を選択 します。 アプリケーションを終了できない場合、または方法がわからない場合は、Command キーと Option キーを押し、キーボードの Esc キーを押します。 [アプリケーションの強制終了] ウィンドウでアプリケーションを選択し、[ 強制終了] を選択します。 [ 強制終了] をクリックしてアプリケーションを終了します。

注:

Finder を終了することはできません。

完了したら、左上隅にある赤いボタンをクリックし、手順 2 に進みます。

手順 2: Excel の基本設定を削除する

  1. すべてのMicrosoft Office for Macアプリケーションを終了します。

  2. [ 移動 ] メニューの [ ホーム] をクリックします。

  3. ライブラリを開きます。 メモMac OS X Lion ではライブラリ フォルダーが非表示になっています。 このフォルダーを表示するには、OPTION キーを押しながら [移動 ] メニューをクリックします。

  4. [基本設定] を開きます

  5. com.microsoft.Excel.plist をデスクトップにドラッグします。 ファイルが見つからない場合、Excel は既定の設定を使用しています。 手順 7 に進みます。

  6. Excel を開き、問題が引き続き発生するかどうかをチェックします。 それでも問題が発生した場合は、Excel を終了し、ファイルを元の場所に復元して、次の手順に進みます。 問題が解決した場合は、 com.microsoft.Excel.plistごみ箱にドラッグします。

  7. すべてのOffice for Macアプリケーションを終了します。

  8. [ 移動 ] メニューの [ ホーム] をクリックします。

  9. ライブラリを開きます。

    注:

    Mac OS X Lion ではライブラリ フォルダーが非表示になっています。 このフォルダーを表示するには、OPTION キーを押しながら [移動 ] メニューをクリックします。

  10. [基本設定] を開きます

  11. Microsoft を開き、com.microsoft.Excel.prefs.plist をデスクトップにドラッグします。 ファイルが見つからない場合、Excel は既定の設定を使用しています。 方法 2 に移動します。

  12. Excel を開き、問題が引き続き発生するかどうかをチェックします。 それでも問題が発生した場合は、Excel を終了し、ファイルを元の場所に復元して 、方法 2 に進みます。 問題が解決した場合は、 com.microsoft.Excel,prefs.plistごみ箱にドラッグします。

方法 2

[ディスクのアクセス許可の修復] オプションを使用する

[ディスクのアクセス許可の修復] オプションを使用して、Mac OS X 10.2 以降のバージョンのアクセス許可の問題のトラブルシューティングを行うことができます。 [ディスクのアクセス許可の修復] オプションを使用するには、次の手順に従います。

  1. [ 移動 ] メニューの [ ユーティリティ] をクリックします。
  2. ディスク ユーティリティ プログラムを起動します。
  3. コンピューターのプライマリ ハード ディスク ドライブをクリックします。
  4. [ 応急処置 ] タブをクリックします。
  5. [ ディスクのアクセス許可の修復] をクリックします。

注:

ディスクユーティリティプログラムは、Appleによってインストールされたソフトウェアのみを修復します。 このユーティリティは、Applications フォルダーなどのフォルダーも修復します。 ただし、このユーティリティは、あなたのホームフォルダにあるソフトウェアを修復しません。

Excel を開き、問題が解決された場合はチェックします。 そうでない場合は、方法 3 に進みます。

方法 3

新しいユーザー アカウントを作成して使用する

新しいユーザー アカウントを作成するには、次の手順に従います。

注:

新しいアカウントでログオンする場合は、多くのユーザーが Office を再インストールする必要があります。

  1. [Apple] アイコンをクリックし、[ システム環境設定] をクリックします。

    Apple アイコンの [システム環境設定] オプションを選択します。

  2. [ アカウント] をクリックします。

    [システム環境設定] で [アカウント] ボタンを選択します。

  3. 左下隅にあるプラス記号 ("+") をクリックして、新しいアカウント ウィンドウを開きます。

    注:

    コンピューターの管理者でない場合は、[ロックをクリックして 変更を加える] をクリックします。 管理者のユーザー名とパスワードを使用してログオンし、[OK] をクリック します

    左下隅にあるプラス記号を選択して、新しいアカウントを開きます。

  4. ユーザー名の "テスト " という単語を入力し、パスワード ボックスは空白のままにします。 [ アカウントの作成] をクリックします。 警告が表示されたら、[OK] をクリックします

    アカウントを作成する名前を入力します。

  5. [ユーザーによる このコンピューターの管理を許可する] をクリックします。 (このオプションを使用できない場合は、次の手順に進んでください)。

    [ユーザーにこのコンピューターの管理を許可する] オプションを選択します。

  6. Apple アイコンをクリックし、[ ログアウト ] をクリックします。

    Apple アイコンでログアウトします。

  7. テスト アカウントでログオンします。

Excel を開き、問題が解決された場合はチェックします。 新しいユーザー アカウントを使用するときに保存できる場合は、Apple サポートに問い合わせて既存のアカウントのトラブルシューティングを行ってください。 既存のアカウントを保持しない場合は、次の手順で作成した "テスト" アカウントの名前を変更し、そのアカウントを引き続き使用できます。 そうでない場合は、方法 4 に進みます。

方法 4

Office を削除してから再インストールする

Office を削除して再インストールする方法については、次の記事を参照してください。

Office 2011 for Mac を再インストールする前に完全にアンインストールして、問題のトラブルシューティングを行う

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