Error message when you try to start Exchange Management Shell (EMS) or Exchange Management Console (EMC): "The connection to the specified remote host was refused"

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Article ID: 2027064 - View products that this article applies to.
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Symptoms

When you try to start Exchange Management Shell (EMS) or Exchange Management Console (EMC) on a computer that is running Microsoft Exchange Server 2010, you receive the following error message:

The connection to the specified remote host was refused. Verify that the WS-Management service is running on the remote host and configured to listen for requests on the correct port and HTTP URL. For more information, see the about_Remote_Troubleshooting Help topic.

Cause

This problem occurs because one or more of the following conditions are true:

  • The MSExchangePowerShellAppPool application pool is experiencing problems or is not running.
  • The user idoes not have Remote PowerShell Enabled status.
  • Windows Remote Management (WinRM) is configured incorrectly on the server.

Resolution

To resolve this problem, use one of the following methods:

  • Make sure that the MSExchangePowerShellAppPool application pool is running. If the pool is running, try to recycle it. Then, check for errors or warnings in the event logs.
  • Make sure that the user who is trying to connect has Remote PowerShell Enabled status. To determine whether a user is enabled for Remote PowerShell, start Exchange Management Shell by using an account that has been enabled, and then run the following query:

    (Get-User <username>).RemotePowershellEnabled


    This query returns a response of True or False. If the response is False, the user is not enabled for Remote PowerShell. To enable the user, run the following command:

    Set-User <username> -RemotePowerShellEnabled $True

  • Make sure that WinRM is configured correctly on the server. To do this, follow these steps:

    1. Run WinRM Quick Config. To do this, click Start, type WinRM Quick Config in the Start Search box, and then press ENTER.
    2. Make sure that both tests pass and that no actions are required. If any actions are required, click Yes in the prompt window to allow the WinRM configuration changes to be made.
    3. Click Start, type cmd in the Start Search box, and then press ENTER. In the Command Prompt window, type WinRM enumerate winrm/config/listener at the command prompt, and then press ENTER.
    4. Make sure that a listener exists for the HTTP protocol on port 5985, and that the listener is listening on all addresses.

Properties

Article ID: 2027064 - Last Review: January 18, 2013 - Revision: 4.0
Applies to
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Service Pack 1
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2013 Enterprise
  • Microsoft Exchange Server 2013 Standard
Keywords: 
KB2027064

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