Noções sobre os requisitos do .NET Framework para várias versões do SQL Server

Traduções de Artigos Traduções de Artigos
Artigo: 2027770 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Versões diferentes do Microsoft SQL Server têm versões diferentes do .NET Framework como um pré-requisito para o programa de configuração e o procedimento para instalar o .net Framework pode ser diferente em diferentes sistemas operativos. Além disso, o .NET Framework requisitos variam com base na edição do SQL Server que está a instalar. Este artigo descreve estes requisitos e dá-lhe as informações necessárias para que possa instalar o correcto .net Framework que é necessária.

Mais Informação

Como utilizar este documento
  1. Utilize o quadro 1 na secção "Pré-requisitos do Microsoft .NET Framework para SQL Server" para verificar os requisitos do .NET Framework para a versão e a edição que está a instalar.
  2. Verifique se o .NET Framework já está incluído como parte do sistema operativo ou se é necessário transferi-lo separadamente a partir de transferências da Microsoft listados na tabela 2 na secção ".NET Framework para SQL Server em vários sistemas operativos e ligações de transferência".
  3. Utilize a última coluna do quadro 2 para verificar se procedimentos especiais necessários para instalar o âmbito no sistema operativo de destino. Se o movimento for Sim, consulte as secções posteriores deste documento para obter os procedimentos necessários. Se o movimento for não, pode transferir quadro correspondente a partir da hiperligação correspondente no quadro 2 e instalá-lo no sistema operativo de destino.

Pré-requisitos de Microsoft .NET Framework para SQL Server

A tabela seguinte resume os requisitos de versão do .NET Framework para várias versões e edições do SQL Server e explica se o produto é incluído no suporte de configuração e é instalado como parte da configuração.

Quadro 1:
Reduzir esta tabelaExpandir esta tabela
Versão SQL ou edição.NET Framework versãoIncluído com o produto?Instalados como parte da configuração?
SQL Server 2005 (todas as edições)2.0SimNão
SQL Server 2008 express (principal)2.0 SP2NãoNão
SQL Server 2008 no Windows Server 2003, (64-bit), IA-642.0 SP2SimSim
SQL Server 2008 (todas as outras edições)3.5 SP1SimSim *


* Para o SQL Server 2008 e para instalações de Cluster de activação pós-falha do SQL Server 2008 R2 e Express Edition, o programa de configuração não instala o .NET Framework 3.5 Service Pack 1 em sistemas que executam o Windows Server 2008 R2 Edition. Para mais informações sobre como activar o .NET Framework 3.5 SP1 nestes sistemas, consulte oComo instalar ou activar o .NET Framework 3.5 SP1 no Windows Server 2008 R2 para o SQL Server 2008 secção.

 .NET Framework para SQL Server em vários sistemas operativos e ligações de transferência

A tabela seguinte indica se o .NET Framework que é necessário para o SQL Edition e a versão que está a instalar é incluído como parte do sistema operativo de destino. A tabela também indica se são necessários quaisquer passos adicionais para instalar ou activar o âmbito do sistema operativo correspondente. E, a tabela fornece uma hiperligação de transferência para os ficheiros redistribuíveis do .NET Framework correspondentes.

Quadro 2:
Reduzir esta tabelaExpandir esta tabela
Versão do .NETNúmero de versãoIncluído no sistema operativoPredefinido com os sistemas operativosInstalado com o Visual Studio .NETHiperligação Redist ou transferênciaSão necessários para instalar a redistribuição de procedimentos especiais?
2.02.0.50727.42Windows Server 2003 R2NenhumMicrosoft Visual Studio 20052.0Não
2.0 SP22.0.50727.3053NenhumNenhumNenhum2.0 SP2Não
3.5 SP13.5.30729.1Windows Server 2008 R2NenhumNenhum3.5 SP1Sim, para o Windows Server 2008 R2


Notas:
  1. Para mais informações sobre as várias versões do .NET Framework, consulte o seguinte blogue registar:
      
  2. Se estiver a instalar o SQL Server 2008 num sistema onde está instalada a versão RTM do Visual Studio 2008, consulte o seguinte blogue registar:

Como instalar ou activar o .NET Framework 3.5 SP1 no Windows Server 2008 R2 para o SQL Server 2008

No Windows Server 2008 R2, o .NET Framework é uma funcionalidade e instalá-lo é diferente de versões anteriores do sistema operativo Windows. O seguinte procedimento explica como verificar se está instalado o .NET Framework 3.5.1. O procedimento também explica como determinar se o .NET Framework não está instalado e como pode adicioná-lo nestes ambientes.

Como determinar se o .NET Framework 3.5 SP1 está instalado:

Para determinar se o .NET Framework 3.5.1 está instalado no Windows Server 2008 R2, siga estes passos:
  1. Clique em Iniciar, clique em Ferramentas administrativase, em seguida, clique em Gestor de servidor.
  2. Clique em funções para apresentar todas as funcionalidades instaladas no painel do lado direito.
  3. Certifique-se de que o .NET Framework 3.5.1 está listado como uma funcionalidade instalada.

Se o .NET Framework 3.5.1 não estiver listado como uma funcionalidade instalada, utilize um dos seguintes métodos para o instalar.

Método 1: Utilizar o Gestor de servidor
  1. No Gestor de servidor, Clique em Adicionar funcionalidades para apresentar uma lista de funcionalidades possíveis.
  2. No Seleccionar funcionalidades interface, expanda a entrada de funcionalidades do .NET Framework 3.5.1 .
  3. Depois de expandir funcionalidades do .NET Framework 3.5.1, verá duas caixas de verificação. É uma caixa de verificação para .NET framework 3.5.1e outra caixa de verificação é utilizada paraActivação do WCF. Clique para selet a caixa de verificação junto a.NET framework 3.5.1e, em seguida, clique em seguinte.

    Nota
    se não expandir o Funcionalidades do .NET framework 3.5.1produto e de verificação, o Assistente para adicionar funcionalidades seguintes é iniciado:

    Reduzir esta imagemExpandir esta imagem
    Assistente para adicionar funcionalidades


    Se o assistente for iniciado, clique emCancelar, expandaFuncionalidades do .NET framework 3.5.1e, em seguida, clique para seleccionar a caixa de verificação do .NET Framework 3.5.1 .
  4. Não é possível instalar Funcionalidades do .NET framework 3.5.1 a menos que as funcionalidades e serviços de função necessários estão também instaladas.
  5. Na Confirmar selecções de instalação , reveja as selecções e, em seguida, clique em instalar.
  6. Permitir que o processo de instalação conclua e, em seguida, clique em Fechar.

Método 2: Utilizar o Windows PowerShell
  1. Faça clique sobre oIniciar, clique em Todos os programase, em seguida, clique emAcessórios.
  2. Expandir O Windows PowerShell,com o botão direitoO Windows PowerShelle clique em Executar como administrador. Clique em Sim na caixa de controlo de conta de utilizador.
  3. Na linha de comandos do PowerShell, escreva os seguintes comandos e, em seguida, prima ENTER após cada comando:
    • Import-Module ServerManager
    • Adicionar-WindowsFeature como-.NET framework
     
     Nota Consulte o seguinte ecrã tiro para obter mais informações:

Reduzir esta imagemExpandir esta imagem
2014321b


Referências




Propriedades

Artigo: 2027770 - Última revisão: 20 de julho de 2013 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft SQL Server 2008 Developer
  • Microsoft SQL Server 2008 Enterprise
  • Microsoft SQL Server 2008 Express
  • Microsoft SQL Server 2008 R2 Datacenter
  • Microsoft SQL Server 2008 R2 Developer
  • Microsoft SQL Server 2008 R2 Enterprise
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL 2005 Server Enterprise
  • Microsoft SQL Server 2005 Enterprise Edition for Itanium Based Systems
  • Microsoft SQL Server 2005 Enterprise X64 Edition
  • Microsoft SQL Server 2005 Evaluation Edition
  • Microsoft SQL Server 2005 Express Edition
  • Microsoft SQL Server 2005 Express Edition with Advanced Services
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Standard X64 Edition
  • Microsoft SQL 2005 Server Workgroup
  • Microsoft SQL Server 2005 Standard Edition for Itanium Based Systems
  • Microsoft SQL Server 2008 Enterprise Evaluation
  • Microsoft SQL Server 2008 Express with Advanced Services
  • Microsoft SQL Server 2008 R2 Express
  • Microsoft SQL Server 2008 R2 Express with Advanced Services
  • Microsoft SQL Server 2008 R2 Standard
Palavras-chave: 
kbmt KB2027770 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2027770

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com