Objetos de dados de colaboração (CDO) 1.2.1 não é compatível com o Outlook 2010 e versões posteriores

Traduções deste artigo Traduções deste artigo
ID do artigo: 2028411
Expandir tudo | Recolher tudo

Sumário

Embora a biblioteca de objetos de objetos de dados de colaboração (CDO) 1.2.1 pode ser usada com o Microsoft Outlook 2010 e o Microsoft Outlook 2013, não podemos recomendar ou suportar isso de forma alguma.

Importante: Este artigo se aplica ao usar o CDO 1.2.1 do cliente com o Outlook 2010 e versões posteriores. Não se aplica ao uso de CDO 1.2.1 que instala o subsistema MAPI e que foi projetado para uso em um computador sem o Outlook.

Mais Informações

Objetos de dados de colaboração (CDO) 1.2.1 é uma biblioteca de cliente que fornece um wrapper estreito sobre funcionalidade de MAPI estendido. Esta biblioteca é normalmente usada para adicionar funcionalidade a programas personalizados de mensagens de e-mail. Esta biblioteca permite que esses programas executar funções como envio de e-mails por meio do MAPI, trabalhar com calendários e acessar vários dados no Microsoft Outlook ou no Microsoft Exchange.

A partir do Outlook 2007, o CDO 1.2.1 não foi incluído com o Microsoft Outlook. Mas o CDO 1.2.1 só está disponível como um download para o Outlook 2007:

http://www.microsoft.com/downloads/details.aspx?FamilyId=2714320d-c997-4de1-986f-24f081725d36&displaylang=en

Este download só pode ser instalado em um computador que tenha o Outlook 2007 instalado. Se o Outlook não estiver instalado, você recebe a seguinte mensagem de erro quando você executar o arquivo ExchangeCdo.msi:

Collaboration Data Objects 1.2.1 não podem ser instalados, a menos que o Microsoft Office Outlook 2007 também é instalado.

Embora a versão para download do CDO não está instalada quando o Outlook 2010 ou 2013 do Outlook está instalado, você pode instalar o CDO primeiro com o Outlook 2007 antes da atualização do Outlook. Nesse cenário, programas ainda podem usar a biblioteca do CDO para integrar com o Outlook 2010 e o Outlook 2013 versão do MAPI.

No entanto, recomendamos que o CDO primeiro foi desinstalado antes que o Outlook é atualizado do Outlook 2007 para o Outlook 2010 e versões posteriores.

O Microsoft Outlook 2010 e versões posteriores incluem muitas alterações de arquitetura para o subsistema MAPI do lado do cliente. De interesse específico são cenários em que o Outlook está configurado para usar várias contas do Exchange. Além disso, o CDO 1.2.1 é uma biblioteca de cliente de 32 bits e não funcionará com versões de 64 bits do Outlook. Considerando todos esses fatores, o CDO 1.2.1 não é suportado para uso com o Outlook 2010 ou Outlook 2013 e não recomendamos seu uso com o Outlook 2010 e versões posteriores.

Programas que usam o CDO devem ser reprojetados para usar outras Interfaces de programação de aplicativo (APIs) em vez do CDO. A partir do Outlook 2007, o modelo de objeto do Outlook foi amplamente expandido para fornecer funcionalidade que estava disponível anteriormente apenas usando o CDO 1.2.1. O modelo de objeto do Outlook 2010 e o Outlook 2013 inclui alguns novos recursos para expandir mais sobre isso. Por exemplo, o modelo de objeto do Outlook tem novas funcionalidades para operar corretamente com várias contas do Exchange. O modelo de objeto do Outlook também funciona para versões de 32 bits e 64 bits do Outlook. Os desenvolvedores devem usar o Outlook 2010 e o modelo de objeto posterior em vez de CDO 1.2.1. Além disso, os desenvolvedores ainda podem usar MAPI estendido (que requer C++ não gerenciado) em alguns cenários onde CDO era necessário. No entanto, se for possível, geralmente recomendamos que o modelo de objeto do Outlook ser usado em vez de MAPI estendido.

Suporte ao produto Microsoft pode ajudar os clientes do desenvolvedor migrar programas personalizados de usar o CDO 1.2.1 usando outras APIs. No entanto, Microsoft não fornecerá suporte para os cenários em que o CDO 1.2.1 é usado com o Outlook 2010 ou Outlook 2013.

Propriedades

ID do artigo: 2028411 - Última revisão: terça-feira, 2 de abril de 2013 - Revisão: 4.0
Palavras-chave: 
kbmt KB2028411 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2028411

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com