OL2000: Error Message in Extension Configuration File (ECF) Starting Outlook

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Article ID: 204951 - View products that this article applies to.
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Symptoms

When you attempt to start Microsoft Outlook, you may receive one or all of the following error messages:

Error in configuration file "C:\Program Files\Microsoft Office 97\Office\Addins\filename.ecf"
-or-
The extension configuration file "C:\Program Files\Microsoft Office 97\Office\Addins\filename.ecf" could not be installed. There is an error in the syntax or format of the file.
-or-
Unable to load filename.dll. You may be out of memory, out of system resources, or missing a .dll file.

Cause

The above errors result from either a damaged or missing .ecf or .dll file, or incorrect information in the Extend.dat file.

Resolution

To correct this problem you may have to replace the damaged extensions, or you may have to remove the reference to them in the Windows Registry. If the problem persists, you should rename and recreate the Extend.dat file, which is a binary cache of extension settings.

More information

Replace the Damaged Extensions

To replace the damaged extensions, follow these steps:
  1. Quit Outlook.
  2. Insert your original Setup CD into the drive. If you installed from the Web this will not be necessary.
  3. In the \Program Files\Microsoft Office\Office\Addins folder on your computer, rename the problem .ecf files referenced in the error message.
  4. Click Start, point to Settings and click Control Panel.
  5. Click to open the Add/Remove Programs icon.
  6. Click to select Microsoft Office 2000, and then click Add/Remove.
  7. When prompted, click "Repair Office". This will replace the .ecf files that were renamed earlier.
  8. Restart Outlook.
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To Remove the Registry Entries

To remove the reference to the files in the Windows Registry, follow these steps:
  1. Quit all programs.
  2. Click Start and then click Run.
  3. In the Open box type, regedit.exe.
  4. Navigate to the folder:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Client\Extensions
    You will see the add-ins listed on the right under the heading of DATA. Click to select the name of the Data key that corresponds to the Addin referenced in the error message and press DELETE to delete this registry key.
  5. On the Registry menu, click Exit.
  6. Restart your computer and then restart Outlook.

Refreshing Extend.dat File

If you still receive the error message when you restart Outlook you must refresh the Extend.dat file.

To refresh the Extend.dat file, follow these steps:

  1. Quit all programs.
  2. Click Start point to Find and click Files or Folders.
  3. In the Named box, type extend.dat.
  4. In the Look In list, click to select your hard drive.
  5. Click to select Include subfolders and click Find Now.
  6. In the Name list, right-click on the file Extend.dat, and on the shortcut menu click Rename to rename the file to Extend.old.
  7. On the File menu, click Close to exit.
  8. Restart Outlook. Restarting Outlook creates a new Extend.dat file.

Properties

Article ID: 204951 - Last Review: June 22, 2014 - Revision: 5.0
Applies to
  • Microsoft Outlook 2000 Standard Edition
Keywords: 
kbprb KB204951

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