Help and Support

文書番号: 206002 - 最終更新日: 2004年12月29日 - リビジョン: 1.1

USB 接続のキーボードまたはマウスが Windows 98 で動作しない

この記事は、以前は次の ID で公開されていました: JP206002

目次

すべて展開する | すべて折りたたむ

現象

Windows 98 ベースのコンピュータを起動したときに、USB (Universal Serial Bus) 接続のキーボードとマウスが正しく動作せず、次のエラー メッセージが表示されることがあります。
コンピュータにマウスが接続されていません。シリアル マウスを接続してください。

PS/2 マウス ポートに接続する場合は、先にコンピュータの電源を切ってください。

原因

この問題は、USB 接続の入力デバイスのレジストリ キーが存在しないか、損傷している場合に発生することがあります。

解決方法

この問題を解決するには、次の方法のいずれかを実行します。

PS/2 マウス、シリアル マウス、またはポインティング デバイスのインストール

PS/2 マウス、シリアル マウス、またはポインティング デバイスを所有している場合は、USB デバイスの代わりにこれらを使用することができます。
  1. コンピュータの電源を切断し、PS/2 マウス、シリアル マウス、またはポインティング デバイスを接続してから、コンピュータを再起動します。
  2. コンピュータへのログオン メッセージが表示されたら、[キャンセル] をクリックします。
  3. [スタート] ボタンをクリックし、[設定] をポイントして [コントロール パネル] をクリックします。
  4. [システム] アイコンをダブルクリックし、[デバイス マネージャ] タブをクリックします。
  5. USB キーボードと USB マウスのエントリを右クリックして [削除] をクリックし、[コンピュータ] を右クリックして [最新の情報に更新] をクリックし、[閉じる] をクリックします。

Usb.inf ファイルのエントリの修復

  1. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 コンピュータの起動が始まった直後から Ctrl キーを押しつづけ、 [Microsoft Windows 98 Startup Menu] を表示させます。
  2. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 [Microsoft Windows 98 Startup Menu] が表示されたら、矢印 (「↑」 「↓」) キーで [3. Safe Mode] を選択後、Enter キーを押して Safe モードで起動します。
    ([Microsoft Windows Millennium Startup Menu] 表示時に [F5] キーを押すことでも Safe モードで起動できます。)
  3. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 [スタート] ボタン - [設定] - [コントロール パネル] を開いて [システム] アイコンをダブルクリックし、[デバイス マネージャ] タブをクリックします。
  4. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 USB コントローラをダブルクリックして [全般] タブをクリックし、[このハードウェア プロファイルで使用不可にする] チェック ボックスをオンにします。
  5. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 [OK] をクリックして [閉じる] をクリックし、コンピュータを再起動します。
  6. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 [スタート] ボタンをクリックし、[設定] をポイントして [コントロール パネル] をクリックします。
  7. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 [システム] アイコンをダブルクリックし、[デバイス マネージャ] タブをクリックします。
  8. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 USB コントローラをダブルクリックして [全般] タブをクリックし、[このハードウェア プロファイルで使用不可にする] チェック ボックスをオフにします。
  9. 以下の作業は Safe モード上で実行する必要があるため、PS/2 マウスを使用してください。 [OK] をクリックして [閉じる] をクリックし、コンピュータを再起動します。

Windows 98 の再インストール

Windows 98 を再インストールしてこの問題を解決することもできますが、この問題が深刻な影響を与えている場合を除いて、Microsoft はこの方法を推奨しません。

詳細

USB デバイスのみのシステム環境を構築するには、PS/2 キーボードのように BIOS が USB キーボードをサポートしている必要があります。そうでない場合、MS-DOS モードまたは Safe モードではドライバがサポートされていないため、これらのモードで USB キーボードを使用することはできません。デバイスを初期化する機能については、USB ドライバはデバイスのレジストリ エントリに依存します。コンピュータを起動すると、かなり早い段階でプラグ アンド プレイ機器が列挙されますが、ハードウェア ウィザードはユーザーのログオン後に起動され、ネットワーク上での認証を取得したうえでネットワーク リソースへのアクセスが可能になるしくみになっています。コンピュータの起動時に Plug and Play Configuration Manager によって USB デバイスが検出された場合、ドライバ ファイル Usbd.sys、Openhci.sys のいずれかがロードされ、BIOS によるキーボードのサポートが自動的にオフになります。これは、デバイスは、設定および再初期化の前には無効になっている必要があるためです。

USB 入力デバイス (マウス、キーボード、または入力互換デバイス) のレジストリ エントリが存在しないか、損傷している場合、コンピュータの起動時に "コンピュータにマウスが接続されていません。" というエラー メッセージが表示されます。このとき、USB ドライバは必要な初期化情報を持っていません。入力互換デバイスとしては、PS/2、USB、またはシリアルのマウスやキーボード、ビルトインされた USB ハブなどが挙げられます。レジストリ キーが存在しないか、損傷している場合、これらのデバイス ドライバの検索やロードは行われません。コンピュータは、ネットワークへのログオン後にこれらのデバイスの新しいドライバを検索するため、必要な場合は、ネットワークからドライバを入手することになります。ただし、ドライバはロードされていないため、ネットワーク ログオンのダイアログ ボックスの次の段階に移行することはできません。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 206002? (http://support.microsoft.com/kb/206002/EN-US/ ) (最終更新日 2000-10-19) をもとに作成したものです。


この資料は以下の製品について記述したものです。
  • Microsoft Windows 98 Standard Edition
キーワード:?
kberrmsg kbprb modwinapiviewer KB206002
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers