ACC2000: Cómo establecer referencias a parámetros en los informes

Seleccione idioma Seleccione idioma
Id. de artículo: 208630 - Ver los productos a los que se aplica este artículo
Moderado: requiere conocimientos básicos de macros, código e interoperabilidad.

Este artículo se refiere a una base de datos de Microsoft Access (.mdb) y a un proyecto de Microsoft Access (.adp).

Expandir todo | Contraer todo

En esta página

Resumen

En este artículo se describe cómo hacer referencia a los parámetros de la consulta o vista RecordSource de un informe. Puede utilizar este método para mostrar los parámetros en un cuadro de texto en el informe.

NOTA
En este artículo se explica una técnica demostrada en el archivo de ejemplo, RptSmp00.mdb. Para obtener información acerca de cómo obtener este archivo de ejemplo, consulte el siguiente artículo en Microsoft Knowledge Base:
231851 ACC2000: Microsoft Access 2000 Sample Queries Available in Download Center

Más información

Pasos para una base de datos de Access

En el siguiente ejemplo se indica cómo mostrar los parámetros de la consulta RecordSource de un informe en una base de datos de Access:

PRECAUCIÓN
Si sigue estos pasos, modificará la base de datos de ejemplo Neptuno.mdb. Quizás desee hacer una copia de seguridad del archivo Neptuno.mdb y realizar estos pasos sobre una copia de la base de datos.

  1. Abra la base de datos de ejemplo Neptuno.mdb y cree una nueva consulta basada en las tablas Pedidos, Detalles de pedido y Productos. Incluya los campos IdPedido y FechaPedido de la tabla Pedidos y NombreProducto de la tabla Productos.
  2. En el menú Consulta, haga clic en Parámetros. En el cuadro Parámetros de la consulta, bajo Parámetros, escriba Especifique fecha de inicio y, en Tipo de datos, seleccione Fecha y hora. Presione TAB para desplazarse al próximo campo de Parámetros. En Parámetros, escriba Especifique fecha de finalización y, en Tipo de datos, especifique Fecha y hora. Haga clic en Aceptar.
  3. Agregue los criterios siguientes en el campo FechaPedido:
    Entre [Especifique fecha de inicio] Y [Especifique fecha de finalización]
  4. Guarde la consulta como InformeProducto y, a continuación, ciérrela.
  5. En la ventana Base de datos, haga clic en Informes, bajo Objetos, y, a continuación, en Nuevo.
  6. En el cuadro Nuevo informe, haga clic en Autoinforme: tabular. A continuación, seleccione la consulta InformeProducto en el cuadro Elija la tabla o consulta de donde proceden los datos del objeto y haga clic en Aceptar.
  7. Cada vez que el Asistente para informes automáticos pida una fecha de inicio y de finalización, haga clic en Aceptar. Cuando el asistente presente el nuevo informe en la Vista preliminar, seleccione Diseño del informe en el menú Ver.
  8. Agregue un cuadro de texto a la sección de encabezado del informe.
  9. Establezca la siguiente expresión en la propiedad OrigenDelControl del cuadro de texto:
    ="Periodo del informe: del" & " " & [Especifique fecha de inicio] & " " & "al" & " " & [Especifique fecha de finalización].
    
    					
  10. En el menú Ver, haga clic en Vista preliminar. Cuando se le pida la fecha de inicio, escriba 08/08/97. Cuando se le pida la fecha de finalización, escriba 01/01/98. Observe cómo, en la Vista preliminar, el encabezado del informe presentará el texto:
    Período del informe: del 08/01/97 al 01/01/98

Pasos para un proyecto de Access

En el siguiente ejemplo se indica cómo mostrar los parámetros de la consulta RecordSource de un informe en un proyecto de Access:

PRECAUCIÓN
Si sigue estos pasos, modificará el proyecto de ejemplo de Access NorthwindCS.adp. Quizás desee hacer una copia de seguridad del archivo NorthwindCS.adp y realizar estos pasos sobre una copia del proyecto.

  1. Abra el proyecto de ejemplo de Access, NorthwindCS.
  2. En Objetos, haga clic en Procedimientos almacenados y, a continuación, en Nuevo.
  3. Escriba lo siguiente en el nuevo procedimiento:
    Create Procedure ProductRepSp
    (@BeginDate datetime, @EndDate datetime)
    As
    
    SELECT Orders.OrderID, Orders.OrderDate, 
        Products.ProductName
    FROM Orders INNER JOIN
        [Order Details] ON 
        Orders.OrderID = [Order Details].OrderID INNER JOIN
        Products ON 
        [Order Details].ProductID = Products.ProductID
    WHERE (Orders.OrderDate BETWEEN @BeginDate AND 
        @EndDate)
    					
  4. Guarde el procedimiento almacenado como InformeProductoSP y, a continuación, ciérrelo.
  5. En la ventana Base de datos, haga clic en Informes, bajo Objetos, y, a continuación, en Nuevo.
  6. Haga clic en Vista Diseño y seleccione Aceptar. No seleccione ningún origen en el cuadro Elija la tabla o vista de donde proceden los datos del objeto.
  7. En el menú Ver, haga clic en Propiedades.
  8. En el campo Origen del registro de la ficha Datos, escriba InformeProductoSP.
  9. Cierre el cuadro de diálogo Propiedades.
  10. Desde el cuadro de lista de campos, arrastre IdPedido, FechaPedido y NombreProducto a la sección de detalles del informe.

    NOTA
    Para eliminar espacio en blanco innecesario de la sección de detalles, deberá acercar la barra del pie de página a los campos agregados.
  11. Agregue un cuadro de texto a la sección de encabezado del informe.
  12. Establezca la siguiente expresión en la propiedad OrigenDelControl del cuadro de texto:
    ="Periodo del informe: del" & " " & [@BeginDate] & " " & "al" & " " & [@EndDate]
    
    					
  13. En el menú Ver, haga clic en Vista preliminar. Cuando se le pida la fecha de inicio, escriba 08/08/97. Cuando se le pida la fecha de finalización, escriba 01/01/98. Observe cómo, en la Vista preliminar, el encabezado del informe presentará el texto:
    Período del informe: del 08/01/97 al 01/01/98

Referencias

Para obtener más información acerca de cómo hacer referencia a parámetros de consulta, haga clic en Ayuda de Microsoft Office Access en el menú Ayuda, escriba parámetros de consulta en el Ayudante de Office o en el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas relacionados.

Propiedades

Id. de artículo: 208630 - Última revisión: martes, 25 de noviembre de 2003 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Access 2000 Standard Edition
Palabras clave: 
kbhowto kbusage KB208630

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com