ACC2000: Como utilizar um banco de dados protegido de mala direta do Word

Traduções deste artigo Traduções deste artigo
ID do artigo: 208933 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Avançadas: Requer especialista de codificação, interoperabilidade e habilidades de multiusuário.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo descreve como usar um banco de dados protegido do Microsoft Access em um Microsoft Word para Windows mala direta. Este artigo pressupõe que já tiver criado ou ter acesso a um banco de dados protegido do Access.

Para acessar um banco de dados protegido do Microsoft Access usando o ODBC (Open Database Connectivity) ou intercâmbio dinâmico de dados (DDE), você deve fazer logon usando uma conta válida do Microsoft Access. Microsoft Word para Windows não abre um documento de mala direta se você não tiver permissão "Ler dados" na tabela ou consulta que é especificada como a fonte de dados.

Mais Informações

Você pode criar um documento de mala direta no Microsoft Word usar DDE ou ODBC para acessar um banco de dados protegido. Escolha um dos seguintes métodos.

Método 1: Criar um documento de mala direta no Word, usando o DDE para acessar o banco de dados protegido

  1. Inicie o Word, criar um novo documento e, em seguida, salve o documento como TestMerge.doc.
  2. No menu Ferramentas , clique em mala direta .
  3. Clique em criar , clique em cartas e, em seguida, clique em Janela .
  4. No auxiliar de mala direta, clique em Obter dados , clique em Abrir fonte de dados e, em seguida, na caixa arquivos do tipo , clique em Bancos de dados do Microsoft Access (*.mdb) .
  5. Localize e selecione o banco de dados protegido criado. Clique para marque a caixa de seleção Selecionar método e, em seguida, clique em Abrir .
  6. Clique em Microsoft Access bancos de dados via DDE e, em seguida, clique em OK .
  7. Quando solicitado, digite o nome de usuário e a senha para uma conta que tenha permissões e, em seguida, clique em OK .

    Observação : se tiver definido uma senha de banco de dados para o banco de dados que você está tentando abrir, você também é solicitado a inserir a senha.
  8. Na lista de tabelas no banco de dados seguro, selecione qualquer tabela que contém alguns dados, clique em OK e, em seguida, clique em Editar documento principal .
  9. Na barra de ferramentas mala direta , clique em Inserir campo . Adicione vários campos ao documento.
  10. Na barra de ferramentas mala direta , clique em Mesclar para novo documento e, em seguida, verifique se a mesclagem é bem-sucedida.
  11. Salve e feche TestMerge.doc e em seguida, tente reabrir o documento. Quando solicitado, digite as informações do usuário para uma conta que não deve ter permissões. Verifique se que o documento falha ao abrir.

Criar um documento de mala direta no Word, usando o ODBC para acessar o banco de dados protegido

  1. Execute as etapas 1 a 5 no método 1.
  2. Clique em Microsoft bancos de dados Access via ODBC e, em seguida, clique em OK .
  3. Se você receber uma mensagem informando que o logon padrão é inválido, clique em OK , digite o nome de usuário e a senha da conta que tenha permissões e, em seguida, clique em OK .
  4. Na lista de tabelas no banco de dados seguro, clique em qualquer tabela que contém alguns dados, clique em OK e, em seguida, clique em Editar documento principal .
  5. Na barra de ferramentas mala direta , clique em Inserir campo e adicione vários campos ao documento.
  6. Clique no botão Mesclar para novo documento na barra de ferramentas mala direta e, em seguida, verifique se a mesclagem é bem-sucedida.
Você pode criar novas fontes de dados ODBC usando o ícone ODBC no painel de controle. Criar uma nova fonte de dados ODBC com o driver do Microsoft Access 32 bits permite que você especificar o banco de dados padrão, o nome de usuário e o grupo de trabalho arquivo (System.mdw).

Para evitar sendo fornecer um nome de usuário e uma senha sempre que você abrir o documento, adicione essas informações para a seqüência de conexão por meio de programação.

Referências

Para obter mais informações sobre como criar um banco de dados protegido, clique em Ajuda do Microsoft Access no menu Ajuda , digite segurança no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Para obter mais informações sobre passando o nome de usuário e a senha em uma seqüência de conexão, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic no menu Ajuda , digite propriedade odbcconnectstr no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Propriedades

ID do artigo: 208933 - Última revisão: sábado, 22 de fevereiro de 2014 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhowto kbinterop KB208933 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 208933

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com