Entweder wird die Fehlermeldung "Das installierbare ISAM wurde nicht gefunden" angezeigt, oder es gehen in Access 2000 Dateitypen beim Importieren, Exportieren oder Verknüpfen von Dateien verloren.

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Artikel-ID: 209805 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D39463
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
209805 You receive a "Could not find installable ISAM" error message or some file types are missing when you import files, export files, or link files in Access 2000
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base:
256986 Bereitstellung des Microsoft Windows-Tools zum Entfernen bösartiger Software in einer Unternehmensumgebung
Moderat: Erfordert grundlegende Kenntnisse in den Bereichen Makros, Programmierung und Interoperabilität.

Dieser Artikel bezieht sich auf Microsoft Access-Datenbanken (.mdb) sowie auf Microsoft Access-Projekte (.adp).


In Artikel 90111 wird dieses Thema für Microsoft Access 97 behandelt.
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie in Microsoft Access Dateien importieren, exportieren oder verknüpfen, fehlen einige Dateitypen im Dropdown-Feld Dateityp der Dialogfelder Importieren, Exportieren oder Verknüpfen. Wenn Access den Indexed Sequential Access Method-Treiber (ISAM-Treiber) für diesen Dateityp nicht finden kann, wird Ihnen möglicherweise die folgende Fehlermeldung angezeigt:

Fehlermeldung 1
Das installierbare ISAM wurde nicht gefunden
Fehlermeldung 2
Der Assistent kann auf die Inhalte der Datei '<Pfadname>' nicht zugreifen. Überprüfen Sie bitte, ob die Datei existiert und im richtigen Format vorliegt.
Ihnen werden diese Fehlermeldungen möglicherweise auch angezeigt, wenn Sie versuchen, Dateien von Access 2000 nach Microsoft FoxPro zu exportieren, zu verknüpfen und zu importieren. Access 2000 erfordert den Microsoft Visual FoxPro ODBC-Treiber (ODBC = Open Database Connectivity). Access 97 verwendet den ISAM-Treiber. Dieses Problem tritt möglicherweise auf, wenn Datenbanken von Access 97 auf Access 2000 aktualisiert wurden.

Weitere Informationen, wie Sie die ODBC-Verbindung zur Visual FoxPro-Datenbank herstellen können, finden Sie in folgendem Artikel der Microsoft Knowledge Base:
225861 Keine Optionen sind verfügbar zu importieren, verknüpft oder zu dem FoxPro-Dateityp in Access 2000 zu exportieren

Ursache

ISAM-Treiber werden von Access verwendet, um andere Dateiformate als das eigene zu aktualisieren. Das Problem tritt möglicherweise auf, wenn der Pfad des ISAM-Treibers in Ihrer Windows-Registrierung nicht gültig ist, oder wenn der ISAM-Treiber nicht vorhanden ist.

Lösung

Warnung: Die unkorrekte Verwendung des Registrierungs-Editors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

Sie können zur Behebung des Problems versuchen, die Datei manuell zu registrieren, oder die Fehler im Pfadnamen in der Windows-Registrierung berichtigen und dann die Datei, die Probleme bereitet, installieren oder ersetzen. Gehen Sie hierzu folgendermaßen vor.

Hinweis: Der Dateiname, der in Fehlermeldung 1 im Abschnitt "Problembeschreibung" angegeben ist, hängt direkt mit dem versuchten Vorgang zusammen. Der Dateiname, der in Fehlermeldung 2 im Abschnitt "Problembeschreibung" angegeben ist, ist in der Meldung enthalten.
  1. Suchen Sie die entsprechende Datei in der folgenden Tabelle:
    Tabelle minimierenTabelle vergrößern
    DateinameISAM importieren/exportieren für:Windows-Registrierung
    Msexcl40.dllMicrosoft ExcelHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel
    Msexch40.dllMicrosoft ExchangeHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Exchange
    Msrd2x40.dllMicrosoft Jet 2.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 2.x
    Msrd3x40.dllMicrosoft Jet 3.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 3.x
    Msltus40.dllLotus 1-2-3HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Lotus
    Mspbde40.dllImprise ParadoxHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox
    Mstext40.dllTextHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Text
    Msxbde40.dlldBaseHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase
  2. Verwenden Sie Microsoft Windows Explorer, um nach der Datei zu suchen.
  3. Wenn Sie die Datei gefunden haben, notieren Sie ihren Pfadnamen. Wenn die Datei nicht gefunden wurde, fahren Sie mit Schritt 13 fort.
  4. Öffnen Sie den Windows-Registrierungseditor.
  5. Suchen Sie den in der Tabelle genannten Registrierungs-Unterschlüssel und vergleichen Sie den Pfadnamen mit dem tatsächlichen Pfadnamen. Wenn der Registrierungsschlüssel nicht vorhanden ist, fahren Sie mit Schritt 8 fort.
  6. Berichtigen Sie den Pfad, falls dieser nicht richtig ist. Fahren Sie mit diesen Schritten fort, wenn der Pfad richtig ist.
  7. Schließen Sie den Registrierungseditor.

    Wenn Sie den Pfad geändert haben, wiederholen Sie den Vorgang, bei dem der ursprüngliche Fehler aufgetreten ist.
  8. Wenn der Fehler weiterhin besteht, versuchen Sie die Datei mithilfe des Programms "Regsvr32.exe" manuell zu registrieren.

    "Regsvr32.exe" ist eine Anwendung, die verwendet wird, um DLLs und ActiveX-Steuerelemente in der Windows-Registrierung zu registrieren. Sie können diese Datei verwenden, um Konflikte mit .dll-Dateien zu lösen. Fahren Sie mit dem nächsten Schritt fort, um Ihre .dll-Dateien mithilfe des Programms "Regsvr32.exe" neu zu registrieren.
  9. Überprüfen Sie, dass sich die Datei "Regsvr32.exe" im Systemordner, in dem Windows installiert ist, befindet.

    Die Datei "Regsvr32.exe" befindet sich in der Regel unter "C:\Windows\System oder in C:\Winnt\System32".
  10. Klicken Sie auf Start und anschließend auf Ausführen.
  11. Geben Sie im Dialogfeld Ausführen im Feld Öffnen folgenden Befehl ein.

    Hinweis: Möglicherweise lautet der Pfad der Datei "Regsvr32.exe" und der Pfadname der DLL-Datei auf Ihrem Computer anders. Der folgende Befehl registriert den Excel-ISAM:

    Regsvr32 c:\winnt\system32\msexcl40.dll

    Hinweis: Eine andere Methode, um DLLs zu registrieren, ist die Verwendung des Windows Explorers, um die DLL-Datei zu finden.

    Doppelklicken Sie auf die DLL. Klicken Sie im Dialogfeld Öffnen mit auf Regsvr32.exe, und klicken Sie dann auf OK.

    Durch diesen Vorgang wird eine permanente Zuordnung aller DLLs zu "Regsvr32.exe" erstellt. Weitere DLLs können Sie dann per Doppelklick registrieren.

    Weitere Informationen, wie Sie diese Datei erhalten, finden Sie in folgendem Artikel der Microsoft Knowledge Base:
    267279 ACC2000: Regsvr32.exe im Download Center verfügbar
  12. Wenn der Fehler weiterhin besteht, oder wenn der Pfadname in Schritt 5 korrekt war, benennen Sie die Datei um.
  13. Starten Sie das Programm "Software", starten Sie das Office 2000 Setup-Programm und klicken Sie auf Office reparieren.

Verweise

Weitere Informationen zum Bearbeiten der Windows-Registrierung finden Sie in der integrierten Hilfe zu Microsoft Access. Klicken Sie hierzu im Menü ? auf Microsoft Access-Hilfe, geben Sie Registrierung in den Office- oder Hilfeassistenten ein, und klicken Sie auf Suchen, um das Thema anzuzeigen.

Weitere Informationen über das Importieren, Verknüpfen und Exportieren von FoxPro-Dateitypen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
225861 Keine Optionen sind verfügbar zu importieren, verknüpft oder zu dem FoxPro-Dateityp in Access 2000 zu exportieren

Eigenschaften

Artikel-ID: 209805 - Geändert am: Mittwoch, 7. Dezember 2005 - Version: 4.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Access 2000 Standard Edition
Keywords: 
kbregistry kbexport kbimport kbopenfile kberrmsg kbprb KB209805
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