Zobrazí chybové hlásenie "Nedá sa nájsť inštalovateľný ISAM" alebo niektoré typy súborov chýbajú pri importe súborov, export súborov, alebo odkaz súbory v programe Access 2000

Preklady článku Preklady článku
ID článku: 209805 - Zobraziť produkty, ktorých sa tento článok týka.
Ak ste zákazníkom malých podnikov, nájsť dodatočné riešenia problémov a vzdelávania získate na Podpora pre malé podniky stránky.
Mierna: Vyžaduje základné makro, kódovanie a interoperabilitu zručnosti.

Tento článok sa vzťahuje na databázu programu Microsoft Access (.mdb) a na projekt programu Microsoft Access (.adp).

Pre verziu programu Microsoft Access 2002 alebo Microsoft Office Access 2003 verziu tohto článku, pozri 283881.

Microsoft Access 97 verziu tohto článku, pozri 90111.
Rozbaliť všetko | Zbaliť všetko

Príznaky

Pri importovaní súborov, export súborov alebo prepojenie súborov v Microsoft Access, niektoré typy súborov chýbajú Súbory typ rozbaľovacom zozname v dialógovom okne Import dialógové okno Export, alebo Odkaz dialógové okno. Môže sa zobraziť nasledovné chybové hlásenia ak prístup nemôže nájsť ovládač indexované sekvenčný prístup metóda (ISAM) pre daný typ súbor:

Chybové hlásenie 1
Nepodarilo sa nájsť inštalovateľný KNIŽNICA ISAM
Chybové hlásenie 2
Sprievodca nie je schopný prístup k informáciám v súbore "<pathname>". Skontrolujte súbor existuje a že súbor je v správnom formáte. </pathname>
Môžete tiež Zobraziť tieto chybové hlásenia, ak sa pokúšate importovať z, prepojenie, a exportovať do programu Microsoft FoxPro z programu Access 2000. Access 2000 vyžaduje, aby ste používali ovládačom Microsoft Visual FoxPro Open Database Connectivity (ODBC). Access 97 používa ovládač knižnica ISAM. Tento problém sa môže vyskytnúť, ak databáz sú inovované zo Access 97, Access 2000.

Ďalšie informácie o tom, ako Ak chcete nastaviť pripojenie k databáze Visual FoxPro ODBC, kliknite nasledujúce číslo článku čím zobrazíte článok v databáze Microsoft Knowledge Base:
225861nie možnosť importovať, odkaz, alebo exportovať do typu súboru FoxPro

Príčina

Knižnica ISAM ovládače sú používané prístup na aktualizáciu formátov súborov iné ako svoje vlastné. Ak je cesta k knižnica ISAM vodiča vo Windows Registry nie je platný, alebo ak neexistuje knižnica ISAM ovládača, problém môže vyskytnúť.

Riešenie

Dôležité Tento oddiel, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Avšak, môžu spôsobiť vážne problémy ak databázu registrov upravíte nesprávne. Preto sa uistite, že ste postupovali správne. Doporučujeme zálohovať databázu registrov skôr, ako zmeníte jej hodnoty. Potom, môžete obnoviť databázu registrov, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy registrov nájdete po kliknutí na nasledovné číslo článku publikovaného v Microsoft Knowledge Base:
322756 Ako zálohovať a obnovenie databázy registry v systéme Windows


Ak chcete opraviť problém, môžete skúsiť zaregistrovať súbor ručne alebo názov chyby cesty v databáze Registry systému Windows, je nutné odstrániť a potom nainštalovať alebo nahradiť súbor problém. K tomu, postupujte podľa týchto kroky.

Poznámka V chybové hlásenie 1, ktorý je uvedený v časti "Príznaky" názov súboru je priamo súvisiace s spustená operácia. V chybovom hlásení 2, ktoré je spomenuté v časti "Príznaky", názov súboru je uvedené v text správy.
  1. Vyhľadajte príslušný súbor v nasledujúcej tabuľke:
    Zbaliť túto tabuľkuRozbaliť túto tabuľku
    Názov súboruImport a export ISAM pre:Windows Databázy Registry
    Msexcl40.dllMicrosoft ExcelHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel
    Msexch40.dllMicrosoft VýmenaHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Exchange
    Msrd2x40.dllMicrosoft Jet 2.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 2.x
    Msrd3x40.dllMicrosoft Jet 3.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 3.x
    Msltus40.dllLotus 1-2-3HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Lotus
    Mspbde40.dllImprise ParadoxHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox
    Mstext40.dllTextHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Text
    Msxbde40.dlldBaseHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase
  2. Použite program Windows Prieskumník na vyhľadávanie súbor.
  3. Ak je súbor nájdený, nahrávať názov cesty pre súbor. Ak súbor nie je nájdený, prejdite na krok 13.
  4. Otvoriť Windows Registry Editor.
  5. Vyhľadajte podkľúč databázy registry, ktorý je popísaný v tabuľke, a potom skontrolujte názov cesty proti skutočný názov cesty. Ak kľúč databázy registry neexistuje, prejdite na krok 8.
  6. Ak je nesprávny, opravte cestu. Pokračovať tieto kroky Ak cesta je správna.
  7. Zatvorte Editor databázy Registry.

    Ak zmeníte cestu, Opakujte proces, ktorý vyrába originálne chyba.
  8. Ak chyba pretrváva, pokúste sa manuálne zaregistrovať súbor Použitie nástroja Regsvr32.exe.

    Nástroj Regsvr32.exe je Aplikácia, ktorá slúži na registráciu knižníc DLL a ovládacích prvkov ActiveX v systéme Windows Databázy Registry. Môžete použiť tento súbor zastaviť vydávanie súbory .dll nevhodne. Na opätovne zaregistrujte súbory .dll pomocou nástroja Regsvr32.exe, prejdite na ďalší krok.
  9. Overiť, že Regsvr32.exe súbor je v priečinku system kde je nainštalovaný systém Windows.

    Napríklad Regsvr32.exe súbor je typicky nájdené v C:\Windows\System alebo C:\Winnt\System32.
  10. Kliknite na tlačidlo Štart, a potom kliknite na tlačidloSpustiť.
  11. V Spustiť dialógové okno, zadajte nasledujúce príkaz Otvorené box.

    Poznámka Cesta Regsvr32.exe a názov a cestu k DLL môže byť na vašom počítači rozdielne. Nasledujúci príkaz registrov programu Excel KNIŽNICA ISAM:

    Príkaz regsvr32 c:\winnt\system32\msexcl40.dll

    Poznámka Iný spôsob registrácie dll je použiť Prieskumníka systému Windows nájsť DLL.

    Dvakrát kliknite na knižnicu DLL. V Otvoriť pomocoudialógové okno, kliknite na tlačidlo Regsvr32.exe, a potom kliknite na tlačidlook.

    To vytvára trvalé asociácie knižníc DLL s Regsvr32.exe. Dvojitým kliknutím sa môžete zaregistrovať ďalšie neregistrovaných dll im.

    Ďalšie informácie o možnostiach získania tento súbor, kliknite na nasledovné číslo článku zobrazte článok v Microsoft Knowledge Base:
    267279Regsvr32.exe sú k dispozícii v stredisku pre prevzatie softvéru
  12. Ak chyba pretrváva, alebo ak cesta bola správne Krok 5, premenujte súbor.
  13. Spustenie nástroja Pridanie alebo odstránenie programov, začať Office 2000 Inštalačný program, a potom kliknite na tlačidlo Oprava Office.

Odkazy

Ďalšie informácie o úprave systému Windows Databázy Registry, kliknite na tlačidlo Pomocník programu Microsoft Access na pomoc ponuka, typu Databázy Registry v kancelárii Asistent alebo Sprievodca odpoveďami a potom kliknite na tlačidlo Hľadať Zobrazte príslušné témy.

Pre Ďalšie informácie o importe, prepojenie alebo exportovanie do programu FoxPro typ súboru, kliknite na nasledovné číslo článku zobrazte článok v Microsoft Knowledge Base:
225861Žiadna možnosť importu, odkaz, alebo exportovať do typu súboru FoxPro

Vlastnosti

ID článku: 209805 - Posledná kontrola: 7. júna 2013 - Revízia: 3.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Access 2000 Standard Edition
Kľúčové slová: 
kbregistry kbexport kbimport kbopenfile kberrmsg kbprb kbmt KB209805 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 209805

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com