ACC2000: Como a referência de classes que existe em várias bibliotecas

Traduções deste artigo Traduções deste artigo
ID do artigo: 209912 - Exibir os produtos aos quais esse artigo se aplica.
Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.

Este artigo se aplica a um banco de dados do Microsoft Access (.mdb) e para um projeto Microsoft Access (.adp).

Expandir tudo | Recolher tudo

Sumário

Se seu banco de dados Microsoft Access contiver uma referência a vários bancos de dados biblioteca, bibliotecas de tipos ou bibliotecas de objetos, é possível para o mesmo nome da classe existir em mais de um arquivo referenciado. Se você desejar declare uma variável do tipo, você deve declarar explicitamente qual referência contém a classe que você deseja usar. Este artigo mostra como especificar um arquivo de referência específica no código.

Mais Informações

Suponha que o banco de dados do Microsoft Access contém duas referências: uma referência a um banco de dados biblioteca chamado MeuBancoDeDados, que contém uma classe chamada RecordSet, e outra referência ao Microsoft DAO 3.6 Object Library, que também contém uma classe chamada RecordSet. Para uma variável do tipo RecordSet da referência MeuBancoDeDados de dimensão, você deve usar a seguinte sintaxe:
Dim rs as MyDatabase.RecordSet
				
se você não explicitamente declarará o nome de referência quando você a variável de dimensão, qualquer referência aparecerá primeira na caixa de diálogo referências é automaticamente considerado. Se a referência errada é assumida, você poderá encontrar mensagens de erro ao tentar usar as propriedades e métodos do objeto declarado.

Você pode usar o Pesquisador de objeto do Microsoft Access para determinar o nome de referência. Para usar o Pesquisador de objetos, abra qualquer módulo no modo Design e em seguida, clique em Pesquisador de objetos no menu Exibir (ou pressione a tecla F2). O nome que aparece na caixa Projeto/biblioteca do Pesquisador de objetos é o nome dessa referência.

Referências

Para obter mais informações sobre configuração de referências, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic no menu Ajuda , digite o comando de referências (menu Ferramentas) no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Para obter mais informações sobre como usar o Pesquisador de objetos, clique em Ajuda do Microsoft Access no menu Ajuda , digite trabalhar com objetos no visual basic usando o navegador de objeto no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.

Propriedades

ID do artigo: 209912 - Última revisão: quarta-feira, 11 de outubro de 2006 - Revisão: 1.5
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2000 Standard Edition
Palavras-chave: 
kbmt kbcode kbhowto kbinfo KB209912 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 209912

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com