Opalis Integration Server Client becomes unresponsive when navigating to one or more specific policies

Article ID: 2104676 - View products that this article applies to.
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Symptoms

When navigating to one or more specific policies using the Opalis Integration Server Client, the Client becomes unresponsive for a long period of time before recovering or does not recover at all.

When viewing the process (OISClient.exe) in Task Manager, the process may show 100% CPU usage.  In addition, when viewing the OpalisManagementService.exe process on the Opalis Integration Server Management Server computer, it also may show 100% CPU usage.

Closing the Opalis Integration Server Client gracefully (if possible) stops the CPU usage of the Client and allows the OpalisManagementService.exe process to cease consuming 100% CPU and return to normal consumption.  Terminating the OISClient.exe process from Task Manager stops the CPU usage of the Client but OpalisManagementService.exe may continue to consume 100% CPU unless it is also terminated using Task Manager.

Cause

The specific policies have an extremely large volume of historical data accrued.  When a policy is selected using the Opalis Integration Server Client, the Client will load the results of all historical instances of that policy in order to populate the "Log History" tab.  A very large volume of historical data results in the Client making a request for a vast amount of data from the Management Server which it must collect from the database and then transfer to the Client for user interface processing resulting in high CPU usage first from the OpalisManagementService.exe process and then from the OISClient.exe process.

Resolution

If Log Purging is not already enabled, then it should be enabled and configured to an appropriately aggressive purging schedule.  If Log Purging is already enabled, then the configuration should be updated to be more aggressive.

Once Log Purging has been appropriately configured, select the "Purge Now" button to perform an immediate purge operation.  If the symptoms still exist, then the purging configuration still needs to be more aggressive.

More Information

To configure Log Purge, follow the steps outlined below:

  1. Open the Opalis Integration Server Client and connect to your desired Management Server.
  2. Right-Click on the Management Server name in the Connections pane and select Log Purge....
  3. Check the Schedule Log Purge checkbox in order to define a purging schedule.
  4. Select the desired option in Log Purge Options and populate the entries or days fields as desired.

The following Log Purge Options are available and will be applied to all policies with each purge execution:

  • Keep last - Keeps the most recent number of policy instances as defined by the user and purges the rest from the database.
  • Keep entries for the last - Keeps all policy instances that have occurred within the defined number of days from the current date and purges the rest from the database.
  • If the number of entries exceeds - Performs a check against each policy to determine if the number of existing policy instances exceeds the defined amount and if so keeps all policy instances that have occurred within the defined number of days from the current date and purges the rest from the database.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2104676 - Last Review: February 7, 2011 - Revision: 2.0
APPLIES TO
  • Opalis Integration Server
  • Opalis Integration Server Legacy Support
Keywords: 
KB2104676

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