Cómo: Utilizar datos de Access 2000 en Word 2000

Seleccione idioma Seleccione idioma
Id. de artículo: 211190 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo se explica cómo hacer lo siguiente:
  • Utilizar una consulta de Microsoft Access o una tabla como origen de datos de Microsoft Word 2000.
  • Utilizar Microsoft Query para recuperar datos de Access como un origen de datos en Word.
  • Exportar y use los datos de Access como un origen de datos.
  • Copiar, pegar y utilizar datos de Access como origen de datos de Word.

Cómo utilizar una consulta de Access o la tabla como un origen de datos de Word

Para obtener información adicional acerca de cómo utilizar una consulta de parámetro de Access, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
214183WD2000: Cómo usar Combinar correspondencia con una consulta de parámetros de Access
Para utilizar una consulta de Access o una tabla como un origen de datos, siga estos pasos:
  1. Si desea utilizar los resultados de una consulta de Access o la tabla como origen de datos de Word combinación de correspondencia, siga estos pasos:
    1. En el menú Herramientas , haga clic en Combinar correspondencia .
    2. En el cuadro de diálogo Combinar correspondencia , haga clic en Obtener datos y, a continuación, haga clic en Abrir origen de datos .
    3. Vaya al paso 3.
  2. Si desea insertar los resultados de una consulta de Access o la tabla en Word un documento, siga estos pasos:
    1. En el menú Ver , elija barras de herramientas y, a continuación, haga clic en la base de datos .
    2. En la barra de herramientas base de datos , haga clic en Insertar base de datos .
    3. En el cuadro de diálogo base de datos , haga clic en Obtener datos .
  3. En la lista de tipo del cuadro de diálogo Abrir origen de datos , haga clic en Bases de datos de Microsoft Access .
  4. Seleccione el archivo de base de datos de Access que desea utilizar como origen de datos.
  5. Seleccione la casilla de verificación Seleccionar método y, a continuación, haga clic en Abrir .
  6. En el cuadro de diálogo Confirmar origen de datos , haga clic en Bases de datos de MS Access con DDE (*.mdb, *.mde) y, a continuación, haga clic en Aceptar .

    Nota : si bases de datos de MS Access con DDE (*.mdb; * mde) es no está disponible, deberá quitar y volver a instalar Access.
  7. En el cuadro de diálogo Microsoft Access , haga clic en la ficha consultas o en la ficha tablas .
  8. Seleccione la consulta o tabla que desee utilizar y, a continuación, haga clic en Aceptar .

    Nota : en la ficha consultas , el vínculo a la consulta está activada de forma predeterminada. Esta opción crea un vínculo a la consulta de base de datos de Access. Active esta casilla de verificación para recuperar siempre la versión actualizada de cualquiera de las consultas enumeradas. Para omitir los cambios en las instrucciones de consulta original, desactive la casilla de verificación Vincular a la consulta .
  9. Word devuelve los resultados de la consulta de Access o una tabla al documento de Word. Siga uno de los siguientes valores, dependiendo de si va a realizar una combinación de correspondencia o insertar sólo una base de datos:
    1. Si estás utilizando la característica Combinar correspondencia, Word le pedirá que con el siguiente mensaje:
      Word no ha encontrado campos de combinación en el documento principal. Elija Modificar documento principal para incluir campos de combinación.
      Haga clic en Modificar documento principal para insertar campos de combinación en el documento principal.
    2. Si va a insertar información de base de datos, haga clic en Insertar datos en el cuadro de diálogo base de datos . En el cuadro de diálogo Insertar datos , haga clic en todo para insertar todos los resultados de la consulta de Access en el documento de Word, o haga clic en y, a continuación, especificar los registros que desea insertar en el documento de Word.

      Nota : en el cuadro de diálogo Insertar datos , la casilla de verificación Insertar datos como campo no es activada de forma predeterminada. Si está seleccionada, esta opción insertará los datos en la tabla como un campo. Active esta casilla de verificación si desea actualizar los datos del documento de Word siempre que cambie el origen de datos.

Cómo utilizar Microsoft Query para recuperar datos de Access como origen de datos en Word

Para utilizar Microsoft Query para recuperar datos de Access como un origen de datos en Word, siga estos pasos:
  1. Si desea utilizar los resultados de una consulta de Access o la tabla como origen de datos de Word combinación de correspondencia, siga estos pasos:
    1. En el menú Herramientas , haga clic en Combinar correspondencia .
    2. En Combinar correspondencia , haga clic en Obtener datos y, a continuación, haga clic en Abrir origen de datos .
    3. Vaya al paso 3.
  2. Si desea insertar los resultados de una consulta de Access o la tabla en Word un documento, siga estos pasos:
    1. En el menú Ver , elija barras de herramientas y, a continuación, haga clic en la base de datos .
    2. En la barra de herramientas base de datos , haga clic en Insertar base de datos .
    3. En el cuadro de diálogo base de datos , haga clic en Obtener datos .
  3. En el cuadro de diálogo Abrir origen de datos , haga clic en MS Query .
  4. En el cuadro de diálogo Elegir origen de datos en la ficha General , haga clic en Base de datos Microsoft Access y, a continuación, haga clic en Aceptar .

    Nota : la casilla de verificación usar el Asistente para consultas para crear o modificar consultas está activada de forma predeterminada. Esta opción utiliza al Asistente para consultas para recorrer de proceso de creación de una consulta simple que devuelve datos a Microsoft Excel u otro programa principal. Este es el procedimiento descrito aquí. Desactive la casilla usar el Asistente para consultas para crear o modificar consultas utilizar Microsoft Query sin el Asistente para consultas.
  5. En el cuadro de diálogo Seleccionar base de datos , haga clic en el archivo de base de datos de Access que desea utilizar y, a continuación, haga clic en Aceptar .

    Nota : si selecciona la casilla de verificación Sólo lectura , puede leer el archivo pero no pueden realizar cambios en él. Si selecciona la casilla de verificación exclusivo , el archivo de base de datos está bloqueado durante el tiempo que Word está usando la base de datos.
  6. En la lista de tablas y columnas disponibles en el cuadro de diálogo Asistente para consultas - Elegir columnas , realice las selecciones que desee utilizar para la consulta, agregarlos a la lista de columnas en la consulta y, a continuación, haga clic en siguiente .
  7. En el cuadro de diálogo Asistente para consultas - filtrar datos , filtrar los datos para especificar qué filas desea incluir en la consulta. Si no desea filtrar los datos, haga clic en siguiente .
  8. En el cuadro de diálogo Asistente para consultas - criterio de ordenación , especifique cómo desea ordenar los datos. Si no desea ordenar los datos, haga clic en siguiente .
  9. En el cuadro de diálogo Asistente para consultas - Finalizar , siga uno de los siguientes:
    • Haga clic en Guardar consulta para ejecutar la consulta y, a continuación, agregar esta consulta a la lista de consultas disponibles. Utilice esta lista cuando se elige una consulta para ejecutar desde Excel o Microsoft Query, o cuando elige un origen de datos. Al hacer clic en Guardar consulta , diseño de la consulta se guarda como el tipo de archivo siguientes:
      *.dqy
      -o bien -
    • Haga clic en Devolver datos a Microsoft Word y haga clic en Finalizar para ejecutar la consulta y devolver los resultados de consulta a Word.

      -o bien -
    • Haga clic en Ver datos o modificar consulta en Microsoft Query y, a continuación, haga clic en Finalizar para ejecutar la consulta y devolver los resultados de consulta a Microsoft Query. Puede ver los datos y realizar cambios adicionales en la consulta en Microsoft Query, antes de devolver los datos a Word.
Nota : si intenta utilizar Access como un origen de datos en Microsoft Query, puede recibir el siguiente mensaje de error:
Word no pudo abrir el origen de datos.
Este comportamiento puede producirse al utilizar una consulta de Access o la tabla.

Para obtener información adicional, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
224056WD2000: Mensaje de error: Word no puede abrir el origen de datos

Cómo exportar y utilizar los datos de Access como origen de datos de Word

Para exportar y utilizar los datos de Access como origen de datos de Word, siga estos pasos:
  1. En Access, abra la tabla de base de datos o consulta.
  2. En el menú archivo , haga clic en Exportar .
  3. En el cuadro de diálogo Exportar tabla o Consulta de exportación , siga estos pasos:
    1. En la lista Guardar como tipo , haga clic en Combinación de Microsoft Word .
    2. En el cuadro nombre de archivo , escriba un nombre para el archivo exportado.
    3. En la lista Guardar en , seleccione la carpeta en la que guardar el archivo.
  4. Haga clic en Guardar todo .

    Acceso ahora exporta el resultado de la tabla o consulta como un archivo de texto delimitado por tabulaciones.
  5. Cierre la base de datos y salga de Access.
En Word, utilizar el archivo de texto delimitado por tabulaciones exportado para seguir con su combinación de correspondencia de Word o para insertar el archivo de base de datos como de costumbre.

Cómo copiar, pegar y usar datos de Access como un origen de datos de Word

Para copiar, pegar y utilizar datos de Access como origen de datos de Word, siga estos pasos:
  1. Abra la tabla de base de datos de Access o la consulta.
  2. En el menú Edición , haga clic en Seleccionar todos los registros .
  3. En el menú Edición , haga clic en Copiar .
  4. Abra un nuevo documento en blanco en Microsoft Word.
  5. Utilice uno de los métodos siguientes.

Método 1: Guardar datos como una tabla

  1. En el menú Edición , haga clic en Pegado especial . En el cuadro de diálogo Pegado especial , haga clic en Texto con formato (RTF) en .

    Se pega la información de la tabla de Access o una consulta en una tabla de Word.
  2. Guardar este nuevo archivo como un documento de Word.

    Este nuevo archivo es su nuevo origen de datos de Word.

Método 2: Guardar datos en formato delimitado por tabuladores

  1. En el menú Edición , haga clic en Pegado especial .
  2. En el cuadro de diálogo Pegado especial , haga clic en Texto sin formato y, a continuación, haga clic en Aceptar .

    Se pega la información de la tabla de Access o una consulta en el documento de Word como texto delimitado por tabuladores.
  3. En el menú archivo , haga clic en Guardar como .
  4. Haga clic en el cuadro de diálogo en Sólo texto en el cuadro Guardar como tipo .
  5. En el cuadro nombre de archivo , escriba un nombre para el archivo exportado.
  6. En la lista Guardar en , seleccione la carpeta guardar el archivo y, a continuación, haga clic en Guardar . Haga clic en en respuesta al mensaje siguiente
    File namepuede contener características que no son compatibles con el formato de sólo texto. ¿Desea guardar el documento en este formato?

    Para guardar, haga clic en Sí.
    Para conservar el formato, haga clic en no. A continuación, guarde una copia en el formato más reciente de Word.
    donde file name es el nombre del documento de Word que contiene el texto desde Access.
  7. Cierre los datos de Word de origen de documento y a continuación, con su combinación de correspondencia de Word o insertar el archivo de base de datos como de costumbre.

Referencias

Para obtener información adicional acerca de la combinación de correspondencia, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
212329WD2000: Cómo iniciar una combinación de correspondencia
212322Cómo: Crear y configurar datos de correspondencia en Microsoft Word 2000
Para obtener más información acerca de cómo insertar una base de datos en el documento de Word, haga clic en Ayuda de Microsoft Word en el menú Ayuda , escriba Insertar datos de Access en un documento de Word en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver el tema.

Propiedades

Id. de artículo: 211190 - Última revisión: viernes, 22 de noviembre de 2002 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Word 2000 Standard Edition
Palabras clave: 
kbmt kbhowto kbhowtomaster kbmerge KB211190 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 211190

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com