WD2000: Solucionar problemas de documentos dañados

Seleccione idioma Seleccione idioma
Id. de artículo: 211634 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E211634
Expandir todo | Contraer todo

En esta página

Resumen

Los archivos de documentos dañados pueden hacer que cualquier programa muestre un comportamiento inusual. Dicho comportamiento se da porque el programa intenta tomar una decisión acerca de la acción que ha de llevar a cabo según una información incorrecta del archivo.

La mejor manera de evitar daños en los documentos consiste en realizar copias de seguridad de los mismos. En caso de que no disponga de una copia de seguridad del documento, en este artículo se proporcionan algunos procedimientos para la solución de problemas que puede seguir para identificar y, posiblemente, recuperar un documento dañado de Microsoft Word para Windows.

Más información

En este artículo se tratan los temas siguientes:

Identificar un documento dañado

Los documentos dañados a menudo muestran un comportamiento que no forma parte del diseño del programa (por ejemplo, repaginación infinita, diseño y formato del documento incorrectos, caracteres ilegibles en la pantalla, mensajes de error durante el procesamiento, el sistema deja de responder o se bloquea cuando se carga o muestra el archivo, o cualquier otro comportamiento inusual que no se puede atribuir al funcionamiento normal del programa). Parte de este comportamiento se puede deber a otros factores diferentes de posibles daños en el documento. Para facilitar la determinación de otros factores, siga estos pasos para solucionar problemas:
  • Compruebe si se produce un comportamiento parecido en otros documentos.
  • Compruebe si se produce un comportamiento parecido en otros programas.
  • Traslade el documento en cuestión a otro equipo e intente repetir el comportamiento.
  • Cambie la plantilla adjunta por la plantilla global (Normal.dot). Si la plantilla adjunta es Normal.dot, cierre Word y cambie el nombre de Normal.dot. Reinicie Word e intente repetir el comportamiento. Para cambiar la plantilla adjunta por la plantilla global, siga estos pasos:

    1. Abra el documento que causa problemas.
    2. En el menú Herramientas, haga clic en Plantillas y complementos.
    3. Si el cuadro Plantilla de documento muestra una plantilla distinta de Normal, haga clic en Adjuntar.
    4. En la carpeta Plantillas, haga clic para seleccionar Normal (Normal.dot) y, después, haga clic en Abrir.
    5. Haga clic en Aceptar para cerrar el cuadro de diálogo Plantillas y complementos.
  • Para cambiar la plantilla adjunta por la plantilla global, siga estos pasos: Abra Word con su configuración predeterminada. Puede utilizar el modificador "/a" para iniciar Word y evitar que cargue los complementos o que utilice la plantilla Normal.dot existente. Una vez reiniciado Word con el modificador "/a", intente repetir el comportamiento. Para obtener información adicional acerca del modificador de inicio "/a" y cómo utilizarlo, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
    210565 WD2000: Word Startup (Command-Line) Switches and Their Purpose
    244843 WD2000: What Does the Word Startup Switch "/a" Really Do?
  • Para cambiar la plantilla adjunta por la plantilla global, siga estos pasos: Utilice un controlador de impresora diferente e intente repetir el comportamiento. Si el comportamiento continúa incluso con un controlador de impresora distinto, quizás sea necesario quitar completamente y volver a instalar el controlador de impresora existente.

    O bien

    Reemplace el controlador de impresora existente mediante estos pasos:
    1. Haga clic en Inicio, seleccione Configuración y, a continuación, haga clic en Impresoras.

      NOTA: en Microsoft Windows XP, haga clic en Inicio y, a continuación, haga clic en Impresoras y faxes.
    2. Haga clic con el botón secundario del mouse (ratón) en la impresora que desee quitar y, después, haga clic en Eliminar.
    3. Si se le pregunta si desea quitar todos los archivos asociados con la impresora, haga clic en .
    4. Realice una de las operaciones siguientes:
      • En Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows Millennium Edition (Me), Microsoft Windows NT 4.0 o Microsoft Windows 2000, haga doble clic en el icono Agregar impresora y siga las instrucciones del Asistente para agregar impresoras con el fin de volver a instalar el controlador de impresora de Windows. O bien

      • O bien En Windows XP, haga clic en Agregar una impresora bajo Tareas de impresión y siga las instrucciones del Asistente para agregar impresoras con el fin de volver a instalar el controlador de impresora de Windows.
    Para obtener información adicional acerca de cómo solucionar los problemas de impresión en Microsoft Windows, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
    128345 Solucionar problemas de impresión en Windows 95/98
    93503 Aislar problemas generales de impresión
    163551 Solucionar problemas de impresión en Windows NT 4.0
    132460 Troubleshooting Windows NT Print Server Alteration of Print Jobs
  • Para cambiar la plantilla adjunta por la plantilla global, siga estos pasos: Cambie otros componentes del sistema (como los controladores de vídeo o las fuentes), desactive los programas de otros fabricantes que se estén ejecutando (como los programas residentes [TSR], los administradores de fuentes, los protectores de pantalla y los shell del sistema) y, a continuación, intente repetir el comportamiento. Para obtener información adicional acerca de cómo desactivar programas que se inician con Windows, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
    192926 Cómo realizar la solución de problemas de inicio limpio en Windows 98
    E180902 Cómo iniciar un equipo en Modo a prueba de fallos en Windows 98
    E156126 Solucionar problemas de Windows 95 con el Modo a prueba de fallos
    200116 OFF2000: Solucionar problemas de programas de Office en Windows NT 4.0
    155681 Troubleshooting Display Problems in Windows NT 4.0
Si, tras realizar estos pasos, el problema sólo ocurre con un documento o un grupo reducido de documentos similares, es probable que el documento o los documentos estén dañados.



Qué debe intentar si el documento se abre pero se comporta de manera inesperada

Método 1: guardar el documento en otro formato de archivo y volverlo a convertir a Word

Este es el método de recuperación de documentos más sencillo y más completo. Inténtelo siempre en primer lugar. Guarde el documento en un formato de archivo diferente; se sugiere que lo guarde como Formato de texto enriquecido (*.rtf) o como Página Web (*.htm; *.html) en primer lugar, ya que estos formatos conservan el formato del documento de Word.

Una vez guardado el archivo en un formato diferente, cierre y vuelva a abrir el documento en Word y, a continuación, guárdelo como un Documento de Word (*.doc). Si este método funciona correctamente, el daño del archivo se eliminó durante la conversión. Si el daño persiste, intente guardar el archivo en otro formato.

Microsoft recomienda que intente guardar el archivo en los siguientes formatos, en orden descendente:
Formato de texto enriquecido (*.rtf)
Página Web (*.htm; *.html)
Cualquier otro formato de procesador de textos
Sólo texto (*.txt)
NOTA IMPORTANTE: Al guardar los archivos en el formato Sólo texto el problema de daños en el documento se corrige. Sin embargo, todo el formato del documento, los gráficos y el código de macros se perderán. Este método requiere dar más formato; por tanto, utilícelo sólo cuando otros formatos de archivo no consigan corregir el problema.

Para obtener información adicional acerca del código de macros que se pierde al guardar en un formato de archivo diferente, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
212387 WD2000: VBA Code Lost When Converting to Another File Format

Método 2: copiar a un nuevo documento todo excepto la última marca de párrafo

Word para Windows asocia una amplia variedad de formatos con la última marca de párrafo, especialmente el formato de secciones y estilos. Si copia todo, excepto la última marca de párrafo, a un nuevo documento, es posible que el daño se quede en el documento original. En el nuevo documento, vuelva a aplicar el formato de secciones y estilos.

NOTA: para seleccionar todo excepto la última marca de párrafo, presione CTRL+FIN y, a continuación, CTRL+MAYÚS+INICIO. Si el documento contiene saltos de sección, copie únicamente el texto que se encuentra entre los saltos de sección (no copie y pegue los saltos de sección porque esto puede dañar el nuevo documento).

Microsoft recomienda que trabaje con el documento de Word en la vista Normal cuando copie y pegue entre documentos para evitar transferir los saltos de sección de un documento a otro. Para cambiar a la vista Normal, haga clic en Normal en el menú Ver.

Método 3: copiar las partes no dañadas del documento a un nuevo documento

En ocasiones puede determinar la ubicación del daño del archivo en el documento. En estos casos, copie todo a un nuevo documento a excepción de la parte dañada y, a continuación, vuelva a construir la sección dañada del documento.

NOTA: si el documento contiene saltos de sección, copie únicamente el texto que se encuentra entre los saltos de sección (no copie y pegue los saltos de sección porque esto puede dañar el nuevo documento).

Microsoft recomienda que trabaje con el documento de Word en la vista Normal cuando copie y pegue entre documentos para evitar transferir los saltos de sección de un documento a otro. Para cambiar a la vista Normal, haga clic en Normal en el menú Ver.



Qué debe intentar si el documento no se abre

Existen varias técnicas que puede utilizar para intentar para abrir un documento que no se abre. El método que utilice dependerá de la naturaleza y la gravedad del daño en el documento, y de la naturaleza del comportamiento demostrado. Aunque muchos de estos métodos proporcionan generalmente resultados satisfactorios, no todos los documentos dañados pueden recuperarse.

Método 1: abrir el documento dañado de Word en modo borrador sin actualizar los vínculos

En ocasiones, puede abrir un documento en modo borrador sin actualizar los vínculos cuando no se abre de otra manera. Para ello, siga estos pasos:
  1. En el menú Ver, haga clic en Normal.
  2. En el menú Herramientas, haga clic en Opciones.
  3. En la ficha Ver, haga clic para activar las casillas de verificación Fuente de borrador y Marcadores de imagen.
  4. En la ficha General, haga clic para desactivar la casilla de verificación Actualizar vínculos automáticos al abrir y, a continuación, haga clic en Aceptar.
Si el documento se abre, quizás pueda recuperar o reparar el archivo mediante los pasos descritos en la sección "Qué debe intentar si el documento se abre pero se comporta de manera inesperada" de este artículo.

Método 2: insertar el documento como un archivo en un documento nuevo

La última marca de párrafo de un documento de Word contiene información acerca del documento. Si el documento está dañado, es posible que pueda recuperar el texto del documento si puede omitir esta última marca de párrafo.

Para tener acceso a un documento sin la última marca de párrafo, siga estos pasos:
  1. En el menú Archivo, haga clic en Nuevo.
  2. En la ficha General, haga clic para seleccionar Documento en blanco y, después, haga clic en Aceptar.
  3. En el menú Insertar, haga clic en Archivo.
  4. En el cuadro de diálogo Insertar archivo, busque y seleccione el documento dañado y, después, haga clic en Insertar.
NOTA: quizás tenga que volver a aplicar ciertos formatos a la última sección del nuevo documento.

Método 3: abrir el archivo mediante un vínculo

Si el método 2 "Insertar el documento como un archivo en un documento nuevo" no funciona, inténtelo con éste.

Este método puede permitirle abrir el archivo si parte del encabezado o si la última marca de párrafo se encuentra en el área dañada del documento.

Realice los siguientes pasos para establecer un vínculo con un archivo que no esté dañado y, a continuación, cambie el vínculo para que señale al archivo dañado:
  1. En el menú Archivo, haga clic en Nuevo.
  2. En la ficha General, haga clic en Documento en blanco y, después, haga clic en Aceptar.
  3. En el nuevo documento, escriba Esto es una prueba y, a continuación, guarde el documento.
  4. Seleccione el texto y haga clic en Copiar en el menú Edición.
  5. En el menú Archivo, haga clic en Nuevo.
  6. En la ficha General, haga clic en Documento en blanco y, después, haga clic en Aceptar.
  7. En este nuevo documento, haga clic en Pegado especial en el menú Edición.
  8. Seleccione Texto con formato, haga clic para seleccionar Pegar vínculo y, a continuación, haga clic en Aceptar.
  9. En el menú Edición, haga clic en Vínculos.
  10. En el cuadro de diálogo Vínculos, seleccione el nombre de archivo del documento vinculado y haga clic en Cambiar origen.
  11. En el cuadro de diálogo Cambiar origen, seleccione el documento que ya no puede abrir y haga clic en Abrir.
  12. Haga clic en Aceptar para cerrar el cuadro de diálogo Vínculos.

    NOTA: aparecerá la información del documento dañado (siempre y cuando hubiera datos o texto recuperables).
  13. En el menú Edición, haga clic en Vínculos.
  14. En el cuadro de diálogo Vínculos, haga clic en Romper vínculo. Cuando aparezca el siguiente mensaje, haga clic en .
    ¿Está seguro de que desea cancelar los vínculos seleccionados?
Ya puede volver a dar formato y guardar el documento recuperado.

Método 4: utilizar el convertidor Recuperar texto de cualquier archivo

El convertidor Recuperar texto de cualquier archivo le permite extraer el texto de cualquier archivo. No es necesario que se trate de un archivo de Word. El uso del convertidor Recuperar texto de cualquier archivo tiene sus limitaciones. El formato del documento se pierde, así como todo aquello que no tiene formato de texto. Se pierden gráficos, campos, objetos de dibujo, etc. Sin embargo, los encabezados, los pies de página, las notas al pie, las notas al final y el texto de los campos se mantienen como texto simple.

Además, después de recuperar el documento mediante el convertidor Recuperar texto de cualquier archivo habrá datos binarios que no se puedan recuperar, especialmente en la parte superior e inferior del documento. Es necesario eliminar estos datos binarios antes de volver a dar formato al archivo y guardarlo como un documento de Word.

Para obtener información adicional acerca de cómo utilizar el convertidor "Recuperar texto de cualquier archivo", haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
212274 WD2000: How to Recover Text from Any File

Método 5: abrir el archivo en WordPad

Cuando no pueda abrir un documento dañado en Word para Windows (generalmente debido a daños en el encabezado del archivo), puede quitar el encabezado del archivo y abrirlo como texto. Al quitar la información del encabezado se pierde todo el formato. Con el siguiente método podrá quitar la información del encabezado del archivo.
  1. Inicie Microsoft WordPad. En Windows, en el menú Inicio, seleccione Programas, seleccione Accesorios y, a continuación, haga clic en WordPad.
  2. En el menú Archivo, haga clic en Abrir y abra el documento de Word dañado.

    El documento de Word se abrirá como un archivo de texto. Es posible que vea caracteres binarios (extraños) al principio y al final del documento. Puede eliminar estos y otros caracteres que no pertenezcan al documento de Word dañado.
  3. En el menú Archivo, haga clic en Guardar como. En el cuadro Nombre de archivo, escriba un nuevo nombre de archivo con la extensión .doc. Antes de hacer clic en el botón Aceptar, anote la carpeta donde se va a guardar el archivo para que pueda encontrarla fácilmente al reiniciar Word.
  4. En el menú Archivo, haga clic en Salir.
  5. Reinicie Word y abra el archivo guardado desde WordPad (el archivo tendrá el nombre que le dio en el paso 3).
  6. En el menú Archivo, haga clic en Guardar como y guarde el archivo en formato Documento de Word (*.doc).
Ahora puede volver a dar formato al nuevo documento y agregar gráficos, campos y otros formatos que se encontraran posiblemente en el documento dañado.



Opciones de soporte técnico de Microsoft

Si no puede resolver este problema, dispone de varias opciones de soporte técnico que le pueden ayudar.

Encuentre con rapidez respuestas en línea

Use el Soporte técnico en línea de Microsoft para buscar en Microsoft Knowledge Base y en otros recursos técnicos respuestas precisas y rápidas. También puede personalizar el sitio para controlar la búsqueda.

Para comenzar la búsqueda, visite el sitio Web siguiente:
http://www.microsoft.com/spain/support/

Soporte técnico de Microsoft

Póngase en contacto con un profesional de Soporte técnico de Microsoft para que le ayude a solucionar los problemas.

Para obtener más información acerca de cómo obtener ayuda para la solución de problemas de Microsoft Windows, haga clic en Temas de Ayuda en el menú Ayuda del Explorador de Windows. En la ficha Contenido , haga doble clic para abrir el libro Solucionar problemas . A continuación, haga doble clic para abrir el libro Ponerse en contacto con el Servicio de soporte técnico de Microsoft para ver las opciones de soporte técnico.

Para obtener más información acerca de cómo obtener Ayuda para la solución de problemas de Microsoft Word, haga clic en Acerca de Microsoft Word en el menú Ayuda y, a continuación, haga clic en Soporte técnico.

Para obtener información adicional acerca de los servicios de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
102344 Microsoft Product Support Options Q&A

Microsoft Solution Providers

Los Microsoft Solution Providers son organizaciones independientes que han llegado a un acuerdo de cooperación con Microsoft para aplicar su tecnología a la solución de problemas empresariales en compañías e industrias de todos los tamaños.

Para obtener información acerca de los Microsoft Solution Providers en España, póngase en contacto con el Centro de Atención al Cliente en el número 902 197 198. En otros países, póngase en contacto con la subsidiaria local de Microsoft. Para encontrar la subsidiaria local, visite el sitio Web de oficinas de Microsoft en el mundo:
http://www.microsoft.com/worldwide/

Propiedades

Id. de artículo: 211634 - Última revisión: miércoles, 31 de agosto de 2005 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Word 2000 Standard Edition
Palabras clave: 
kbdta kbfaq kbinfo kbtshoot wd2000 KB211634

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com