Risoluzione dei problemi relativi a documenti danneggiati di Word 2000

Traduzione articoli Traduzione articoli
Identificativo articolo: 211634 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la versione di questo articolo relativa a Microsoft Office Word 2003, vedere 826864.
Per la versione di questo articolo relativa a Microsoft Word 2002, vedere 290932.
Per la versione di questo articolo relativa a Microsoft Word 97, vedere 187309.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

I file danneggiati determinano comportamenti anomali nei programmi. Tali comportamenti si verificano perchÚ il programma tenta di effettuare operazioni basandosi su informazioni non corrette contenute nel documento danneggiato.

Il modo migliore per evitare i problemi causati da documenti danneggiati consiste nel conservare copie di backup dei documenti stessi. Nel caso non si disponga di una copia di backup del documento, utilizzare le procedure per la risoluzione dei problemi descritte in questo articolo per identificare ed eventualmente ripristinare un documento danneggiato di Microsoft Word per Windows.

Informazioni

In questo articolo sono illustrati i seguenti argomenti:

Identificazione di un documento danneggiato

I documenti danneggiati determinano spesso un comportamento anomalo da parte del programma, ad esempio operazioni di impaginazione senza fine, formattazione e layout di documento non corretti, caratteri illeggibili, messaggi di errore durante l'elaborazione, blocco o arresto del sistema durante il caricamento o la visualizzazione del file o qualsiasi altro comportamento inusuale non attribuibile al normale funzionamento del programma. Alcuni di questi comportamenti possono tuttavia essere riconducibili anche ad altri fattori e non solo a documenti danneggiati. Per facilitare l'identificazione di altri fattori, attenersi alla seguente procedura di risoluzione dei problemi:
  • Controllare se tali comportamenti si verificano anche con altri documenti.
  • Controllare se comportamenti simili si verificano anche in altri programmi.
  • Utilizzare il documento in questione in un altro computer e provare a riprodurre il comportamento.
  • Sostituire il modello allegato con il modello globale (Normal.dot). Se il modello allegato Ŕ Normal.dot, uscire da Word e rinominare il file Normal.dot. Riavviare Word e provare a riprodurre il comportamento.

    Per sostituire il modello allegato con il modello globale, attenersi alla seguente procedura:
    1. Aprire il documento che ha causato il problema.
    2. Scegliere Modelli e aggiunte dal menu Strumenti.
    3. Se nella casella Modello di documento Ŕ contenuto un documento diverso da Normal, scegliere Applica.
    4. Nella cartella Modelli fare clic su Normal (Normal.dot), quindi scegliere Apri.
    5. Scegliere OK per chiudere la finestra di dialogo Modelli e aggiunte.
  • Avviare Word con le impostazioni predefinite. ╚ possibile avviare Word con il parametro "/a" per impedire che vengano caricati i componenti aggiuntivi o che venga utilizzato il modello Normal.dot esistente. Dopo avere riavviato Word con il parametro /a, provare a riprodurre il comportamento.
  • Per ulteriori informazioni sull'utilizzo delle opzioni della riga di comando per l'avvio di Word 2003, Word 2002 e Word 2000, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito (il contenuto potrebbe essere in inglese):
    210565 WD2000: Utilizzo delle opzioni della riga di comando per l'avvio di Word 2003, Word 2002 e Word 2000
    244843 WD2000: Descrizione dell'opzione di avvio /a in Word 2000
  • Utilizzare un diverso driver di stampante e provare a riprodurre il comportamento. Se il comportamento persiste anche con un driver di stampante diverso, potrebbe essere necessario rimuovere completamente e reinstallare il driver di stampante esistente.

    Oppure

    Sostituire il driver di stampante esistente attenendosi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Stampanti.

      Nota In Microsoft Windows XP fare clic sul pulsante Start, quindi scegliere Stampanti e fax.
    2. Fare clic con il pulsante destro del mouse sulla stampante che si desidera rimuovere, quindi scegliere Elimina.
    3. Se viene chiesto di eliminare tutti i file associati alla stampante, scegliere .
    4. Effettuare una delle seguenti operazioni:
      • In Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows Millennium Edition (ME), Microsoft Windows NT 4.0, o Microsoft Windows 2000 fare doppio clic su Aggiungi stampante e seguire le istruzioni dell'Installazione guidata stampante per reinstallare il driver della stampante di Windows.

        Oppure
      • In Windows XP in Operazioni stampante scegliere Aggiungi stampante, quindi seguire le istruzioni dell'Installazione guidata stampante per reinstallare il driver della stampante di Windows.
    Per ulteriori informazioni sulla risoluzione dei problemi di stampa in Windows 95, Windows 98 e Windows Millennium Edition, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito (il contenuto potrebbe essere in inglese):
    128345 Risoluzione dei problemi di stampa in Windows 95/98
    93503 Isolamento di problemi di stampa generali
    163551 Risoluzione dei problemi di stampa in Windows NT 4.0
    132460 Risoluzione dei problemi relativi all'alterazione dei processi di stampa nel server di stampa di Windows
  • Cambiare altri componenti di sistema, come schede video o tipi di carattere, e disattivare qualsiasi programma di terze parti in esecuzione, ad esempio programmi TSR, gestori di caratteri, screen saver e shell di sistema, quindi tentare di riprodurre il comportamento.
    Per ulteriori informazioni sulla disattivazione di programmi avviati con Windows, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito (il contenuto potrebbe essere in inglese):
    192926 Risoluzione dei problemi mediante l'avvio parziale di Windows 98
    180902 Avvio di un computer Windows 98 in ModalitÓ provvisoria
    156126 Risoluzione dei problemi di Windows 95 mediante la modalitÓ Provvisoria
    200116 OFF2000: Risoluzione dei problemi dei programmi di Office in Windows NT 4.0
    155681 Risoluzione dei problemi di visualizzazione in Windows NT 4.0
Se il problema si presenta solo con un documento o un gruppo di documenti simili dopo aver eseguito queste verifiche, molto probabilmente il documento o i documenti sono danneggiati.



Operazioni da effettuare se il documento viene aperto ma presenta un comportamento imprevisto

Metodo 1: Salvare il documento in un altro formato, quindi riconvertirlo nel formato di Word

Questo Ŕ il modo migliore e pi¨ completo per ripristinare un documento ed Ŕ quello che si consiglia di utilizzare sempre per primo. Salvare il documento in un altro formato. Si suggerisce di provare prima a salvare il documento in formato Rich Text Format (*.rtf) o Pagina Web (*.htm; *.html) poichÚ questi formati conservano la formattazione del documento di Word.

Dopo avere salvato il file in un formato differente, chiudere e riaprire il documento in Word, quindi salvarlo come Documento Word (*.doc). Se questo metodo fornisce risultati positivi, l'errore viene rimosso dal file durante il processo di conversione. Se l'errore persiste, provare a salvare il file in un altro formato.

Microsoft consiglia di provare a salvare il file nei seguenti formati attenendosi all'ordine indicato:
Rich Text Format (*.rtf)
Pagina Web (*.htm; *.html)
Qualsiasi altro formato di elaborazione testi
Solo testo (*.txt)
NOTA IMPORTANTE: il salvataggio di un file in formato Solo testo consente spesso di risolvere i problemi relativi a documenti danneggiati, ma determina anche la perdita di qualsiasi informazione di formattazione del documento, comprese immagini e codice macro. Questo metodo richiede un notevole lavoro di riformattazione e in quanto tale Ŕ consigliabile ricorrervi solo dopo che tutti gli altri formati di file non hanno consentito di correggere il problema.

Per ulteriori informazioni sulla perdita di codice macro quando si effettua il salvataggio in un formato diverso, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
212387 WD2000: Perdita di codice VBA durante la conversione in un altro formato di file

Metodo 2: Copiare tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo in un nuovo documento

Word per Windows associa tutta una serie di informazioni di formattazione all'ultimo segno di paragrafo del documento, specialmente per quanto riguarda formattazioni di sezione e di stile. Copiando tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo in un nuovo documento, Ŕ possibile che venga tralasciata la parte danneggiata del documento originale. In seguito sarÓ necessario riapplicare la formattazione di sezione e di stile al nuovo documento.

Nota ╚ possibile selezione tutto il contenuto di un documento a eccezione dell'ultimo segno di paragrafo premendo INVIO+FINE e quindi INVIO+MAIUSC+HOME. Se il documento contiene interruzioni di sezione, copiare solo il testo tra le interruzioni. Evitare di copiare e incollare le interruzioni di sezione perchÚ si potrebbero importare gli errori nel nuovo documento.

Quando si copiano e incollano parti di documenti, si consiglia di lavorare in visualizzazione Normale per evitare di trasferire anche le interruzioni di sezione. Per passare alla visualizzazione Normale, scegliere Normale dal menu Visualizza.

Metodo 3: Copiare le parti danneggiate del documento in un nuovo documento

Talvolta Ŕ possibile determinare la parte danneggiata di un documento. In questi casi si consiglia di copiare in un nuovo file tutto il contenuto del documento a eccezione della parte danneggiata e ricostruirla nel nuovo documento.

Nota Se il documento contiene interruzioni di sezione, copiare solo il testo tra le interruzioni. Evitare di copiare e incollare le interruzioni di sezione perchÚ si potrebbero importare gli errori nel nuovo documento.

Quando si copiano e incollano parti di documenti, si consiglia di lavorare in visualizzazione Normale per evitare di trasferire anche le interruzioni di sezione. Per passare alla visualizzazione Normale, scegliere Normale dal menu Visualizza.



Operazioni da effettuare se il documento non viene aperto

Esistono varie tecniche da utilizzare per aprire un documento che non viene aperto normalmente. Il metodo da utilizzare dipende dalla natura e dalla gravitÓ del danno e dal tipo di comportamento anomalo del documento. Sebbene molti di questi metodi vengano utilizzati regolarmente con successo, non tutti i documenti danneggiati possono essere recuperati.

Metodo 1: Aprire il documento di Word danneggiato in modalitÓ Bozza senza aggiornare i collegamenti

Quando non Ŕ possibile aprirlo in altri modi, a volte un documento pu˛ essere aperto in modalitÓ Bozza senza aggiornamento dei collegamenti attenendosi alla seguente procedura:
  1. Scegliere Normale dal menu Visualizza.
  2. Scegliere Opzioni dal menu Strumenti.
  3. Nella scheda Visualizza fare clic per selezionare le caselle di controllo Caratteri bozza e Segnaposto immagini.
  4. Nella scheda Generale fare clic per deselezionare la casella di controllo Aggiorna collegamenti automatici all'apertura, quindi scegliere OK.
Se il documento viene aperto correttamente, Ŕ possibile tentare di ripristinare o riparare il file utilizzando la procedura descritta nella sezione "Operazioni da effettuare se il documento viene aperto ma presenta un comportamento imprevisto" in questo articolo.

Metodo 2: Inserire il documento come file in un nuovo documento

L'ultimo segno di paragrafo in un documento di Word contiene informazioni sul documento stesso. Se il documento Ŕ danneggiato, Ŕ possibile tentare di recuperare il testo omettendo l'ultimo segno di paragrafo.

Per accedere a un documento tralasciando l'ultimo segno di paragrafo, attenersi alla seguente procedura:
  1. Scegliere Nuovo dal menu File.
  2. Nella scheda Generale fare clic su Documento vuoto, quindi scegliere OK.
  3. Scegliere File dal menu Inserisci.
  4. Nella finestra di dialogo Inserisci file individuare e selezionare il documento danneggiato, quindi scegliere Inserisci.
NOTA: potrebbe necessario riapplicare la formattazione all'ultima sezione del nuovo documento.

Metodo 3: Aprire il file tramite un collegamento

Se il "Metodo 2: Inserire il documento come file in un nuovo documento" non funziona, provare questo metodo.

Il metodo pu˛ consentire l'apertura del file se una parte dell'intestazione del file o se l'ultimo segno di paragrafo si trova nell'area danneggiata del documento.

Per creare un collegamento a un file non danneggiato, quindi modificare il collegamento in modo che faccia riferimento al file danneggiato, attenersi alla procedura seguente:
  1. Scegliere Nuovo dal menu File.
  2. Nella scheda Generale fare su Documento vuoto, quindi scegliere OK.
  3. Nel nuovo documento digitare Questa Ŕ una prova e salvare il documento.
  4. Selezionare il testo e scegliere Copia dal menu Modifica.
  5. Scegliere Nuovo dal menu File.
  6. Nella scheda Generale fare su Documento vuoto, quindi scegliere OK.
  7. Nel nuovo documento scegliere Incolla speciale dal menu Modifica.
  8. Selezionare Testo formattato, fare clic per selezionare Incolla collegamento, quindi scegliere OK.
  9. Scegliere Collegamenti dal menu Modifica.
  10. Nella finestra di dialogo Collegamenti selezionare il nome di file del documento collegato, quindi scegliere Cambia origine.
  11. Nella finestra di dialogo Cambia origine selezionare il documento impossibile da aprire, quindi scegliere Apri.
  12. Scegliere OK per chiudere la finestra di dialogo Collegamenti.

    Nota Dovrebbero essere visualizzate le informazioni contenute nel documento danneggiato, a condizione che vi siano dati o testo recuperabili.
  13. Scegliere Collegamenti dal menu Modifica.
  14. Nella finestra di dialogo Collegamenti fare clic su Interrompi collegamento. Quando viene visualizzato il messaggio riportato di seguito, scegliere .

    Interrompere i collegamenti selezionati?
A questo punto sarÓ possibile riformattare e salvare il documento.

Metodo 4: Utilizzare il convertitore Recupera testo da qualsiasi file

Il convertitore Recupera testo da qualsiasi file consente di estrarre il testo da un file di qualunque tipo, non necessariamente un file di Word. Il convertitore Recupera testo da qualsiasi file presenta tuttavia alcuni limiti. Nel recupero viene infatti persa la formattazione e tutto ci˛ che non Ŕ testo. Grafica, campi, oggetti di disegno e cosý via non vengono recuperati. Intestazioni, piŔ di pagina, note a piŔ di pagina, note di chiusura e campi di testo vengono tuttavia conservati come testo semplice.

Inoltre, dopo il ripristino del documento tramite il convertitore Recupera testo da qualsiasi file alcuni dati binari non potranno essere convertiti, soprattutto all'inizio e alla fine del documento. Questi dati binari dovranno essere eliminati prima di riformattare e salvare il file come documento di Word.

Per ulteriori informazioni su come recuperare testo da qualsiasi file in Microsoft Word 2000, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
212274 Recupero di testo da qualsiasi documento in Word 2000

Metodo 5: Aprire il file in WordPad

Se non Ŕ possibile aprire un documento danneggiato in Word per Windows, generalmente a causa di un danno nell'intestazione del file, Ŕ possibile eliminare l'intestazione del file e aprirlo come testo. La rimozione delle informazioni di intestazione causa la perdita di tutta la formattazione. Il seguente metodo consente di eliminare dal file le informazioni di intestazione.
  1. Avviare Microsoft WordPad.

    In Windows fare clic sul pulsante Start, scegliere Programmi, Accessori e infine WordPad.
  2. Scegliere Apri dal menu File e aprire il documento di Word danneggiato.

    Il documento dovrebbe essere aperto come file di testo. Alla fine e all'inizio del documento dovrebbero essere presenti caratteri binari (non riconoscibili). ╚ possibile eliminare questi caratteri e tutti quelli che non appartengono al documento di Word danneggiato.
  3. Scegliere Salva con nome dal menu File. Nella casella Nome file digitare un nuovo nome file con estensione doc. Prima di scegliere OK, prendere nota della cartella in cui viene salvato il file per poterlo trovare facilmente quando si riavvia Word.
  4. Scegliere Esci dal menu File.
  5. Riavviare Word e aprire il file salvato da WordPad con il nome assegnato nel passaggio 3.
  6. Scegliere Salva con nome dal menu File salvando il file in formato Documento Word (*.doc).
A questo punto Ŕ possibile riformattare il nuovo documento e aggiungere grafica, campi e altra formattazione che erano eventualmente presenti nel documento danneggiato.

ProprietÓ

Identificativo articolo: 211634 - Ultima modifica: mercoledý 31 agosto 2005 - Revisione: 3.3
Le informazioni in questo articolo si applicano a
  • Microsoft Word 2000 Standard Edition
Chiavi:á
kbcorrupt kbdta kbfaq kbinfo kbtshoot wd2000 KB211634
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com