WD2000: Resolução de problemas de documentos danificados

Traduções de Artigos Traduções de Artigos
Artigo: 211634 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT211634
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Os documentos danificados podem provocar problemas de funcionamento noutros programas. Tal deve-se ao facto de o programa tentar efectuar acções com base em informações incorrectas existentes naqueles documentos.

O melhor modo de se proteger contra danos nos documentos é manter cópias de segurança destes. Caso não tenha uma cópia de segurança do seu documento, este artigo fornece alguns procedimentos de resolução de problemas que poderão ser utilizados para identificar e, possivelmente, recuperar, um documento danificado do Microsoft Word para Windows.

Mais Informação

Este artigo abrange os seguintes tópicos:

Identificar um documento danificado

Frequentemente, os documentos danificados apresentam um comportamento que não faz parte da concepção do programa (por exemplo, repaginação infinita, esquema e formatação incorrectos do documento, caracteres ilegíveis no ecrã, apresentação de mensagens de erro durante o processamento, paragem ou falha do sistema durante o carregamento ou visualização do ficheiro ou qualquer outro comportamento anormal que não possa ser atribuído ao funcionamento normal do programa). Alguns destes comportamentos podem ser causados por factores que não incluam a existência de danos no documento. Para o ajudar a pôr de parte outros factores, utilize os seguintes passos de resolução de problemas:
  • Verifique a existência de comportamento semelhante noutros documentos.
  • Verifique a existência de comportamento semelhante noutros programas.
  • Copie o documento em questão para outro computador e tente duplicar o comportamento.
  • Altere o modelo anexado para o modelo global (Normal.dot). Se o modelo anexado for o Normal.dot, saia do Word e mude o nome ao Normal.dot. Depois de reiniciar o Word, tente duplicar o problema. Para alterar o modelo anexado para o modelo global, utilize os seguintes passos:

    1. Abra o documento com problemas.
    2. No menu Ferramentas, clique em Modelos e suplementos.
    3. Se a caixa Modelo do documento mostrar um modelo que não seja o Normal, clique em Anexar.
    4. Na pasta Modelos, clique para seleccionar Normal (Normal.dot) e clique em Abrir.
    5. Clique em OK para fechar a caixa de diálogo Modelos e suplementos.
  • Para alterar o modelo anexado para o modelo global, utilize os seguintes passos: Inicie o Word com as respectivas predefinições. Pode utilizar o parâmetro /a para iniciar o Word de modo a que este não carregue quaisquer suplementos ou que este não utilize o modelo Normal.dot existente. Depois de reiniciar o Word com o parâmetro /a, tente duplicar o comportamento. Para obter informações adicionais sobre o parâmetro de arranque /a e a respectiva utilização, clique nos números de artigo existentes abaixo para visualizar os artigos na Microsoft Knowledge Base:
    210565WD2000: Parâmetros de arranque do Word (linha de comandos) e respectiva finalidade
    244843WD2000: O que faz realmente o parâmetro "/a" de arranque do Word?
  • Para alterar o modelo anexado para o modelo global, utilize os seguintes passos: Utilize outro controlador de impressora e tente duplicar o comportamento. Se o comportamento persistir com outro controlador de impressora, poderá ter de remover totalmente e reinstalar o controlador de impressora existente.

    -ou-

    Substitua o controlador de impressora existente utilizando os seguintes passos:
    1. Clique em Iniciar, aponte para Definições e, em seguida, clique em Impressoras.
    2. Clique com o botão direito do rato na impressora que pretende remover e, em seguida, clique em Eliminar.
    3. Se lhe for perguntado se pretende remover todos os ficheiros associados à impressora, clique em Sim.
    4. Clique em Iniciar, aponte para Definições e, em seguida, clique em Impressoras.
    5. Clique duas vezes no ícone Adicionar impressora e siga as instruções apresentadas pelo Assistente para adicionar impressoras para reinstalar o controlador de impressora do Windows.
    Para obter informações adicionais sobre a resolução de problemas relacionados com impressoras no Microsoft Windows, clique nos números de artigo existentes abaixo para visualizar os artigos na Microsoft Knowledge Base:
    128345 Troubleshooting Printing Problems in Windows 95/98
    93503 Isolating General Printing Problems
    163551Resolução de problemas de impressão no Windows
    132460 Troubleshooting Windows NT Print Server Alteration of Print Jobs
  • Para alterar o modelo anexado para o modelo global, utilize os seguintes passos: Passe para outros componentes do sistema (tais como controladores de vídeo ou tipos de letra) e desactive quaisquer programas de outros fornecedores que estejam em execução (tais como programas TSR, gestores de tipos de letra, protecções de ecrã e shells do sistema) e, em seguida, tente duplicar o comportamento. Para obter informações adicionais sobre a desactivação de programas iniciados com o Windows, clique nos números de artigo existentes abaixo para visualizar os artigos na Microsoft Knowledge Base:
    192926Como efectuar a resolução de problemas com arranque limpo para o Windows 98
    180902Como iniciar um computador baseado no Windows em modo de segurança
    156126 Troubleshooting Windows 95 Using Safe Mode
    200116OFF2000: Resolução de problemas de programas do Office no Windows NT 4.0
    155681 Troubleshooting Display Problems in Windows NT 4.0
Se, após ter efectuado estes passos, o problema ocorrer apenas com um só documento ou com um pequeno grupo de documentos semelhantes, é provável que esses documentos estejam danificados.



Acções a tentar se o documento abrir mas apresentar um comportamento inesperado

Método 1: Guardar o documento noutro formato de ficheiro e, em seguida, convertê-lo novamente para o formato do Word

Este é o método de recuperação de documentos mais fácil e completo; experimente-o sempre em primeiro lugar. Guarde o documento noutro formato de ficheiro; sugerimos que guarde o documento nos formatos Rich Text Format (*.rtf) ou Página Web (*.htm; *.html), porque estes formatos preservam a formatação do documento do Word.

Depois de guardar o ficheiro noutro formato, feche-o, abra-o novamente no Word e, em seguida, guarde-o no formato Documento do Word (*.doc). Se este método tiver êxito, os danos existentes no ficheiro foram corrigidos durante a conversão. Se os danos persistirem, tente guardar o ficheiro noutro formato.

A Microsoft recomenda que tente guardar o ficheiro nos seguintes formatos, em ordem descendente:
Rich Text Format (*/rtf)
Página Web (*.htm; *.html)
Qualquer outro formato de processamento de texto
Só texto (*.txt)
NOTA IMPORTANTE: Guardar os ficheiros no formato Só texto corrige frequentemente os danos existentes; no entanto, esta conversão causa a perda de toda a formatação do documento, dos gráficos e do código das macros. Este método requer uma maior reformatação do documento; por este motivo, só o deverá utilizar se nenhum dos outros formatos de ficheiro conseguir resolver o problema.

Para obter informações adicionais sobre a perda do código das macros ao guardar documentos num formato de ficheiro diferente, clique no número de artigo existente abaixo para visualizar o artigo na Microsoft Knowledge Base:
212387 WD2000: VBA Code Lost When Converting to Another File Format

Método 2: Copiar tudo, excepto a última marca de parágrafo, para um documento novo

O Word para Windows associa uma vasta gama de formatação à última marca de parágrafo, especialmente a formatação de secções e estilos. Se copiar tudo excepto a última marca de parágrafo para um documento novo, é possível que o problema seja resolvido. No documento novo, aplique novamente a formatação de secções ou de estilos.

NOTA: Pode seleccionar tudo excepto a última marca de parágrafo premindo as teclas CTRL+END e, em seguida, CTRL+SHIFT+HOME. Se o documento contiver quebras de secção, copie apenas o texto existente entre as quebras de secção (não copie e cole as quebras de secção porque poderá transferir o problema para o documento novo).

A Microsoft recomenda que trabalhe com o documento do Word na vista Normal quando copiar e colar entre documentos, para evitar a transferência de quebras de secção de um documento para o outro. Para mudar para a vista Normal, clique em Normal no menu Ver.

Método 3: Copiar as partes não danificadas do documento para um documento novo

Por vezes, é possível determinar a localização dos danos no documento. Nestes casos, copie tudo excepto a parte danificada para um ficheiro novo e, em seguida, reconstrua a secção danificada do documento.

NOTA: Se o documento contiver quebras de secção, copie apenas o texto existente entre as quebras de secção (não copie e cole as quebras de secção porque poderá transferir o problema para o documento novo).

A Microsoft recomenda que trabalhe com o documento do Word na vista Normal quando copiar e colar entre documentos, para evitar a transferência de quebras de secção de um documento para o outro. Para mudar para a vista Normal, clique em Normal no menu Ver.



Acções a tentar se não conseguir abrir o documento

Pode utilizar várias técnicas para tentar abrir um documento que não consegue abrir. O método que deve utilizar depende da natureza e da gravidade dos danos do seu documento, bem como da natureza do comportamento apresentado. Apesar de muitos destes métodos terem êxito regularmente, nem todos os documentos danificados podem ser recuperados.

Método 1: Abrir o documento do Word danificado no modo de rascunho sem actualizar as ligações

Por vezes, um documento que não se consegue abrir de outro modo pode ser aberto em modo de rascunho sem actualização das ligações. Para o fazer, siga estes passos:
  1. No menu Ver, clique em Normal.
  2. No menu Ferramentas, clique em Opções.
  3. No separador Ver, seleccione as caixas de verificação Tipo de letra de rascunho e Marcadores de posição p/ imagens.
  4. No separador Geral, clique para desmarcar a caixa de verificação Actualizar ligações automaticamente ao abrir e, em seguida, clique em OK.
Se conseguir abrir o documento, poderá conseguir recuperar ou corrigir o ficheiro utilizando os passos descritos na secção Acções a tentar se o documento abrir mas apresentar um comportamento inesperado deste artigo.

Método 2: Inserir o documento como ficheiro num documento novo

A última marca de parágrafo de um documento do Word contém informações sobre o documento. Se o documento estiver danificado, poderá conseguir recuperar o texto deste se omitir esta última marca de parágrafo.

Para aceder a um documento mas não copiar a última marca de parágrafo, utilize os seguintes passos:
  1. No menu Ficheiro, clique em Novo.
  2. No separador Geral, clique para seleccionar Documento vazio e clique em OK.
  3. No menu Inserir, clique em Ficheiro.
  4. Na caixa de diálogo Inserir ficheiro, localize e seleccione o documento danificado e clique em Inserir.
NOTA: Poderá ter de aplicar novamente alguma formatação à última secção do novo documento.

Método 3: Abrir o ficheiro criando uma ligação a este

Se o método 2 (inserir o documento como ficheiro num documento novo) não resultar, experimente este método.

Este método pode permitir-lhe abrir o ficheiro se uma parte do cabeçalho do ficheiro ou a marca de parágrafo estiver na área danificada do ficheiro.

Utilize os seguintes passos para ligar a um ficheiro não danificado e, em seguida, alterar a ligação para referenciar o ficheiro danificado:
  1. No menu Ficheiro, clique em Novo.
  2. No separador Geral, clique em Documento vazio e clique em OK.
  3. No novo documento, escreva Isto é um teste e, em seguida, guarde o documento.
  4. Seleccione o texto e clique em Copiar no menu Editar.
  5. No menu Ficheiro, clique em Novo.
  6. No separador Geral, clique em Documento vazio e clique em OK.
  7. Neste novo documento, clique em Colar especial no menu Editar.
  8. Seleccione Texto formatado, clique para seleccionar Colar ligação e, em seguida, clique em OK.
  9. No menu Editar, clique em Ligações.
  10. Na caixa de diálogo Ligações, seleccione o nome do ficheiro do documento ligado e clique em Alterar origem.
  11. Na caixa de diálogo Alterar origem, seleccione o documento que não consegue abrir e clique em Abrir.
  12. Clique em OK para fechar a caixa de diálogo Ligações.

    NOTA: As informações existentes no documento danificado devem ser apresentadas (desde que existam dados ou texto recuperável).
  13. No menu Editar, clique em Ligações.
  14. Na caixa de diálogo Ligações, clique em Romper ligação. Se lhe for apresentada a seguinte mensagem, clique em Sim.
    Tem a certeza de que deseja romper as ligações seleccionadas?
Agora, pode reformatar e guardar o documento recuperado.

Método 4: Utilizar o conversor 'Recuperar texto de qualquer ficheiro'

O conversor Recuperar texto de qualquer ficheiro permite-lhe extrair o texto a partir de qualquer ficheiro. O ficheiro não tem de ser um ficheiro do Word. A utilização do conversor Recuperar texto de qualquer ficheiro tem as suas limitações. A formatação do documento é perdida, juntamente com tudo aquilo que não seja texto. Os gráficos, os campos e os objectos de desenho, entre outros, são perdidos. No entanto, os cabeçalhos, os rodapés, as notas de rodapé, as notas de fim e os campos de texto são mantidos como texto simples.

Para além disso, após o documento ser recuperado através da utilização de Recuperar texto de qualquer ficheiro, existirão alguns dados binários que não foi possível converter, principalmente no início e no fim do documento. Tem de eliminar estes dados binários antes de reformatar e guardar o ficheiro como documento do Word.

Para obter informações adicionais sobre como utilizar o conversor Recuperar texto de qualquer ficheiro, clique no número de artigo existente abaixo para visualizar o artigo na Microsoft Knowledge Base:
212274WD2000: Como recuperar texto a partir de qualquer ficheiro

Método 5: Abrir o ficheiro no WordPad

Quando não consegue abrir um documento danificado no Word para Windows (normalmente devido à existência de danos no cabeçalho do ficheiro), pode excluir o cabeçalho do ficheiro e abrir o ficheiro como texto. Quando exclui as informações do cabeçalho, toda a formatação é perdida. O método seguinte exclui as informações do cabeçalho do ficheiro.
  1. Inicie o Microsoft WordPad. No Windows, no menu Iniciar, aponte para Programas, aponte para Acessórios e, em seguida, clique em WordPad.
  2. No menu Ficheiro, clique em Abrir e abra o documento do Word danificado.

    O documento do Word deve ser aberto como ficheiro de texto. Poderão existir caracteres binários (caracteres estranhos) no início e no fim do documento. Pode eliminar estes caracteres, bem como quaisquer outros caracteres que não pertençam ao documento do Word danificado.
  3. No menu Ficheiro, clique em Guardar como. Na caixa Nome do ficheiro, escreva um novo nome de ficheiro com uma extensão .doc. Antes de clicar no botão OK, anote a pasta onde o ficheiro está a ser guardado, para o poder encontrar mais facilmente quando reiniciar o Word.
  4. No menu Ficheiro, clique em Sair.
  5. Reinicie o Word e abra o documento que guardou no WordPad (o ficheiro terá o nome que lhe deu no passo 3).
  6. No menu Ficheiro, clique em Guardar como e guarde o ficheiro no formato Documento do Word (*.doc).
Agora, poderá reformatar o novo documento e adicionar os gráficos, campos e outra formatação contida no documento danificado.



Opções de suporte da Microsoft

Se não conseguir resolver este problema, estão à sua disposição várias opções de suporte para o ajudar.

Localizar rapidamente as respostas online

Utilize o Microsoft Personal Online Support para pesquisar a Microsoft Knowledge Base e outros recursos técnicos, para obter respostas rápidas e exactas. Também pode personalizar o site de modo a controlar a sua pesquisa.

Para iniciar a sua pesquisa, visite o seguinte endereço Web:
http://support.microsoft.com/support/

Suporte técnico da Microsoft

Contacte um profissional de suporte técnico da Microsoft para o ajudar nos procedimentos de resolução de problemas.

Para obter mais informações sobre como obter ajuda para a resolução de problemas do Microsoft Windows, clique em Tópicos de ajuda no menu Ajuda do Explorador do Windows. No separador Índice clique duas vezes para abrir o livro Resolução de problemas . Em seguida, clique duas vezes para abrir o livro Contactar o suporte técnico da Microsoft para ver as opções de suporte que tem à sua disposição.

Para obter mais informações sobre como obter ajuda para a resolução de problemas do Microsoft Word, clique em Acerca do Microsoft Word no menu Ajuda e, em seguida, clique em Suporte técnico.

Para obter informações adicionais sobre os serviços de suporte da Microsoft, clique no número de artigo existente abaixo para visualizar o artigo na Microsoft Knowledge Base:
102344 Microsoft Product Support Options Q&A

Microsoft Solution Providers

Os Microsoft Solution Providers são organizações independentes que se associaram à Microsoft para utilizarem a tecnologia com o fim de resolver os problemas comerciais de empresas de todos os tamanhos e áreas.

Para localizar um Microsoft Solution Provider na sua área, contacte a subsidiária local da Microsoft. Para localizar a sua subsidiária, visite o Web site Microsoft World Wide Offices em:
http://www.microsoft.com/worldwide/default.aspx

Propriedades

Artigo: 211634 - Última revisão: 25 de outubro de 2006 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbdta kbtshoot wd2000 KB211634

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com